Gettext override translations

Descripción

Te permite sustituir textos por defecto desde tu panel de administración.
Creado originalmente para sustituir textos de Woocommerce, pero también funciona para casi cualquier texto añadido por WordPress y plugins.

Traducirá todas las llamadas de cadenas _e(») o __(»), así que revisa el código fuente PHP del plugin o tema que necesitas traducir.

NO traduce cadenas dinámicas como %s o %d, así que «%s se ha añadido a tu carrito.» no se puede traducir.

Algunos ejemplos de WooCommerce:
WooCommerce «Select option» (dropdown value) setting
Fullscreen Screenshot 3
WooCommerce «Select option» (dropdown value) translation result
Fullscreen Screenshot 4
WooCommerce «Order notes» setting
Fullscreen Screenshot 5
WooCommerce «Order notes» translation result
Fullscreen Screenshot 6

Programado por: MijnPress.nl Perfil en Twitter Más plugins

Capturas

Instalación

  1. Upload directory Gettext override translations to the /wp-content/plugins/ directory
  2. Activate the plugin through the ‘Plugins’ menu in WordPress.
  3. Click settings in your plugin list (or visit plugin submenu)
  4. You are ready to go!

FAQ

How does this plugin work?

It uses a gettext WordPress filter

I have a lot of questions and I want support where can I go?

http://pluginsupport.mijnpress.nl/ or drop me a tweet to notify me of your support topic over here.
I always check my tweets, so mention my name with @ramonfincken and your problem.

Reseñas

12 de marzo de 2022
Hi, really like the plugin, but I think it's weird to have it located in the plugins submenu of the WordPress menu. Maybe it's better to move it to tools/settings submenu? Keep up the good work!
10 de junio de 2021
I'm so happy to found this plugin! It just works perfectly! Thank you! It looks a bit buggy, but only visually, and it's not the problem at all to me. This image .../wp-content/plugins/gettext-override-translations/img/delete.png is in the wrong place. Delete image "X" is below the "Original (translated) text", so all text fields are moved to one place on the right side. Noobs will be confused, so will be best to fix that. Maybe to relocate the delete button next to the checkbox "protect settings". I hope I explained the problem understandable. Thanks again!
24 de febrero de 2017
After trying several other alternatives which took me hours of testing and getting frustrated, this little plugin simply works! At least in woocommerce, others I have not tried. Thanks for this and keep up the good work.
3 de septiembre de 2016
In a WooCommerce shop for one of my customers I edited the .po file to change the default text into a more informal text. With every WooCommerce update the changes were gone and I needed to upload the files again. With this plugin I don't have to do that anymore. It's perfect if you want to translate / change (a few) strings in a plugin. Thank you!
Leer todas las 7 reseñas

Colaboradores y desarrolladores

«Gettext override translations» es un software de código abierto. Las siguientes personas han colaborado con este plugin.

Colaboradores

Traduce «Gettext override translations» a tu idioma.

¿Interesado en el desarrollo?

Revisa el código , echa un vistazo al repositorio SVN o suscríbete al registro de desarrollo por RSS.

Registro de cambios

1.0.1

Bugfix: Small PHP warning fixed

1.0.0

First public release