Glue para Yoast SEO & AMP

Descripción

Google está trabajando actualmente en las «Accelerated Mobile Pages» o proyecto AMP. El plugin WordPress AMP ofrece una implementación técnica de las especificaciones AMP. Esto asegura que tus páginas contengan código AMP válido.

El plugin Yoast SEO: AMP Glue integra Yoast SEO en tus páginas AMP. Se asegura que tus metadatos se incorporen correctamente.

Además de las mejoras técnicas de SEO, el plugin Yoast SEO: AMP Glue tambié ofrece un modo sencillo de personalizar tus páginas AMP.
Añade estilos básicos en forma de colores y estilos de enlaces, para que tus páginas AMP puedan mantener el aspecto que tienen tus páginas principales.
Para cambiar el diseño de tus páginas AMP ve a SEO -> AMP y echa un vistazo a la pestaña de diseño.

Capturas

  • Ejemplo de página AMP, con el diseño cambiado con este plugin.
  • Compatibilidad con tipos de contenido en el plugin.
  • Ajustes de diseño del plugin.

Instalación

  1. Sube los archivos del plugin al directorio /wp-content/plugins/yoast-seo-amp, o instala el plugin directamente desde la pantalla de plugins de WordPress.
  2. Activa el plugin desde la pantalla de ‘Plugins’ de WordPress
  3. Ve a SEO -> AMP para cambiar tu diseño y activar la compatibilidad con tipos de contenido personalizados.
  4. Ya está.

Reseñas

9 de mayo de 2019
1. The plugin is outdated and only applies to the basic version of AMP which is now called Reader or Classic. 2.The plugin needs updating inline with the three methods of serving AMP using the official AMP plugin, which are Native, Transitional and Reader. (Basic AMP has different icon requirements, for example, the small round icon.) 3. It would surely make more sense to incorporate this plugin with Yoast as a feature, rather than have a separate plugin? 4. Including the AMP publisher logo would help cover all the bases, as currently the plugin isn't as useful as it should be. It's doing half a job! 5. Taking the above into consideration, the plugin isn't that helpful and a few tweaks would see a vast improvement and lessen the likelihood of notifications from Google Search Console for error in required structured data markup, etc. Google is much stricter with AMP requirements so Yoast will be doing people a favor if they take some time out to bring this plugin up to date.
26 de noviembre de 2018
automaticc amp plugin is enough, this plugin does not give any extra function expect backling to yoast

bad

26 de octubre de 2018
related posts not appear.. google ads not appear in AMP pages very simple design and edit AMP page plz update your plugin
3 de mayo de 2018
Not compatible with version 0.7 of AMP plugin. Had to struggle for a few minutes when the AMP plugin did not work after updating to version 0.7. Later, I tried deactivating this glue and AMP started working. This one needs an urgent update.
Leer todas las 25 reseñas

Colaboradores y desarrolladores

«Glue para Yoast SEO & AMP» es un software de código abierto. Las siguientes personas han colaborado con este plugin.

Colaboradores

«Glue para Yoast SEO & AMP» ha sido traducido a 8 idiomas locales. Gracias a los traductores por sus contribuciones.

Traduce «Glue para Yoast SEO & AMP» a tu idioma.

¿Interesado en el desarrollo?

Revisa el código , echa un vistazo al repositorio SVN o suscríbete al registro de desarrollo por RSS.

Registro de cambios

0.5

  • Bugfixes:

    • Fixes a problem where the AMP icon and Default image could not be unset when Yoast SEO 9.0+ has been installed.
  • Enhancements:

0.4.3

  • Bugfixes:
    • Fixes a fatal error in combination with AMP for WordPress version 0.7.0. Props Ryan Kienstra.

0.4.2

  • Bugfixes:
    • Reverts the canonical removal.

0.4.1

  • Bugfixes:
    • Fix styling of design tab.

0.4.0

  • Bugfixes:

    • Removed page from post-type list to avoid unwanted canonical link.
  • Enhancements:

    • Removed canonical feature because it is being handled by the AMP plugin.
    • Removed sanitizations which are already being done by the AMP plugin.
    • Added a check for Monster Insights analytics implementation and disables our implementation if present.
    • Added class selector implementation for AMP 0.4.x compatibility.

0.3.3

  • Bugfixes:
    • Fixes bug where AMP was only activated for the first post type in the list.
    • Made sure that the function is not declared multiple times.

0.3.2

  • Bugfixes:
    • Fixed underline setting that wasn’t working.
    • Added screenshots to plugin page.

0.3.1

  • Bugfixes:
    • Fixed bug where featured image wouldn’t be used properly anymore.
    • Fixed bug where CSS in Extra CSS field could be wrongly escaped.
    • Fixed bug where wrong hook was used to add_post_type_support, causing integration issues.
    • Fixed bug where post type settings wouldn’t save properly.
  • Enhancement:
    • Added some more escaping to color picker functionality.
    • Made sure no notice is thrown on frontend when post type setting isn’t available.

0.3

  • Split the plugin into several classes.
  • Added a settings page, found under SEO -> AMP
  • This new settings page has:
    • A post types settings tab;
    • A design settings tab;
    • An analytics integration tab.
  • Added sanitization functions that further clean up AMP output to make sure more pages pass validation.
  • Added a default image (settable on the design tab) to use when a post has no image. This because the image in the JSON+LD output is required by Google.
  • The plugin now automatically enables AMP GA tracking when GA by Yoast is enabled, but also allows you to add custom tracking.

0.1

  • Initial version.