Este plugin no se ha probado con las últimas 3 versiones mayores de WordPress. Puede que ya no tenga soporte ni lo mantenga nadie, o puede que tenga problemas de compatibilidad cuando se usa con las versiones más recientes de WordPress.

TinyMCE Valid Elements

Descripción

By default, WordPress’ WYSIWYG editor, TinyMCE, will strip out of your Article and Page HTML code any
elements that are not defined as «valid elements»; this can be extremely annoying (especially if
you want to include iframes).

This plugin will allow you to extend what TinyMCE defines as «valid elements». By doing so,
TinyMCE will no longer remove, delete, or strip-out the additional elements and attributes
that you specify.

** NOTE: Make sure after you add elements or attributes you do a hard refresh (ctrl + F5) of
your browser on a _TinyMCE screen *(editing or creating a page/post)* so that the TinyMCE cache
will be refreshed! You will not see your changes until you do this!

Capturas

  • Plugin screenshot. Make sure to read the Help at the bottom of the page after installation!

Instalación

  1. Upload the tinymce_valid_elements/ directory and its contents to the /wp-content/plugins/ directory
  2. Activate the plugin through the ‘Plugins’ menu in WordPress
  3. Go to Manage -> TinyMCE Valid Elements and add some elements and attributes.

Read the Help Section at the bottom of the management page.

FAQ

I added new elements/attributes, why is TinyMCE still stripping it out?

Most likely, you need to do a hard refresh of your browser (ctrl + F5). Your JavaScript cache needs to be
refreshed.

Reseñas

No hay reseñas para este plugin.

Colaboradores y desarrolladores

«TinyMCE Valid Elements» es un software de código abierto. Las siguientes personas han colaborado con este plugin.

Colaboradores

Traduce «TinyMCE Valid Elements» a tu idioma.

¿Interesado en el desarrollo?

Revisa el código , echa un vistazo al repositorio SVN o suscríbete al registro de desarrollo por RSS.