Soporte » Plugins y Hacks » WooCommerce » 2 problemas con mi woocommerce

  • Buenos días,

    Estoy poniendo en marcha una tienda online de mi negocio (carniceria) y hay 2 problemas que me tienen desesperado.

    El 1º es que solo sale en Google con el título de uno de mis productos y debajo el siguiente mensaje: No hay disponible una descripción de este resultado debido al archivo robots.txt de este sitio. Más información.

    El 2º es que cuando introduzco un código dentro del editor,guardo los cambios, se ven dentro del modo administrador pero cuando salgo de él, lo cambios no se ven.

    Algún gran experto que me pudiera ayudar. Lo agradecería enormemente.

    Muchas gracias!

    ‘www.carniceriarodriguez.es’

    • Este debate fue modificado hace 1 semana, 2 días por  Fernando Tellado. Razón: Movido al foro adecuado
Viendo 2 respuestas - 1 de 2 (de 2 total)
  • Moderador Mariano Perez

    (@mpcdigital)

    Respecto a lo primero, el archivo robots.txt es un archivo de texto que dicta unas recomendaciones para que todos los crawlers y robots de buscadores cumplan. Aquí información sobre eso: http://www.emezeta.com/articulos/robots-txt-todo-lo-que-deberia-saber

    Respecto a lo segundo, ¿qué clase de código escribes en el editor? Si son shortcodes intenta no ponerlos en el editor visual.

    Buenos días Mariano,

    Lo primero agradecerte que me hayas contestado tan rápido.

    El código es este: y lo pongo en el editor de «funciones del tema».

    add_filter( 'woocommerce_package_rates', 'ocultar_otros_envios', 10, 2 );
    
    // Oculta otros tipos de envío cuando el envío gratuito está disponible
    function ocultar_otros_envios( $rates, $package ) {
        if ( isset( $rates['free_shipping'] ) ) {
    
            // Deshabilita todos los métodos de envío activos, excepto el envío gratuito.
      	$free_shipping          = $rates['free_shipping'];
      	$rates                  = array();
      	$rates['free_shipping'] = $free_shipping;
        }
    
        return $rates;
    }

    La cuestión es que dentro del modo administrador, funciona sin problema. Pero cuando salgo y pruebo desde cualquier otro navegador, ordenador, etc. No se ven los cambios.

    • Esta respuesta fue modificada hace 1 semana, 2 días por  Fernando Tellado. Razón: Etiquetado correcto del código
Viendo 2 respuestas - 1 de 2 (de 2 total)
  • El debate ‘2 problemas con mi woocommerce’ está cerrado a nuevas respuestas.