Soporte » Instalación – Actualizaciones » Actual. a 4.6 No se ven las fotos

  • Acabo de actualizar a wordpress 4.6 español y algunas fotos han dejado de verse. Subo una foto por media y si la que muestro en la entrada es la original ¡, no se ve, en cambio, las que genera wp en otros tamaños si que se ven. Si fuera solo con las nuevas es un problema menor, pero las que ya estaban subidas han dejado de verse. Si copio la URL de la imagen e intento verla fuera del blog, tampoco se ve, da error 500. Es realmente extraño. Accedo por ftp y el fichero existe, el nombre es correcto. Desde el ftp copio la imagen a mi portátil. Borro la original en la carpeta de uploads. Vuelvo a subir la misma imagen… y ya se ve perfectamente…. ¿Alguna idea de como no hacerlo a mano o si van a sacar una actualización para arreglar este poltergeist?

Viendo 15 respuestas - de la 1 a la 15 (de un total de 15)
  • Moderador almendron

    (@almendron)

    Es extraño que te de un error 500 cuando copia-pegas la URL de la imagen. Eso podría indicar que no es un problema de WordPress sino de tu servidor.
    De todas formas, sigue los pasos básicos:
    1) Activa debug: https://codex.wordpress.org/es:Depurar_en_WordPress
    2) Desactiva plugins
    3) Cambia de tema

    Iniciador del debate kdweb

    (@kdweb)

    Si, es extraño y me ha despistado mucho. He reiniciado servidor y comprobado actualizaciones y seguía igual. Copio el fichero de imagen (que no se ve) a otra carpeta del wordpress y tecleando la url la veo bien. Si regrabo el fichero sigo sin ver la imagen. Si elimino el fichero y lo vuelvo a subir por FTP ya se ve bien. He probado con varios temas y con todos pasa lo mismo. Solo pasa con las fotos originales subidas a WP, thumbnails y otros tamaños se ven bien.

    Moderador almendron

    (@almendron)

    ¿Puedes poner la URL de alguna imagen que no se vea?
    ¿Has activado el depurador?

    Iniciador del debate kdweb

    (@kdweb)

    Disculpa por el retraso en responderte. Es un problema de permisos. El fichero original que subo desde WordPress no tiene los mismos permisos que los que genera automáticamente, por eso no se ven. He regenerado los permisos de la instalaciòn wordpress y ya se ven todas las imágenes, pero con las nuevas que subo sigo teniendo el mismo problema.

    Moderador almendron

    (@almendron)

    La verdad es que no se qué decirte. Reconozco que no tengo ni idea de porqué da ese error.
    ¿Almacenas por mes y año las imágenes?

    Iniciador del debate kdweb

    (@kdweb)

    Si, por mes y año, sin ningún problema hasta la actualización a la versión 4.6.

    Moderador almendron

    (@almendron)

    Prueba a quitarla. Hay otra persona que tiene un problema parecido al tuyo y también archiva por mes y año.

    Hola @kdweb ,

    ¿Has podido resolver tu problema?

    Es para darlo por solucionado y cerrar este tema.

    Gracias!

    Iniciador del debate kdweb

    (@kdweb)

    No. Con FTP me bajo la imagen original subida desde el gestor multimedia. La elimino del servidor. La vuelvo a subir y ya se ve correctamente. Los permisos del servidor están todos correctos y en otros blogs no actualizados funciona correctamente. Espero que en la próxima actualización del WP se arregle.

    Moderador LGrusin

    (@lgrusin)

    Igual hubo algún fallo en la actualización, en ese caso tendrás que hacerlo manualmente de nuevo.

    Antes prueba desactivando todos los plugins.

    Ya sé que esto no tiene nada que ver con los permisos pero ya le ha sucedido a alguien algo parecido.

    No me carga las imágenes, ni logos, ni nada.

    Un saludo

    Hola @kdweb,

    Estaría bien poder ver tu sitio para poder ayudarte mejor, si pones aquí la url lo vemos, y si indicas una url donde se vea claramente el problema tanto mejor.

    De todos modos, de la misma manera que se suele reiniciar el ordenador cuando todo falla, yo suelo actualizar los permalink, que no es más que entrar en esa sección de tu administrador y pulsar el guardar. Inténtalo y me cuentas.

    Saludos!

    Hola Almendron. Me puedes explicar en la lengua humana que significa
    1) Activa debug: https://codex.wordpress.org/es:Depurar_en_WordPress

    ???

    Perdona he visto el link…muchos textos técnicos, no soy ni desollador software ni siquiera usuario avanzado de rollo html code

    Moderador almendron

    (@almendron)

    Significa lo siguiente:
    1) Editas el archivo wp-config.php
    2) Buscas la línea define('WP_DEBUG', false);. Si está tal cual, pones true en lugar de false. Si está true, lo dejas. Si no está la línea, la añades poniendo true.
    3) Una vez activada, te aparecerán en pantalla todos los errores, avisos y noticias de PHP.

    Muchas gracias. Ahora esta entendido

    Un Cordial Saludo

    Moderador almendron

    (@almendron)

    De nada. Un saludo.

Viendo 15 respuestas - de la 1 a la 15 (de un total de 15)
  • El debate ‘Actual. a 4.6 No se ven las fotos’ está cerrado a nuevas respuestas.