• Se me actualizó solo woocommerce a la versión 8.7 y a la mañana siguiente no podía entrar en el admin, encontramos que el error venía del plugin woocommerce y lo desactivamos para poder entrar en el admin pero claro, ahora la página web se ve a medias y no hay opción ni de ver productos ni de comprar claro.

    El error que me manda wordpress por mail es este:

    Se ha producido un error del tipo E_COMPILE_ERROR en la línea 89 del archivo /homepages/34/d900973067/htdocs/madreindiaeses/shop/wp-content/plugins/jetpack/vendor/jetpack-autoloader/class-version-loader.php. Mensaje de error: require_once(): Failed opening required ‘/homepages/34/d900973067/htdocs/madreindiaeses/shop/wp-content/plugins/_woocommerce/src/StoreApi/deprecated.php’ (include_path=’.:/usr/lib/php7.4′)

    No tengo idea de cómo solucionar esto,

    ¿Me pueden ayudar?

    Gracias!

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • Hola,

    Parece un error de compatibilidad de Woocommerce y el plugin Jetpack.

    Intenta desactivar el plugin Jetpack para ver si se soluciona el problema.

    Un saludo!

    Iniciador del debate madreindia

    (@madreindia)

    Hola,
    Desactivé jetpack y cuando intento activar woocommerce me salta de nuevo a la página con este mensaje:

    Ha habido un error crítico en esta web. Por favor, comprueba la bandeja de entrada del correo electrónico del administrador de tu sitio para obtener instrucciones.

    Aprende más sobre el diagnóstico de WordPress.

    Hola,
    Puedes intentar activar el DEBUG en tu WordPress para ver exactamente el error que es.
    Puede que sea compatibilidad con la versión de PHP que tienes en tu servidor.

    Iniciador del debate madreindia

    (@madreindia)

    Después de varios intentos, parece que al desactivar ahora jetpack, woocommerce quiere activarse pero hay una nota que advierte lo siguiente:

    Warning: require(/homepages/34/d900973067/htdocs/madreindiaeses/shop/wp-content/plugins/woocommerce/src/Autoloader.php): Failed to open stream: No such file or directory in /homepages/34/d900973067/htdocs/madreindiaeses/shop/wp-content/plugins/woocommerce/woocommerce.php on line 30

    Fatal error: Uncaught Error: Failed opening required ‘/homepages/34/d900973067/htdocs/madreindiaeses/shop/wp-content/plugins/woocommerce/src/Autoloader.php’ (include_path=’/homepages/34/d900973067/htdocs/madreindiaeses/shop/wp-content/plugins/kirki/:/homepages/34/d900973067/htdocs/madreindiaeses/shop/wp-content/plugins/kirki/core:.:/usr/lib/php8.1′) in /homepages/34/d900973067/htdocs/madreindiaeses/shop/wp-content/plugins/woocommerce/woocommerce.php:30 Stack trace: #0 /homepages/34/d900973067/htdocs/madreindiaeses/shop/wp-admin/includes/plugin.php(2389): include_once() #1 /homepages/34/d900973067/htdocs/madreindiaeses/shop/wp-admin/plugins.php(194): plugin_sandbox_scrape() #2 {main} thrown in /homepages/34/d900973067/htdocs/madreindiaeses/shop/wp-content/plugins/woocommerce/woocommerce.php on line 30

    Actualice a php 8.1.
    Puede ayudar esta info para ver porqué sigue sin funcionar?
    Gracias,

    Hola,

    Por lo que veo en el mensaje de error, parece algún tipo de incompatibilidad con el plugin kirki que tienes instalado.

    Prueba a desactivar ese plugin e intentar volver a activar Woocommerce.

    Cuando hayas terminado, no olvides volver a a desactivar el DEBUG.

    Un saludo!

    Iniciador del debate madreindia

    (@madreindia)

    Buen dia,

    Gracias, descativé kirki y de nuevo aparece un error fatal, esta vez:

    Warning: require(/homepages/34/d900973067/htdocs/madreindiaeses/shop/wp-content/plugins/woocommerce/src/Autoloader.php): Failed to open stream: No such file or directory in /homepages/34/d900973067/htdocs/madreindiaeses/shop/wp-content/plugins/woocommerce/woocommerce.php on line 30

    Fatal error: Uncaught Error: Failed opening required ‘/homepages/34/d900973067/htdocs/madreindiaeses/shop/wp-content/plugins/woocommerce/src/Autoloader.php’ (include_path=’.:/usr/lib/php8.1′) in /homepages/34/d900973067/htdocs/madreindiaeses/shop/wp-content/plugins/woocommerce/woocommerce.php:30 Stack trace: #0 /homepages/34/d900973067/htdocs/madreindiaeses/shop/wp-admin/includes/plugin.php(2389): include_once() #1 /homepages/34/d900973067/htdocs/madreindiaeses/shop/wp-admin/plugins.php(194): plugin_sandbox_scrape() #2 {main} thrown in /homepages/34/d900973067/htdocs/madreindiaeses/shop/wp-content/plugins/woocommerce/woocommerce.php on line 30

    No hay manera de solucionar, he desactivado también todos los plugins relacioandos con woocommerce para ver si también ayudaba y nada.

    Gracias,

    Hola,

    Pues ya lo único que te queda es contactar con tu empresa de Hosting para ver si en los logs del servidor pueden encontrar alguna información.

    Un saludo!

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • Debes estar registrado para responder a este debate.