Soporte » Guías – Resolución de problemas » Actualización de Php en servidor

  • guilllemes

    (@guilllemes)


    Muy buenas a todos:
    Acabo de instalar WordPress en una sub carpeta (/new) de la vieja web y que se va reemplazar cuando terminemos la nueva pero me está saliendo el mensaje:
    «Your server is running PHP version 5.4.45 but WordPress 5.2.3
    requires at least 5.6.20.»

    Voy al Cpanel y me da la opción de actualizar el Php a la versión Php 7 o 7.1 pero lo que me preocupa es cargarme la web antigua (que NO está hecha en wordpress). Hay alguna manera de comprobar la compatibilidad ó puedo actualizar a la versión y si no funciona volver a la versión antigua de php? Algún consejo?
    Muchísimas gracias

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 5 respuestas - 1 de 5 (de 5 total)
  • rolozco

    (@rolozco)

    Algunos hosting permiten volver a la versión anterior de PHP después de actualizar. Pero la mejor solución sería llevarte la web antigua a un entorno de prueba (por ejemplo en local) con una versión de PHP actual y comprobar que todo funcione bien.

    Moderador LGrusin

    (@lgrusin)

    Si la web antigua no usa PHP porque está en HTML no debería afectarte mucho.

    Muchísimas gracias a los dos por las respuestas. En el hosting me sale una pestaña en la que puedo escoger tres versiones de Php: en la que está, la default 5.4 y las 7.0 y las 7.1, pareciera que da la opción a volver a una versión anterior.
    Si hago la prueba y resulta que no funciona, con solo volver a la versión anterior se soluciona todo?
    Gracias de nuevo,

    G

    Moderador LGrusin

    (@lgrusin)

    En teoría si. Lo mejor es que hagas copia de todo por lo que pudiera ocurrir.

    No entiendo por qué tu servidor únicamente dispone de esas versiones. De todas formas la versión de PHP recomendada es la 7.3.

    Gracias por la respuesta. Sí, ya he hecho copia de todo.haré el intento y ya os contaré. Saludos 😉

Viendo 5 respuestas - 1 de 5 (de 5 total)
  • Debes estar registrado para responder a este debate.