Soporte » Plugins y Hacks » WooCommerce » Actualización fallida woocommerce

  • Hola a todos y gracias por vuestra ayuda.
    Ya llevo un par de meses con este problema. Al actualizar Woocommerce 6.1.0 éste da un fallo de actualización y desaparece completamente de la web. Te quedas sin tienda, sin productos, nada. Desaparece directamente el plugin de Woocommerce.
    El cartel de aviso dice: Actualización fallida: <DOCTYPE html> servicio no disponible [504]servicio temporalmente no disponible.
    Mi solución hasta ahora es restaurar la web al día anterior y dejar pasar el tiempo, pero claro esto no está siendo una solución. Puesto que ya llevo desde el año pasado con este problema.
    Si me podéis echar un cable os lo agradecería.
    Un gran saludo a todos.

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • Moderador Jose Luis

    (@jose64)

    Hola.

    Bienvenido al foro de soporte. Deberías consultarlo con tu hosting, el error no lo produce WooCommerce, es una respuesta de error del servidor. Ahora mismo puedes hacer una actualización manual, descarga la última versión desde el repositorio, sube por FTP o usando el panel de administración de tu hosting a la carpeta /wp-content/plugins, borra la carpeta wp-contente/plugins/woocommerce y descomprime el archivo subido. De esta forma reemplazas la versión obsoleta (la que está en la carpeta original) por la nueva (la de la carpeta woocommerce que descomprimes de la descarga).

    Una vez hecho el cambio seguramente verás el mensaje de que necesitas actualizar la base de datos.

    Coméntanos si tienes alguna duda y, por favor, recuerda marcar el debate como resuelto, así nos ayudas a mantener el foro al día.

    Iniciador del debate mrsagaz

    (@mrsagaz)

    Hola José Luis, gracias por la ayuda.
    He hablado con mi Hosting y me comenta que el fallo se da porque entra en conflicto mi tema Divi con Woocommerce. Hay que ver la programación algo está «reventando» la actualización. Por lo cual no me recomienda tampoco hacerlo de forma manual sin solucionar el código.
    Gracias, seguiré contando.
    Un saludo.

    Moderador Jose Luis

    (@jose64)

    Hola.

    En las Instrucciones de uso de los foros tienes explicada, entre otras cosas, la forma correcta de hacer una consulta. Debes dar la url de la web para poder revisarla.

    Cambia DIVI por uno de los temas que instala WordPress por defecto, uno de los Twenty, y haz la prueba. Al margen de lo anterior, DIVI es compatible con WooCommerce.

    Quedamos a la espera de más información.

    Iniciador del debate mrsagaz

    (@mrsagaz)

    https://soysagaz.com/

    Gracias por la ayuda y disculpa la falta de información.

    Moderador Jose Luis

    (@jose64)

    Hola.

    ¿Hiciste la prueba cambiando DIVI por otro tema?

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • Debes estar registrado para responder a este debate.