• tvalades

    (@tvalades)


    Buenos días a tod@s. Espero que las vacaciones hayan ido bien y para los que todavía siguen mucho mejor.

    Estoy haciendo mantenimiento de mis webs para hacer actualizaciones y dejarlas todas a punto y con esta en concreto estoy teniendo problemas con la versión de jQuery. Tengo la versión 1.12.4 y estoy actualizando todos los sitios a la 3.5.1.

    El resto de páginas se han actualizado sin problemas o bien con el plugin jQuery Updater o bien por código en el functions.

    Con este ya he probado todo: el plugin, el código… Os pongo los códigos que he probado por si le queréis echar un vistazo
    Ya no se me ocurren más ideas

    function replace_core_jquery_version() {
        wp_deregister_script( 'jquery' );
        wp_register_script( 'jquery', "https://code.jquery.com/jquery-3.5.1.min.js", array(), '3.5.1' );
    }
    add_action( 'wp_enqueue_scripts', 'replace_core_jquery_version' );
    
    function replace_core_jquery_version() {
        wp_deregister_script( 'jquery-core' );
        wp_register_script( 'jquery-core', "https://code.jquery.com/jquery-3.5.1.min.js", array(), '3.5.1' );
        wp_deregister_script( 'jquery-migrate' );
        wp_register_script( 'jquery-migrate', "https://code.jquery.com/jquery-migrate-3.0.0.min.js", array(), '3.0.0' );
    }

    Se que no está actualizado a la versión 5.5 y que woocommerce tampoco está actualizado. Tengo que hacer unos cambios en la plantilla de woocommerce que realizaron en el padre y llevármela al hijo.

    Gracias de antemano!

    • Este debate fue modificado hace 4 semanas por Fernando Tellado. Razón: Etiquetado correcto del código

    La página con la que necesito ayuda: [accede para ver el enlace]

  • Debes estar registrado para responder a este debate.