• Buenas tardes. He migrado de hosting la web de la empresa en la que trabajo a Hostigar. Cuando se terminaron de propagar los DNS, quise crear una entrada en el blog y en ves de aparecer el botón de «Publicar», me sale «Enviar para Revisión». Lo mismo me pasa si quiero crear una tienda por ejemplo.

    He probado modificar los usuarios administradores desde Phpmyadmin y nada.

    He añadido un nuevo usuario administrador desde Phpmyadmin y este es capas de acceder a WordPress desde wp-admin pero no veo el escritorio, solo la barra superior.

    Me da la sensación que no se interpretan bien los permisos u roles de los de los Administradores.

    • Este debate fue modificado hace 1 año, 5 meses por jose64. Razón: Mover el debate al foro adecuado y añadir enlace de la web

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 3 respuestas - de la 1 a la 3 (de un total de 3)
  • Iniciador del debate DiegoAlves

    (@dsalvesp)

    No era mi intención duplicar debate. En mi perfil solo salía un debate de hace unos años. Muchas gracias

    Iniciador del debate DiegoAlves

    (@dsalvesp)

    El tema que utilizo es Salient, y el constructor es wpbakery, WordPress está actualizado a la última versión.

    He realizado varias pruebas:

    • He creado un usuario administrador nuevo y cuando voy a la lista de usuarios en ves de 4 que son lo habituales, me aparecen 5, pero el 5to que es el recién creado me aparece con todos los datos en blanco.
    • He actualizado el jQuery.
    • He utilizado el modo diagnóstico con todos los plugins desactivados menos el editor clásico y seguía igual, sin el editor no podía escribir.
    • He verificado los permisos ftp
    • He restaurado a las distintas versiones de las copias de seguridad diarias del hosting.
    • He probado distintas versiones de PHP siendo la 7.4 la maxima versión que no me da fallos.
    • He verificado las tablas user y meta user en phpmyadmin, y aunque no es mi especialidad php, si se me dan bien las bases de datos, y no termino de ver nada raro, pero puedo fallar.

    Hasta aquí todo igual, pero me pasaron dos cosas. Al activar el debug y el display no tengo errores de php en la 7.4. Pero al actualizar a la versión 8 por ejemplo, y volver nuevamente a la 7.4, comienzan a aparecer errores de php que antes no salían y todas las variables afectadas eran tipo create_post o create_meta, etc, cosas así.

    Otra cosa que me pasó fue que instalé un plugin, no recuerdo cual, para gestionar permisos, y en algunos aparecían vacíos o erróneos. Si pienso en base de datos, es como si los permisos que tienen los usuarios no existan como permisos en ninguna tabla. También puede ser tema de Roles.

    De verdad, cualquier ayuda me vendría genial. Muchas gracias.

    • Esta respuesta fue modificada hace 1 año, 5 meses por DiegoAlves.
    • Esta respuesta fue modificada hace 1 año, 5 meses por DiegoAlves.
    Moderador jose64

    (@jose64)

    Hola.

    Revisando tu web veo que estás usando una versión obsoleta del tema, tiene caso dos años (13.0.5) y la última versión (15.0.8) es de hace un mes. Deberías empezar por ahí porque junto con el tema te incluirá las versiones más recientes de los plugins que incluya.

    Los roles de los usuarios los puedes gestionar sin mayor dificultad usando, por ejemplo, el plugin User Role Editor, así puedes revisar tanto los tipos de usuario como las capacidades de cada usuario.

Viendo 3 respuestas - de la 1 a la 3 (de un total de 3)
  • El debate ‘Administradores no pueden crear entradas, ni tiendas tras una migración’ está cerrado a nuevas respuestas.