Soporte » Multisitio » Ajustes en multisitio

  • Buenos días,

    tengo un problema y no se como solucionarlo. Tengo dos multisitios: beuptocity.com y beuptocity.com/maps/maps que provienen de dos temas diferentes lynk y listopia (son de los mismos creadores y comparten muchas caracteristicas en comun).

    El problema viene porque cuando yo me meto en los ajustes (en la parte de arriba a la derecha de mi barra de wordpress) me encuentre en la pagina en la que me encuentre me redirige a los ajustes del tema dominante, de lynk en este caso, en lugar de ir a los ajustes del tema correspondiente.

    Lo que provoca esto es que pierda alguna de las funcionalidades del otro tema (listopia) ya que la gestión de favoritos es diferente para cada tema. En uno me tendría que dar mis posts favoritos (ya que lynk es un tema social) y en el otro mis locales favoritos (ya que listopia es un tema donde se buscan locales en un mapa).

    Se puede hacer esa division de alguna manera para que se vean ambos ajustes dependiendo de donde los llame?

    Muchas gracias de antemano y un saludo,
    Jaime

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 10 respuestas - 1 de 10 (de 10 total)
  • Moderador Fernando Tellado

    (@fernandot)

    Creo que el problema está en que entras con perfil de SuperAdmin y editas/modificas el tema globalmente. Deberías acceder como admin de cada sitio particular.

    Buenas tardes,

    he probado a entrar con mi usuario particular en la web (no superadmin) y me sigue redirigiendo a los ajustes del sitio principal (beuptocity) en vez de llevarme a los del sitio secundario (beuptocity/maps/maps).

    No se si te he entendido bien o tendría que modificar algo en el backend. Si quieres puedes probar a registrarte y comprobar lo que te comento.

    Un saludo y gracias,
    Jaime

    Moderador Fernando Tellado

    (@fernandot)

    Lo siento pero no tengo tanto tiempo, ahora me toca trabajar y que me paguen por ello, sino mi mujer me echa de casa.

    Yo revisaría qué tema tienes activo en el sitio principal y cuáles disponibles para el resto de sitios, así como si hay algún plugin que hace «cosas» con los ajustes de ambos sitios

    Gracias, a ver si alguien mas me puede comentar alguna otra idea porque eso ya lo he revisado pero nada…

    Moderador Jose Conti

    (@jconti)

    Hola,

    Si lo interpreto bien, puede que el problema esté en el theme en si, es decir, que esté capturando la url principal y no la url del sitio. Es un error típico en algunos desarrolladores que “empiezan” con WordPress.

    En los themes, no existe el “theme global”, a menos que esté utilizando las options de forma incorrecta.

    Cuando accedes a la configuración del theme, tienes una URL en el navegador. Añade a esa URL la parte del subsitio a ver qué sucede, y si accedes, a ver qué configuraciones ves.

    Si ves exactamente las configuraciones que tienes en el principal, hay un error de desarrollo y gordo.

    He hecho lo que pruebas y afortunadamente no pasa eso. En uno me dirige a uno y en el otro me da error 404 que la pagina no existe.

    No se como hacer que dependiendo en que subdominio esté, me lleve a la pagina de ajustes del subdominio que deberia ir. Adjunto dos pantallazos con la prueba que me has dicho.

    https://ibb.co/gGx5c8

    https://ibb.co/ccYNPo

    He hecho lo que pruebas y afortunadamente no pasa eso. En uno me dirige a uno y en el otro me da error 404 que la pagina no existe.

    No se como hacer que dependiendo en que subdominio esté, me lleve a la pagina de ajustes del subdominio que deberia ir.

    Veamos,
    Cuando dices que tienes dos multisitios, te refieres a que tienes una instalacion de WordPress y configurado para ser multisitios, correcto?

    Has desactivado todos los plugins y activado el theme predeterminado de tu version de WordPress en los «dos» sitios, para comprobar que no hay nada que modifique el admin bar o las redirecciones? Como dice @fernandot.

    Creo recordar que aun estando logueado como superadmin el link para los ajustes del theme deberia llevarte al theme del sitio actual.

    Perdona la desconfianza, pero estas seguro que el sitio maps/maps tienes activado el theme listopia?
    Dicho esto y por curiosidad porque la url que dices es maps/maps, yo veo mas logico un solo maps?

    Buenas, lo primero la url de la home del segundo tema era una errata, es beuptocity.com/maps (estaba haciendo una prueba).

    lo segundo, si, tengo una instalacion de wp congigurado para ser multisitio, en este caso dos direcciones y dos temas.

    Tengo cada tema instalado en cada url:

    beuptocity.com – lynk
    beuptocity.com/maps – listopia

    la forma de darme cuenta de que no veia el menu propio de listopia fue activar listopia en la url de beuptocity.com por eso abrí este post.

    He hecho lo de desactivar todos los plugins e ir activandolos, no he encontrado cual es el causante, pero tiene que estar la causa en alguno de los que tenia activados para toda la red (en lugar de activar en cada site el suyo).

    Lo único es que no se si ahora mis dos sites van a estar linkados y si se registra el usuario en uso podrá acceder al otro…

    Gracias y un saludo

    Moderador Jose Conti

    (@jconti)

    A ver,

    Así a primeras, no tiene ni pies ni cabeza lo que te sucede, a menos que la configuración del theme se realice mediante un plugin tipo option tree y lo hayas activado para la red, pero si la configuración va en el mismo theme, es virtualmente imposible que la configuración del theme te salga más allá de donde tengas activado el theme.

    Por favor, revisa los plugin a activados de la red, aparte de los activados sitio por sitio.

Viendo 10 respuestas - 1 de 10 (de 10 total)
  • El debate ‘Ajustes en multisitio’ está cerrado a nuevas respuestas.