Soporte » WordPress Avanzado » Añadir parámetros al menú

  • Resuelto xavi74

    (@xavi74)


    Tengo una web en castellano/catalán con el catalán por defecto con WooCommerce.
    El problema que tengo es que el menú no pasa el parámetro del idioma y cuando estoy en castellano cualquier opción de menú me enlaza bien, pero me pasa el menú a catalán porque no le puedo especificar que siga en castellano.
    He hecho una prueba y en el listado de cualquier categoría en castellano que me muestra el menú en catalán, si le añado a la URL &lang=es me muestra el menú en castellano (como debe ser).

    Después de todo este rollo me pregunto si existe alguna forma de añadirle al enlace de menú el &lang=es para que sepa que debe seguir mostrando el menú en castellano.

    Sé que podría hacer enlaces personalizados, pero no creo que sea la forma correcta y tengo muchos ítems de menú, debería hacerlo todo de nuevo.

    Gracias de antemano a quien pueda echarme una mano.

    • Este debate fue modificado hace 1 mes, 3 semanas por xavi74.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 6 respuestas - de la 1 a la 6 (de un total de 6)
  • ¿Estás usando algún plugin para gestionar la capacidad multilingüe de tu sitio?

    Si es así, ¿podrías decirnos cuál para intentar ayudarte mejor?

    Si no, por favor, dinos cómo estás manejando los distintos idiomas en tu sitio.

    Iniciador del debate xavi74

    (@xavi74)

    Uso polylang.

    Gracias por decirnos qué plugin estás utilizando, @xavi74:

    Polylang duplica las ubicaciones de menú por cada idioma activado. Por lo que tendrías que crear un nuevo menú para el español (repitiendo los pasos para cualquier idioma adicional que hayas activado en tu sitio), en Apariencia > Menú > Crear un nuevo menú y asignarlo a su ubicación correspondiente.

    Por ejemplo, si tu tema proporciona dos ubicaciones de menú, como las siguientes:

    • Menú principal
    • Menú secundario

    Luego de activar el español en tu sitio como idioma alternativo, deberías ver duplicados estos menús, con el nombre del idioma al final:

    • Menú principal Català
    • Menú principal Español
    • Menú secundario Català
    • Menú secundario Español
    Iniciador del debate xavi74

    (@xavi74)

    Es así como lo tengo pero como el idioma principal es el castellano cuando no paso el parámetro &lang=es coge el idioma principal, el catalán.

    Iniciador del debate xavi74

    (@xavi74)

    Ya lo tengo resulto.
    En el settings de Polylang, en URL Modifications se puede gestionar eso.

    Gracias igualmente.

    Hola, @xavi74:

    Qué bueno que descubriste dónde se estaba generando el problema 🙂

    …¡y gracias por compartir la solución!

Viendo 6 respuestas - de la 1 a la 6 (de un total de 6)
  • Debes estar registrado para responder a este debate.