Foros » Guías – Resolución de problemas » Aplicar css a una llamada meta

  • Resuelto primeratoma

    (@primeratoma)


    Hola,

    A ver si me podéis echar un cable, ya que he mirado por varios sitios y no he dado con la solución.

    Necesito mostrar un campo personalizado en la plantilla «single.php». Hasta aquí, lo he logrado, el problema viene que no me aplica el estilo css que debería.

    // Get theme Options
    $max_slider_posts = cs_getoption('theme_slidermax');
    
    get_header(); ?>
    
    	<div id="main" class="containerblock">
    
    		<div id="content_full">
    			<?php if (have_posts()) : $postcount = 0;
    					while (have_posts()) : the_post(); ?>
    
    						<div <?php post_class('singlepost'); ?> id="post-<?php the_ID(); ?>">
    		    				<?php the_category(); ?><div class="clearer"></div>
    
    		    				<h2 class="post_title"><?php the_title(); ?></h2>											
    
    						<div class=“tit”><?php echo get_post_meta($post->ID,'TITULAR',true); ?></div>
    
    						<div class="clearer"></div>
    
    						<div class="date">
    		    					Publicada el <?php the_time('l j, F Y'); ?>
    			    			</div>
    
    						<div class="entry">
    							<?php the_content(); ?>
    							</br>
    							</br>
                                <?php wp_pagenavi(); ?>
    							<center><?php wp_pagenavi( array( 'type' => 'multipart' ) ); ?></center>
    							</br>
    							</br>
    			    			</div>
    <p></p>
    <?php st_the_tags(); ?>
    <img class="linfin" src="http://www.primeratoma.com.es/wp-content/uploads/2014/07/linea_cabecera.jpg" alt="" width="918" height="7" />
    <p></p>
    						<?php if( function_exists ('ADDTOANY_SHARE_SAVE_KIT') ) { ADDTOANY_SHARE_SAVE_KIT(); } ?>
    
    		    				<div class="clearer"></div>
    </br>
    </br>
    <?php wp_related_posts()?>
    
    		    				<div class="clearer"></div>
    
    		    			</div>
    
    					<?
    
    					endwhile; 
    
    					rewind_posts();
    					if (have_posts()) : $postcount = 0;
    						while (have_posts()) : the_post();
    
    						comments_template(); 
    
    						endwhile;
    					endif;
    
    					?>
    
    					<div class="clearer"></div>
    
    			<?php else : ?>
    
    				<div class="post">
    		    		<div class="entry">
    						<h2 class="title"><?php echo $notfound_title; ?></h2>
    						<p><?php echo $notfound_text ?></p>
    					</div>
    				</div>
    
    			<?php endif; ?>
    
    		</div>
    
    		<div class="clearer"></div>
    
    	</div>
    
    	<?php get_footer(); ?>

    En concreto es la línea:

    <div class=“tit”><?php echo get_post_meta($post->ID,’TITULAR’,true); ?></div>

    El div class que hay al principio, lo ignora y me aplica el formato normal del texto de la entrada.

    ¿Alguien sabe por qué puede ser esto?

    Muchas gracias.

Viendo 1 respuesta (de un total de 1)
  • Iniciador del debate primeratoma

    (@primeratoma)

    Solucionado.
    El problema era que las comillas no eran las correctas, sino que era otro tipo de comillas.

Viendo 1 respuesta (de un total de 1)
  • El debate ‘Aplicar css a una llamada meta’ está cerrado a nuevas respuestas.