• Resuelto Alberto

    (@albert0deavila)


    Buenos días, estoy intentando reparar un error 500 y para ello he usado el depurador del wordpress que me de unas pistas, pero no se interpretarlo. Más o menos entiendo por el código que hay varios fallos porque me indica los archivos que son.

    ¿Alguien tiene algún tutorial para entender el siguiente código?

    Deprecated: Function create_function() is deprecated in /mnt/web102/e2/43/57679843/htdocs/wp-content/plugins/revslider/includes/framework/functions-wordpress.class.php on line 257 Deprecated: Function create_function() is deprecated in /mnt/web102/e2/43/57679843/htdocs/wp-includes/pomo/translations.php on line 208 Deprecated: Function create_function() is deprecated in /mnt/web102/e2/43/57679843/htdocs/wp-includes/pomo/translations.php on line 208 Deprecated: Function create_function() is deprecated in /mnt/web102/e2/43/57679843/htdocs/wp-includes/pomo/translations.php on line 208 Fatal error: Uncaught Error: Using $this when not in object context in /mnt/web102/e2/43/57679843/htdocs/wp-content/themes/the8/functions.php:3270 Stack trace: #0 /mnt/web102/e2/43/57679843/htdocs/wp-settings.php(387): include() #1 /mnt/web102/e2/43/57679843/htdocs/wp-config.php(89): require_once(‘/mnt/web102/e2/…’) #2 /mnt/web102/e2/43/57679843/htdocs/wp-load.php(39): require_once(‘/mnt/web102/e2/…’) #3 /mnt/web102/e2/43/57679843/htdocs/wp-blog-header.php(13): require_once(‘/mnt/web102/e2/…’) #4 /mnt/web102/e2/43/57679843/htdocs/index.php(17): require(‘/mnt/web102/e2/…’) #5 {main} thrown in /mnt/web102/e2/43/57679843/htdocs/wp-content/themes/the8/functions.php on line 3270

    Gracias de antemano!!

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 4 respuestas - de la 1 a la 4 (de un total de 4)
  • Moderador LGrusin

    (@lgrusin)

    En esto hay que emplear un poco la lógica.
    Deprecated – La función que utiliza es obsoleta
    require_once – Se necesita el archivo y no se encuentra por algún motivo
    El resto son errores por posiblemente usar una versión de PHP inferior.

    Las preguntas son las de siempre, ¿están actualizado WordPress, plugins y tema a sus últimas versiones?. ¿Usas la versión 7.3 de PHP? ¿son compatibles los plugins entre si?

    Por cierto, el error 500 no tiene por qué deberse a problemas de código exclusivamente. Puede ser debido a mala configuración o pocos recursos de servidor.

    • Esta respuesta fue modificada hace 5 años, 1 mes por LGrusin.
    Moderador kallookoo

    (@kallookoo)

    Hola @albert0deavila

    Tienes varios problemas pero todos se solucionan si actualizases tu sitio web.
    En algun momento tu hosting actualizo la version de PHP y al no tenerlo actualizado te estan dando esos problemas.

    Iniciador del debate Alberto

    (@albert0deavila)

    Lo primero de todo gracias a ambos por la info.
    @kallookoo creo que el fallo principal ha sido actualizar la versión php antes que el wordpress, plugins y el theme. Actualmente estoy actualizando el theme y el wordpress manualmente.

    Iniciador del debate Alberto

    (@albert0deavila)

    Ya he arreglado el error 500. Efectivamente fue la actualización del php. La solución: actualizar el wordpress y theme vía ftp y posteriormente los plugins.

    Muchas gracias @kallookoo y @lgrusin

Viendo 4 respuestas - de la 1 a la 4 (de un total de 4)
  • El debate ‘Aprendiendo a usar el depurador de wordpress’ está cerrado a nuevas respuestas.