Soporte » Plugins y Hacks » BuddyPress » BuddyPress

  • Hola. Necesito ayuda para configurar el BuddyPress. No tengo idea de como se hace. Cuando activo el plugin me dice: BuddyPress is almost ready. You must update your permalink structure to something other than the default for it to work.. Se que tengo que actualizar los enlaces permanentes pero no se que significa esto.

Viendo 10 respuestas - de la 1 a la 10 (de un total de 10)
  • Hola Peter, los enlaces permanentes son los que hacen que las rutas o urls de las páginas no tengan códigos raros, sino los nombres de los posts, etc. por ejemplo, en lugar de tener la siguiente ruta:

    http://tupaginaweb.com/?p=123

    automáticamente WordPress la cambiará por:

    http://tupaginaweb.com/titulo-del-post/

    Así que para actualizar la estructura de permalinks, ve en el panel de administración a: Apariencia -> Enlaces Permanentes y elije la opción que prefieras.

    Buenos días. A mí me sucede lo siguiente: instalo wordpress 3.1.1 , instalo buddypress 1.2.8, y pongo los enlaces permanentes de cualquier manera que no son los por defecto. Entonces intento moverme por los enlaces de mi web (por ejemplo «http://127.0.0.1/wp_bp2/2011/04/29/hola-mundo/»), y ya me da un error de página. Con los enlaces por defecto, a la página que se accedía era «http://127.0.0.1/wp_bp2/?p=1»

    Si intento acceder a «http://127.0.0.1/wp_bp2/activity/» también me da error.

    La verdad es que no sé qué estoy haciendo mal, porque los pasos que sigo son los típicos explicados en todas las webs (creo).

    Saludos!

    Iniciador del debate Peter Lake

    (@peter-lake)

    Eso de que son los enlaces permanentes yo lo entiendo bien. lo que no entiendo es cual es la configuración del enlace permantente que tengo que poner para que el buddypress me funcione ? porque cualquiera que ponga cuando intento entrar por ejemplo a la opcion de miembros (members) me sale The requested URL /bp/members/ was not found on this server. tengo entendido que esa carpeta no existe. Es problema de los enlaces permanentes. Que tendría que hacer para que funcione correctamente ?? en cuanto a lo que dice Jokin WordPress a mi pasa también. gracias.

    Peter, yo ya lo he conseguido.

    El problema viene a que los enlaces permanentes no son aceptados por tu servidor de internet. Es decir, WordPress está bien configurado, pero no el servidor.

    Yo tenía en mi equipo Wamp y Xampp, en Wamp no me funcionaba pero en Xampp sí, así que no es problema de WordPress.

    Existen muchas páginas para hacer que funcione, habilitando mod-rewrite, modificando htaccess…

    Para empezar, Peter, qué utilizas? IIS? ubuntu? Dime y trataré de ayudarte, que yo lo tengo fresco…

    Iniciador del debate Peter Lake

    (@peter-lake)

    Por lo que veo uno de los problemas es ese. que no tengo internet como tal. estoy montando eso en una PC para una red interna. para una red LAN aqui donde estoy. yo uso el Windows XP. y el servidor lo tengo montado en appserver 2.2. es obligado tener acceso a internet para poder usar el buddypress ?? que pasa entonces ?? el buddypress debe tener acceso a su página de internet ?? gracias por tu ayuda.

    No, da igual que tengas acceso a internet o no, pero debes configurar bien appserver (doy por hecho que wordpress te funciona correctamente, ¿no?) para que admita los enlaces permanantes requeridos por BuddyPress.

    El siguiente ejemplo (yo no lo he probado, no tengo appserver)

    Rewriting en WordPress en AppServer para Windows

    Por ahí debe estar la solución. Simplemente busca en google appserver enlaces permanentes y hay un montón de páginas con información para cómo habilitarlo.

    Espero que te sirva. Saludos!

    Iniciador del debate Peter Lake

    (@peter-lake)

    El WordPress si me funciona bien. Es que hay un problema grabe. yo no tengo internet. Ni siquiera al google. Dependo de un servidor proxy. Con esto quiero decirte que a esa dirección que me diste no puedo entrar. solo tengo nabegación nacional y a dos o tres páginas de internet como a esta del wordpress. si ubiera una forma de que me dejaras llegar la ayuda para hacer eso te lo agradecería.

    Iniciador del debate Peter Lake

    (@peter-lake)

    Ya instalé el Xamp pero sigo teniendo el mismo problema. Al parecer hay algo que no estoy haciendo bien.

    Hola Peter, el problema que te está ocurriendo es seguramente debido a lo que te ha dicho Jokin, un problema de configuración del seridor local. Ya que no tienes acceso a internet, te transcribo lo que viene en la página que te indicaba Jokin más arriba:

    «Rewriting en WordPress en AppServer para Windows

    1. Abrir con un editor (mejor si es de programación) el archivo httpd.conf
    Este archivo de Apache se encuentra en una ruta similar a la siguiente en AppServer:
    C:\AppServ\Apache2.2\conf\Apache2.2\ puede variar dependiendo de la versión que instaleos.

    2. Activar rewritting:
    #LoadModule rewrite_module modules/mod_rewrite.so

    (El caracter # es un comentario, por lo que hay que eliminarlo:)
    LoadModule rewrite_module modules/mod_rewrite.so

    3. Modificar Permalinks en WordPress:
    Acceder al panel de control de WordPress (http://localhost/tublog/wp-admin/)

    Apartado de Permalinks (enlaces permanentes)
    Configurarlo al gusto. Por ejemplo (recomendado para SEO):
    Wordpress rewriting SEO compatible – sección Permalinks de WordPress

    4. Reiniciar Apache.
    Si no os funciona, reiniciar el ordenador y aseguraros que el IIS está parado.

    Saludos desde Venezuela mi problema con Buddypress es que no me funciona el foro despues que cambie mi pagina de servidor, cuando le digo Post new topic me da el siguiente mensaje «This group does not have a forum setup yet.» antes funcionaba sin problemas ahora no funciona desde que mude la pagina de servidor, alguna respuesta a este caso? gracias

Viendo 10 respuestas - de la 1 a la 10 (de un total de 10)
  • El debate ‘BuddyPress’ está cerrado a nuevas respuestas.