Soporte » Guías – Resolución de problemas » Buscador de Medios (Imágenes) no funciona

  • Resuelto Bruno Ramos Lara

    (@brunoramoslara)


    Hola!
    Desde hace un par de años el buscador de contenido multimedia nunca me devuelve resultados, siempre indica el mismo error: «No se han encontrado archivos de medios.» aunque busque por nombre de archivo exacto o meta etiquetas.

    Esto también ocurre al buscar imágenes desde los propios post al insertar medios.

    Si entro en la galería me carga todas las miniaturas y puedo seleccionarlas, el problema solo ocurre al buscar.

    La instalación de WordPress es bastante antigua, y ha pasado por un par de migraciones de servidor.

    ¿Hay alguna manera de reconstruir la base de datos de la galería o acción similar?

    Gracias!

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 15 respuestas - de la 1 a la 15 (de un total de 19)
  • Moderador almendron

    (@almendron)

    Entiendo que si, por ejemplo, tú buscas «recuperacion-update-google», no te devuelve ningún resultado. ¿Podrías probar con ese nombre de archivo?

    Moderador almendron

    (@almendron)

    Y haz también la prueba de ir a Entradas > Todas las pruebas y hacer allí la misma búsqueda, es decir, «recuperacion-update-google»

    Iniciador del debate Bruno Ramos Lara

    (@brunoramoslara)

    Exacto, no devuelve nada.

    He encontrado este plugin rebuscando en otros hilos:
    https://wordpress.org/plugins/wow-media-library-fix/

    Lo estoy pasando a ver si arregla algo, o termina por destrozarlo todo XD

    Iniciador del debate Bruno Ramos Lara

    (@brunoramoslara)

    Si busco en entradas me saca el post donde está la imagen (buscando con eslug o slug+.jpg)

    Moderador almendron

    (@almendron)

    Ya nos dirás si el plugin te sirve.

    Iniciador del debate Bruno Ramos Lara

    (@brunoramoslara)

    Nada, no ha servido, solo ha recolocado thumbnails sin referencia en una carpeta a parte para ello.

    He reinstalado WordPress 5.5.1, desactivado plugins y tampoco. He visto unos cuantos hilos en el foro en inglés, pero o bien no desvelan la solución, o hay que tocar base de datos, donde ya me pierdo.

    A ver si hay alguien que haya dado con la tecla, gracias!

    Moderador almendron

    (@almendron)

    Instala y activa https://es.wordpress.org/plugins/enable-database-tools/

    El plugin está en español y su funcionamiento es muy sencillo.

    Iniciador del debate Bruno Ramos Lara

    (@brunoramoslara)

    Hecho (también había probado opciones similares desde phpmyadmin)

    Me dice que todo correcto/reparado salvo esta:

    Fallo al optimizar la tabla wp_termmeta . Error: Table does not support optimize, doing recreate + analyze instead

    Sigue sin mostrar nada el buscador de medios 🙁

    Moderador almendron

    (@almendron)

    Y si subes una nueva: ¿la encuentra?

    Iniciador del debate Bruno Ramos Lara

    (@brunoramoslara)

    No, tampoco, ni nuevas ni antiguas.

    Recordando, hace unos años migré contenido de una web con el importador de XML nativo de WordPress, pero precisamente las imágenes las subí a mano post a post.

    Saludos seguí este tuto de esta web, no se si es tu caso pero espero que puede ayudarte
    wordpress buscador de medios no funciona

    Venga un saludo…

    Iniciador del debate Bruno Ramos Lara

    (@brunoramoslara)

    Gracias @solord pero no, la cosa parece que va con una base de datos que se ha corrompido con los años y tanto update. Me tocará reinstalar desde cero, resubir todas las imágenes y reemplazar las cadenas de las URL de las carpetas.
    Gracias igualmente!

    Moderador almendron

    (@almendron)

    Probad a a desactivar Gutenberg: https://es.wordpress.org/plugins/no-gutenberg/

    Si no utilizáis alguna característica en especial de Gutenberg, lo mejor es desactivarlo y trabajas con el clásico.

    Iniciador del debate Bruno Ramos Lara

    (@brunoramoslara)

    Gracias @almendron, pero tampoco uso Gutenberg :S

    Moderador almendron

    (@almendron)

    Perdona que el mensaje de Gutenberg no era para ti 🙂

    Prueba lo siguiente:

    1) Instala y activa https://es.wordpress.org/plugins/force-regenerate-thumbnails/

    Es antiguo pero funciona perfectamente.

    2) Fuerza la regeneración de dos o tres imágenes.

    3) Busca ahora esas mismas imágenes.

Viendo 15 respuestas - de la 1 a la 15 (de un total de 19)
  • El debate ‘Buscador de Medios (Imágenes) no funciona’ está cerrado a nuevas respuestas.