Soporte » Guías – Resolución de problemas » Cambio de URL del sitio

  • Resuelto alexgamarra

    (@alexgamarra)


    Hola , he intentado cambiar la URL de mi sito tuniforme.org a tuniforme.com.py y ahora al recargar me sale esto No se puede acceder a este sitioNo se pudo encontrar la dirección IP del servidor de tuniforme.com.py.
    DNS_PROBE_FINISHED_NXDOMAIN
    Como puedo arreglarlo?

    • Este debate fue modificado hace 2 años, 4 meses por Jose Luis. Razón: arreglar url de la página

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 14 respuestas - de la 1 a la 14 (de un total de 14)
  • Moderador Jose Luis

    (@jose64)

    Hola.

    Bienvenido al foro de soporte de WordPress. El dominio tuniforme.com.py aparece como disponible, así que es imposible que cambies a ese dominio si previamente no lo registras.

    Iniciador del debate alexgamarra

    (@alexgamarra)

    Como vuelvo a la normalidad mi sitio y que ya no salga el error intentar acceder?

    Moderador Jose Luis

    (@jose64)

    Hola.

    Te dejo enlace a la documentación de WordPress:

    Changing The Site URL

    La opción más sencilla es hacer unas modificaciones en las siguientes líneas en el archivo wp-config.php ahora mismo debes tener:

    define( 'WP_HOME', 'https://tuniforme.com.py/' );
    define( 'WP_SITEURL', 'https://tuniforme.com.py/' );

    Tienes que cambiar las urls por las correctas, de forma que te quede:

    define( 'WP_HOME', 'https://tuniforme.org/' );
    define( 'WP_SITEURL', 'https://tuniforme.org/' );

    Otra opción es editar directamente en la base de datos la tabla wp_options los valores de siteurl y home y cambiarlos por la url correcta.

    Recuerda hacer una copia de seguridad de la base de datos antes de modificar nada.

    Coméntanos cualquier duda y, por favor, recuerda cerrar el debate marcándolo como resuelto cuando así sea, de esta forma nos ayudas a mantener el foro al día.

    Iniciador del debate alexgamarra

    (@alexgamarra)

    no encontre los codigos que me ha mandado , encontre estos
    // ** MySQL settings – You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define( ‘DB_NAME’, ‘xxxxxx’ );

    /** MySQL database username */
    define( ‘DB_USER’, ‘xxxx’ );

    /** MySQL database password */
    define( ‘DB_PASSWORD’, ‘xxxxxx’ );

    /** MySQL hostname */
    define( ‘DB_HOST’, ‘localhost’ );

    /** Database Charset to use in creating database tables. */
    define( ‘DB_CHARSET’, ‘utf8’ );

    /** The Database Collate type. Don’t change this if in doubt. */
    define( ‘DB_COLLATE’, » );

    • Esta respuesta fue modificada hace 2 años, 4 meses por Jose Luis. Razón: Eliminar datos innecesarios
    Moderador Jose Luis

    (@jose64)

    Hola

    No toques nada de eso, es la conexión con la base de datos. Añade esas líneas de código al final.

    Como siempre, haz una copia de seguridad por si acaso.

    Añade las líneas de código con la URL correcta y haz la prueba.

    Iniciador del debate alexgamarra

    (@alexgamarra)

    HE HECHO ESTO Y ME APARECE DE ESTA FORMA

    /** MySQL hostname */
    define( 'DB_HOST', 'localhost' );
    
    /** Database Charset to use in creating database tables. */
    define( 'DB_CHARSET', 'utf8' );
    
    /** The Database Collate type. Don't change this if in doubt. */
    define( 'DB_COLLATE', '' );
    
    define( 'WP_HOME', 'https://tuniforme.org' );
    
    define( 'WP_SITEURL', 'https://tuniforme.org/' );
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *

    AHORA AL RECARGAR LA PAGINA ME APARECE ESTO
    Future home of something quite cool.
    If you’re the site owner, log in to launch this site

    If you are a visitor, check back soon.

    • Esta respuesta fue modificada hace 2 años, 4 meses por Jose Luis. Razón: etiquetar código
    Iniciador del debate alexgamarra

    (@alexgamarra)

    DEBO CORREGIR TAMBIEN MIS REGISTROS DNS? ON SE SI AFECATRIA ESO TAMBIEN YA QUE TENGO MI DOMINIO EN GODADDY Y MI DNS EN .cloudflare

    Moderador Jose Luis

    (@jose64)

    Las DNS están bien (aparentemente) porque tu web cargaba correctamente, simplemente se redireccionaba a un dominio que no existía. Ese mensaje debe ser porque tienes un archivo index.html en la raíz de la instalación que se muestra en lugar del index.php que crea WordPress. Si es así elimínalo y la instalación debería volver a funcionar.

    Iniciador del debate alexgamarra

    (@alexgamarra)

    ahora al recargar me aparece esto Esta página no funcionaLa página tuniforme.org no puede procesar esta solicitud ahora.
    HTTP ERROR 500
    tambien he notado que al costado izquierdo de este codigo define(‘AUTH_KEY’, ‘l3bFnabcjr6r3F9Ff1S3Dk9enxBNgUxWAEqRp5JyxJnUioapE5BzQ781qgysb2gE’);
    define(‘SECURE_AUTH_KEY’, aparece una x y dice sintax errorunexpeted

    mis dns son
    Tipo Nombre Contenido TTL Estado de proxy
    A
    admin
    107.180.16.114
    Automático

    Redirigido por proxy

    Editar
    A
    mail
    107.180.16.114
    Automático

    Redirigido por proxy

    Editar
    A
    tuniforme.org
    107.180.16.114
    Automático

    Redirigido por proxy

    Editar
    CNAME
    cpanel
    tuniforme.org
    Automático

    Redirigido por proxy

    Editar
    CNAME
    _domainconnect
    _domainconnect.gd.domaincontrol.com
    Automático

    Redirigido por proxy

    Editar
    CNAME
    webdisk.admin
    tuniforme.org
    Automático

    Redirigido por proxy

    Editar
    CNAME
    webdisk
    tuniforme.org
    Automático

    Redirigido por proxy

    Editar
    CNAME
    whm
    tuniforme.org
    Automático

    Redirigido por proxy

    Editar
    CNAME
    http://www.admin
    tuniforme.org
    Automático

    Redirigido por proxy

    Editar
    CNAME
    www
    tuniforme.org
    Automático

    Redirigido por proxy

    Editar

    Moderador Jose Luis

    (@jose64)

    Hola

    Revisa el archivo wp-config.php, es posible que modificases algo por error. Compáralo con la copia de seguridad.

    Iniciador del debate alexgamarra

    (@alexgamarra)

    <?php
    define('WP_CACHE', true);
    /** Enable W3 Total Cache */
    
    /** Enable W3 Total Cache */
    
    /** Enable W3 Total Cache */
    
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the
     * installation. You don't have to use the web site, you can
     * copy this file to "wp-config.php" and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://wordpress.org/support/article/editing-wp-config-php/
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define( 'DB_NAME', 'xxxxxx' );
    
    /** MySQL database username */
    define( 'DB_USER', 'xxxxxx' );
    
    /** MySQL database password */
    define( 'DB_PASSWORD', 'xxxxx' );
    
    /** MySQL hostname */
    define( 'DB_HOST', 'localhost' );
    
    /** Database Charset to use in creating database tables. */
    define( 'DB_CHARSET', 'utf8' );
    
    /** The Database Collate type. Don't change this if in doubt. */
    define( 'DB_COLLATE', '' );
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx');
    define('SECURE_AUTH_KEY',  'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx');
    define('LOGGED_IN_KEY',    'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx');
    define('NONCE_KEY',        'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx');
    define('AUTH_SALT',        'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx');
    define('SECURE_AUTH_SALT', 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx');
    define('LOGGED_IN_SALT',   'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx');
    define('NONCE_SALT',       'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx');
    
    /**
     * Other customizations.
     */
    define('FS_METHOD','direct');
    define('FS_CHMOD_DIR',0755);
    define('FS_CHMOD_FILE',0644);
    define('WP_TEMP_DIR',dirname(__FILE__).'/wp-content/uploads');
    
    /**
     * Turn off automatic updates since these are managed externally by Installatron.
     * If you remove this define() to re-enable WordPress's automatic background updating
     * then it's advised to disable auto-updating in Installatron.
     */
    define('AUTOMATIC_UPDATER_DISABLED', true);
    
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each
     * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix = 'wp_';
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     *
     * For information on other constants that can be used for debugging,
     * visit the documentation.
     *
     * @link https://wordpress.org/support/article/debugging-in-wordpress/
     */
    define( 'WP_DEBUG', false );
    
    /* That's all, stop editing! Happy publishing. */
    
    /** Absolute path to the WordPress directory. */
    if ( ! defined( 'ABSPATH' ) ) {
    	define( 'ABSPATH', __DIR__ . '/' );
    }
    
    /** Sets up WordPress vars and included files. */
    require_once ABSPATH . 'wp-settings.php';

    cual codigos agrego y en que parte , corregi el error quitando los codigos anteriores que me envio

    hay una opcion para cambiar el dominio men godaddy y reemplazar dns , noc si eso funcionaria.

    • Esta respuesta fue modificada hace 2 años, 4 meses por Jose Luis. Razón: Etiquetar código y eliminar información sensible
    Iniciador del debate alexgamarra

    (@alexgamarra)

    Otra opción es editar directamente en la base de datos la tabla wp_options los valores de siteurl y home y cambiarlos por la url correcta.
    podria decirme como hago esto, para probar esta forma

    Moderador Jose Luis

    (@jose64)

    Hola.

    Veo que tu página está funcionando, ¿cómo lo resolviste?, las dos veces que pusiste código dejaste el nombre de usuario, base de datos y contraseña, por seguridad esos datos nunca debes hacerlos públicos, por eso los edité. Recuerda cerrar el debate marcándolo como resuelto.

    Iniciador del debate alexgamarra

    (@alexgamarra)

    Primero agradecerte por la paciencia y por la gran ayuda , reemplaze todo el codigo con la ayuda de la copia de seguridad , después ya empezó a funcionar normal

Viendo 14 respuestas - de la 1 a la 14 (de un total de 14)
  • El debate ‘Cambio de URL del sitio’ está cerrado a nuevas respuestas.