Soporte » Instalación – Actualizaciones » Carga doble de librerías jQuery 1.12.4 y jQuery Migrate 1.4.1 en WP 5.3.2

  • hunterace

    (@hunterace)


    Hola comunidad,

    No tengo un problema, pero si quisiera mostrar unos bugs que he notado en la versión 5.3.2 de WP.

    Uso Elementor Pro para maquetar mis páginas, y también veo temas de seguridad, por lo cual pude ver que en esta actualización se ejecuta dos veces las librerías de jQuery 1.12.4 y jQuery Migrate 1.4.1.Lo mismo se replica si se usa el editor de WP (Apariencia/Personalizar), esto se puede visualizar al editar cualquier página con Elementor o el editor de WP, pueden verlo en la consola del navegador, o instalando la extensión Retire.js.

    Por el momento no tengo ningún problema con mis páginas, y tengo unas que no he actualizado a la versión actual que no veo este bug, pero quisiera informar a los desarrolladores si esto es intencional o no.

    • Este debate fue modificado hace 1 mes por hunterace.
Viendo 8 respuestas - 1 de 8 (de 8 total)
  • Moderador almendron

    (@almendron)

    Si se ejecuta dos veces cada una de las librerías que mencionas, es porque algún plugin las carga además de hacerlo WordPress. Normalmente, los plugins que requieren dichas librerías suelen tener una opción para evitar dicha duplicidad.

    Ve desactivando plugins hasta encontrar al responsable.

    hunterace

    (@hunterace)

    Hola @almendron,

    Llegaste a probar el bug en alguna instalación de WP?, antes de poner este comunicado lo probé con instalaciones limpias y desde 0, por eso he comunicado esto, y como digo más abajo en mi comentario, por el momento no encuentro errores con mis páginas porque el duplicado de Js no se aplica en el front, sólo cuando se usa el editor.

    Moderador almendron

    (@almendron)

    Lo acabo de comprobar y a mi no me aparecen duplicadas las librerías. Lo he probado en local y en mis sitios. Lo he mirado con la consola.

    De todas formas, se lo comento a mis compañeros por si alguno de ellos lo ha detectado.

    Moderador almendron

    (@almendron)

    ¿Podrías poner un pantallazo de la consola donde se vea la duplicidad?

    Moderador José Arcos

    (@josearcos)

    Hola, @hunterace. Con el tema por defecto TwentyTwenty y Elementor en su última versión en una instalación limpia, sólo veo la carga de jQuery una vez, y es la propia de WordPress en wp-includes:

    Elementor jQuery

    Es posible que se trate entonces de tu tema o de la versión de elementor que estás usando, ¿puede ser que tengas instalada la versión PRO?

    Un saludo.

    hunterace

    (@hunterace)

    @almendron

    Llegaron a entrar a Apariencia/Personalizar?

    Dejo aquí imágenes:

    Plugins desactivados:
    0 plugins
    <br>

    Visualización de los js con la extensión Retire.js, al entrar a Apariencia/Personalizar:
    evidencia 1
    <br>

    Visualización de los js con la consola del navegador, al entrar a Apariencia/Personalizar:
    evidencia 2

    • Esta respuesta fue modificada hace 1 mes por hunterace.
    • Esta respuesta fue modificada hace 1 mes por hunterace.
    • Esta respuesta fue modificada hace 1 mes por hunterace.
    Moderador almendron

    (@almendron)

    Sí, claro. Y solo me aparecen cargadas una sola vez.

    Moderador José Arcos

    (@josearcos)

    Pues acabo de abrir el personalizador y sí que veo la librería jQuery Migrate cargada dos veces. Voy a echarle un vistazo más a fondo y te digo algo.

Viendo 8 respuestas - 1 de 8 (de 8 total)
  • Debes estar registrado para responder a este debate.