Soporte » Guías – Resolución de problemas » código extraño en los enlaces permanentes

  • Resuelto asisrodriguez

    (@asisrodriguez)


    buenas tardes, desde hace unos días, en las cuatro webs de mi servidor han empezado a aparecer los enlaces con símbolos raros:
    la url https://www.ntdhoy.com/contacto/
    aparece como https://www.ntdhoy.com/?q=%2Fcontacto%2F
    y no funcionan.
    si pongo el enlace permanente como «simple» en vez de como «nombre de la entrada» si funcionan.
    por favor, alguien sabe cómo se soluciona?
    ya he borrado el wordpress e instalado uno nuevo, he desactivado todos los plugins, pero no lo consigo y estoy un poco desesperado.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 3 respuestas - 1 de 3 (de 3 total)
  • Moderador LGrusin

    (@lgrusin)

    – Eso no falla solo, pregunta al soporte del servidor si han tocado algo.

    – Comprueba que se crea el archivo .htaccess al poner un permalink.

    Un saludo

    hola y gracias.
    eso es lo desesperante, que todo está, incluso borrro el htaccess, cambio el permalink y se crea otro htaccess por el propio WordPress… pero sigue igual.
    no encuentro a nadie en internet con ese mismo problema y ya no sé qué más hacer.
    si borro esos símbolos en las tablas, vuelven a aparecer.
    yo creo que es algo del servidor y no del wordpress pero como no soy informático no sé ni qué preguntar a mi soporte, que, aunque lo han intentado, no encuentran nada.
    gracias… alguna otra forma de verlo?
    Asís

    hola, acabo de encontrar el problema en este servidor:
    en la Configuración de Apache y nginx, estaba este código que era el que producía el error (una vez eliminado, se ha solucionado)

    # WordPress permalinks
    if (!-e $request_filename) {
    rewrite ^(.*)$ /index.php?q=$1 last;
    break;
    }

    o se puso solo ¿?en alguna actualización o alguien lo metió y no se dió cuenta luego de quitarlo.
    pero bueno, lo importante es que queda solucionado.
    gracias por las ideas.
    Asís

Viendo 3 respuestas - 1 de 3 (de 3 total)
  • El debate ‘código extraño en los enlaces permanentes’ está cerrado a nuevas respuestas.