Soporte » Plugins y Hacks » Columna «shortcodes» no aparece en «mi biblioteca» de Elementor.

  • Resuelto medina30

    (@medina30)


    Hola a todo el mundo:

    Tengo un problema con el plugin Elementor, instalado en WordPress 4.8.2 (uso el tema Twenty Seventeen).

    En el apartado «mi biblioteca» del citado plugin sólo aparecen tres columnas: «autor», «tipo» y «fecha», pero no aparece la correspondiente a shortcode.

    ¿Alguien ha tenido algún problema parecido o puede dar alguna idea del problema?

    Muchas gracias de antemano.

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • Moderador Mariano Perez

    (@mpcdigital)

    Hola,

    no es un módulo que incluya Elementor peor puedes usar el shortcode que quieras en un módulo de texto y funcionará.

    Iniciador del debate medina30

    (@medina30)

    Hola Mariano, muchas gracias por tu respuesta. Te explico, y de paso lo cuento también por si le puede servir a alguien:

    La cuestión es la siguiente, quería insertar en el menú superior del tema «Twenty Seventeen» varios iconos de redes sociales según el procedimiento que explica José M. Peña en este breve tutorial (https://www.youtube.com/watch?v=w5bpWx7vxtQ). En él se dice que es posible usar elementor para crearlos y guardarlos en «mi biblioteca» por ejemplo como «iconos RRSS»

    Hecho esto entiendo, según el video, que se genera automáticamente un shortcode para la sección «iconos RRSS» que podrá ser insertada mediante otro plugin en el menú superior de la página. El problema es que al parecer el mostrar ese shortcode es una función exclusiva de la versión pro de Elementor.

    De hecho hay un comentario reciente (que no estaba cuando lo miré) en el video donde otra persona pregunta esto mismo al autor del video y éste le da la respuesta.

    Probaré con algún otro plugin.

    Muchas gracias por la ayuda en cualquier caso.

    Un saludo.

    • Esta respuesta fue modificada hace 4 años, 12 meses por medina30.
    Moderador LGrusin

    (@lgrusin)

    Los iconos ya se crean en el momento de añadirle los enlaces a las redes sociales. En el tema Twenty Seventeen salen en el footer pero igual haciendo algún invento se podría conseguir que salieran en el menú superior.

    Un saludo

    • Esta respuesta fue modificada hace 4 años, 11 meses por LGrusin.
    Iniciador del debate medina30

    (@medina30)

    Hola LGrusin, muchas gracias por la respuesta. Cierto, en el footer sí que aparecen automáticamente los iconos si le añades el enlace, pero para que se vean mejor los quiero poner arriba, en el menú superior.

    Ahora lo que estoy probando es añadir al menú superior del tema varios enlaces personalizados, correspondientes a los iconos de las RRSS que necesito desde Font Awesome. Habría que poner un enlace por cada icono que vaya a añadir.

    Haciéndolo así funciona, muestra los iconos perfectamente, lo único que me falta es conseguir que al picar sobre ellos se abran en nuevas pestañas del navegador…

    Por lo que he leído -creo- que hay que añadir un pequeño trozo de código al de Font Awesome. Lo que no sé es en qué parte va ese trozo de código: target=»_blank». Disculpad mi torpeza pero de programación ando muy pegado.

    La cuestión entonces es:

    ¿Sabeis dónde iría target=»_blank» en un código de un icono como este: <i class=»fa fa-camera-retro fa-2x»></i> para que al picar se abriera una pestaña nueva?

    Muchas gracias de nuevo.

    Iniciador del debate medina30

    (@medina30)

    Buenas a todos, por si sirve de ayuda para alguien, he podido resolver el problema de la siguiente manera:

    En la ventana que se abre después de entrar en «Apariencia»/»menús» existe una pestaña en la parte superior derecha denominada «opciones de pantalla» si la desplegamos, podemos marcar en «Mostrar propiedades avanzadas de menú» la casilla «destino del enlace». Una vez activa, aparece la opción de marcar «abrir enlace en una pestaña nueva» al desplegar las propiedades del enlace personalizado.

    ¡Saludos!

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • El debate ‘Columna «shortcodes» no aparece en «mi biblioteca» de Elementor.’ está cerrado a nuevas respuestas.