Soporte » Diseño – Temas y plantillas » Como corregir el error fatal de mi tema

  • Resuelto reinaldorafaelbriceno

    (@reinaldorafaelbriceno)


    Buenas tardes,
    Mi tema se llama crowdpress, lo instalo a mi wordpress, versión 5.8, pero al tratar de activarlo me sale este error fatal:

    Fatal error: Declaration of ECF_FieldRichText::render() must be compatible with ECF_FieldTextarea::render($append = '') in C:\xampp\htdocs\wordpress\wp-content\themes\crowdpress\_framework\custom_fields\fields.php on line 316
    
    Warning: Trying to access array offset on value of type bool in C:\xampp\htdocs\wordpress\wp-includes\class-wp-recovery-mode-email-service.php on line 351
    
    Warning: Trying to access array offset on value of type bool in C:\xampp\htdocs\wordpress\wp-includes\class-wp-recovery-mode-email-service.php on line 352

    Otro dato el php es versión 8.0 el del servidor local con xampp

    Deseo trabajar el tema en localhost y al activar el tema me sale ese error.
    Quisieran que me ayudaran a solucionar ese error. Además soy nuevo trabajando wp.

    Saludos
    Reinaldo Briceño

Viendo 4 respuestas - de la 1 a la 4 (de un total de 4)
  • Moderador almendron

    (@almendron)

    Usas un tema comercial y los voluntarios del foro no tenemos acceso a ese tipo de productos. No podemos, por tanto, hacer pruebas.

    De todas formas, prueba con una versión inferior de PHP (por ejemplo la 7.4)

    martinmartinezwebcreacionesdanis

    (@martinmartinezwebcreacionesdanis)

    Tengo un problema similar:

    Trying to access array offset on value of type bool in /usr/home/creacionesdanis.com/web/wp-content/plugins/storefront-powerpack/includes/customizer/designer/class-sp-designer.php on line 84

    Yo uso Store Front, ahora que leo me percato que recientemente actualice PHP a 8 pero el mismo dia tambien actualice Storefront.

    Agradezco si tienen una idea de como corregir este error fatal, de hecho a parte del mensaje, al querer cambiar la apariencia no es posible modificar la apariencia de mi pagina.

    martinmartinezwebcreacionesdanis

    (@martinmartinezwebcreacionesdanis)

    Seguí la recomendación de cambiar la versión PHP a 7.4 y ahora ya funciona bien.
    Muchas gracias, sin embargo me pregunto que sera cuando si o si deba cambiar la version PHP.

    Loading

    (@loadinges)

    Buenas,

    Tendrás que esperar todavía un tiempo hasta que los plugins y plantillas usadas sean compatibles con PHP 8.x, en futuras actualizaciones que saquen los desarrolladores.

    Es una versión de PHP bastante reciente y muchos plugins o plantillas no están todavía adaptados.

Viendo 4 respuestas - de la 1 a la 4 (de un total de 4)
  • Debes estar registrado para responder a este debate.