Soporte » Guías – Resolución de problemas » ¿Cómo logro que puedan registrase los usuarios en mi foro?

  • Resuelto formador

    (@formador)


    Buenas tardes,

    He creado un foro en mi Blog. Para ello he instalado un pluggin; Asgaros Forum.

    Mi sorpresa es que por el momento no permite que ningún usuario interesado pueda registrarse en el foro. Asunto que evidentemente me interesa solucionar para que puedan registrarse y participar escribiendo en el foro.

    He ido a ajustes del foro, una vez iniciado sesión con mi cuenta, en mi panel de administrador en mi blog (el que aparece a la izquierda de la pantalla, en color negro con letras blancas). Donde he realizado algunos cambios. Sólo he logrado que desaparezca un mensaje que dice que; en este momento nadie puede registrarse.

    No logro hallar la solución tanto en la pestaña ajustes del pluggin foro Asgaros, como en ajustes en Profilepress. Lugar este último donde he logrado que desapareciera el aviso antes mencionado.

    He estado buscando información que me diera la solución y sólo he encontrado un mensaje en u foro de soporte de Asgaros.de, que decía que la solución se halla en la configuración general de WordPress y no en la configuración del foro de Asgaros.

    Chicos, ni así lo saco. No lo veo. Por favor ¿Podríais detallarme paso a paso cómo lograr solucionar este asunto?

    Os ruego paciencia si veis que es muy fácil la solución. Para mi que soy más analógico que digital, me cuesta. Ando aprendiendo en este universo a base de encontronazos con los problemas que surgen y la ayuda que recibo.

    Si conocéis de algún otro foro para instalar en mi Blog que sea mejor al citado y que no diera problemas, os lo agradecería. Este lo tomé junto a bbpress porque lo vi en una lista en una búsqueda previa que realicé en el motor de búsqueda y me lo recomendó.

    Gracias.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • Moderador Jose Luis

    (@jose64)

    Hola.

    Bienvenido al foro de soporte de WordPress. Asegúrate de tener activada la opción de permitir el registro, sigue la ruta Ajustes > Generales > Miembros y marca la opción Cualquiera puede registrarse, los usuarios del foro son los mismos de la web.

    Los usuarios tendrán que registrarse en tu web y una vez identificados pueden participar en el foro.

    Coméntanos si tienes alguna duda y, por favor, recuerda marcar el debate como resuelto cuando así lo consideres, de esta forma nos ayudas a mantener el foro al día.

    Iniciador del debate formador

    (@formador)

    Buenas tardes, Jose Luis.

    Muchas gracias por tu pronta respuesta. La leí a la media hora de publicarla. Pude realizar el cambio que me indicaste pero aún así continuo con el problema. ¿podrías indicarme otra solución posible?

    Estoy nuevamente intentándolo desde el menú de administrador de wordpress en mi Blog, desde la pestaña «apariencia» – «Menú» – etc. Pero no logro gran cosa. Más bien he ido provocando destrozos que luego he tenido que recomponer.

    Es curioso que doy clic al apartado registrarme o entrar y me lleva de regreso a la pagina del foro. Supongo que debería encontrar la manera de poner el enlace que lleva al registro de usuario, pero no lo veo en este momento por ningún lado. Por cierto, utilizo Glades para mi Blog. Por si quizá sirve de algo este dato.

    Sin duda, una vez finalizado y solucionado el debate, lo marcaré como resuelto.

    Gracias.

    EDITO: ¿Y si instalo un pluggin de registro de usuarios? Por ejemplo acabo de poner New User Approve. Parece interesante, aunque no veo que funcione por ahora. Lo tengo activado. Me faltaría poner el apartado que diga registrate o similar o si quizás debería salir por defecto. ¿Qué te parece Jose Luis?

    Gracias una vez más.

    • Esta respuesta fue modificada hace 2 semanas, 4 días por formador.
    • Esta respuesta fue modificada hace 2 semanas, 4 días por formador.
    Moderador Jose Luis

    (@jose64)

    Hola.

    Creo que el problema es que modificaste las urls de acceso y registro (/wp-admin, /wp-login.php), seguramente estás usando un plugin de seguridad que las cambió, o un código personalizado, por eso no te funciona.

    Iniciador del debate formador

    (@formador)

    Buenas, Jose Luis

    He comprobado los plugins instalados y he encontrado y recordado efectivamente que tengo instalado el plugin WPS Hide Login. Que me dice lo siguiente; Protege tu web cambiando la URL de acceso y evitando el acceso al archivo «wp-login.php» y al directorio «wp-admin» si no se está conectado.

    He desactivado el plugin mencionado. Llevo unos minutos dando a la opción acceso y a la de registro que aparece tanto en el menu del foro, como en otro aviso que me da la misma opción, pero me devuelve a la pagina del foro. Sin resultado.

    Puedo aprobar registros de nuevos usuarios manualmente (de cara a evitar el spam viene genial), ellos me envían el alias que quieren y el mail y les respondo vía correo electrónico. Por un lado está bien, pero por el otro intuyo que puede llegar a ser pesado en el caso de recibir muchas solicitudes.

    En fin, no veo solución en este momento. No tengo mucho conocimiento en este campo de las TIC, así que me atrevo a decir que dudo que por mí mismo haya cambiado la configuración pese a que cada vez más me pongo a aventurarme, pero no recuerdo haberlo realizado. Lo que me deja la opción del plugin antes mencionado, pero si ahora lo tengo desactivado…¿Dónde estaría el problema?

    Por cierto, tengo activada la casilla; cualquiera puede registrase. De mi panel de administrador.

    ¿Se te ocurre alguna otra solución?
    Gracias, Jose Luis.

    Moderador Jose Luis

    (@jose64)

    Hola.

    La página de acceso sigue sin funcionar con los valores por defecto, sigue siendo la que modificó el plugin, tienes que desinstalarlo por completo para que te funcione el acceso y registro del foro

    Iniciador del debate formador

    (@formador)

    Hola,

    He borrado plugins y desactivado otros. Sin resultado. Así que decidí ir a mi panel de administrador y probar en ajustes – generales y después en dos campos donde aparece el nombre de mi blog, así que en uno de ellos puse a continuación del nombre de dominio /login y otro texto más largo, que es lo que me sale cuando quiero acceder. Pues me lo he cargado. Ahora no puedo acceder a mi cuenta de administrador.

    Hace 2 años y 10 meses respondiste, Luis, lo siguiente a una mujer con un problema similar al mío.

    Cito;»en la tabla wp-options (wp_ por defecto o el prefijo que uses) vas a ver los dos primeros campos: siteurl y home. Edita estos campos y ponle las URL correctas. Una vez hecho esto podrás acceder nuevamente a tu instalación.»

    Pues ni así. No hallo solución. Me sale error 404

    He estado rato largo leyendo y buscando información y todo lo que he encontrado no me sirve para solucionar, aunque sí para aprender y tener más conocimientos en materia. Así que he navegado por phpmyadmin y no me he atrevido por ftp porque me ha parecido que las carpetas las veo igual en phpmyadmin por lo que he leído en blogs de ayuda.

    Total, al final me ido a file manager y he borrado las carpetas del foro asgaros y wps hide login y en phpmyadmin, en la fila 33 active_pluggins borrado también.

    Pero nada de nada. Ahora no sólo he acabado mandando al olvido el foro sino que me llevo de regalo no poder acceder a mi cuenta y panel de administrador en mi blog hasta saber cuando. Porque no logro arreglarlo. No veo cómo entrar en la interfaz (creo que se dice así) de wordpress para acceder a mi blog. Aunque cuanto menos está visible y se pude consultar.

    Menudo dolor de cabeza. Aunque me quedo con lo positivo, voy aprendiendo a manejarme en este campo, aunque sea a base de tropiezos.

    ¿Se te ocurre algo que podamos hacer para arreglarlo?

    Gracias.

    Iniciador del debate formador

    (@formador)

    Hola, Jose Luis.

    He contactado con el servicio de soporte técnico de mi proveedor y tras explicarle mi caso, en un instante me lo ha arreglado.

    Se trata de poner el nombre de dominio, en mi caso el mío, jefedeseguridad.es seguido de la extensión que me ha pasado y automáticamente he accedido a la interfaz que me permite poner mi nombre de usuario y contraseña. Acceder a mi sesión de administrador y moverme sin problema.

    Ahora voy a borrar plugins, seguir aprendiendo y ver si puedo finalmente poner un foro en mi blog que ayude a mis visitantes a comunicarse mejor entre todos y de paso aumentar mi tráfico en mi blog.

    Gracias por tu ayuda, me ha servido para aprender cosas nuevas.

    Saludos a todos.
    Podemos dar por resuelto y cerrar este hilo.

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • Debes estar registrado para responder a este debate.