Soporte » Guías – Resolución de problemas » Compatibilidad versión php entre local y remote server.

  • Hola,

    voy a empezar a crear una web, y haré una maqueta previa en server local (wampserver) y posteriormente la migraré al servidor de mi empresa (arsys).Destacar que la empresa no quiere actualizar el php con arsys, no está en mis manos.

    Mi empresa utiliza un servidor con versión de PHP antigua y el wordpress que funciona es la versión 3.1.4.
    Mi pregunta es: puedo trabajar en local con la versión más nueva de wordpress y posteriormente migrar sin ningún problema o tendré que trabajar también con la versión 3.1.4 en local.
    Gracias

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • ¿Cómo? ¿Vas a seguir con WordPress 3.1.4? ¿He entendido bien? Desde entonces se han solucionado muchos problemas de seguridad. Es un deber actualizar. Lo mismo se aplica a PHP.

    Y si la seguridad no es suficiente razón, te perderás importantes mejoras en rendimiento; también aplicable tanto a WordPress cómo a PHP.

    Y sin contar con que te será muy dificíl encontrar themes y plugins actuales compatibles con esa verión tan vieja y que te vas a perder mejoras en usabilidad, en flujo editorial, en opciones de personalización, incluso en velocidad de carga y SEO (por ejemplo, se me ocurre las imágenes responsive con srcset introducido en WP 4.4) … y un sin fin de ventajas más.

    Lo siento pero no voy a decir nada diferente a ACTUALIZA.

    Y no creo que trabajando con la última versión de WordPress luego lo puedas pasar a la 3.1.4 sin ningún tipo de error, seguro que aparece alguno.

    Iniciador del debate mgonzalezq

    (@mgonzalezq)

    gracias cybmeta,

    si si estoy de acuerdo, lo suyo es trabajar con la versión más actual por sus mejoras y seguridad, pero en mi caso para poder utilizar wordpress sólo puedo usar la version 3.1.4, porque las otras requieren una versión PHP superior a la que tiene el servidor contratado por mi empresa.

    pero si ya me dices que no encontraré pluguins ni themes (de hecho se me ha colgado más de una vez la web- pantallazo blanco).

    Optaré por trabajar con una version 4.i.

    Una vez termine la maqueta, que soluciones tendría para poder migrar la web a remoto?

    El tema es que, como decía, los problemas de seguridad (y las mejoras) no solo afectan a WordPress, PHP también tiene problemas de seguridad y actualmente sólo PHP 5.5 o superior es mantenido en cuestiones de seguridad. Y a partir de Julio 2016 sólo 5.6 o superior (Mira PHP Supported Versions).

    Así que, ahora mismo deberías tener como mínimo PHP 5.5. Y a partir de Julio, cómo mínimo, PHP 5.6. En cualquiera de esas versiones de PHP puedes utilizar la última versión de WordPress.

    Explica a tu cliente la importancia de contratar un hosting actualizado, si es que la seguridad le importa.

    Y a parte ya, pues también le puedes contar todas las mejoras adicionales a la seguridad.

    Y vuelvo a decir que no creo que puedas trabajar con WordPress > 4 y luego pasar el trabajo a WordPress 3.1.4 y un servidor con PHP anticuado sin ningún tipo de problemas; estoy convencido de que aparecerá alguno.

    De todas formas, ¿qué versión de PHP tiene el hosting? La última versión de WordPress funciona a partir de PHP 5.2.4+, una versión que llegó a su fin hace más de 5 años ya. ¿Tienes menos de PHP 5.2.4?

    Iniciador del debate mgonzalezq

    (@mgonzalezq)

    Si, ahora mismo tienen la versión PHP 5.1. que queda ya bastante desfasada…

    gracias

    Moderador erchache2000

    (@erchache2000)

    Si tienes una versión antigua de WordPress actualiza, no hay otra.

    El hosting debe de cumplir con los requisitos mínimos para ejecutar WordPress, https://wordpress.org/about/requirements/

    Te recomiendo a que uses virtualbox y una VM ubuntu en vez de wampp/xampp o mierdas similares.

    Lo suyo es que tu entorno de desarrollo y producción sea el mismos, así evitarás muchos dolores de cabeza.

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • El debate ‘Compatibilidad versión php entre local y remote server.’ está cerrado a nuevas respuestas.