Soporte » Plugins y Hacks » WooCommerce » no funciona la opción de comprar cómo invitado

  • fatima197

    (@fatima197)


    Hola

    Llevamos muchos días teniendo un problema con mi página web que no deja a mis clientes hacer un pedido como invitado. En otras palabras sin tener que registrarse,

    A la hora de finalizar la compra siempre la página esta redirigida «Crear una cuenta» y no a pagar

    Estoy utlizando astra y elementor

    Me pueden ayudar?

    • Este debate fue modificado hace 1 semana por fatima197.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • Moderador Jose Luis

    (@jose64)

    Hola.

    Bienvenida al foro de soporte. Revisa la configuración de WooCommerce, en la ruta WooCommerce > Ajustes, en la pestaña Cuentas y privacidad asegúrate de tener marcadas en Pago como invitado las dos opciones:

    • Permite a los clientes hacer pedidos sin tener una cuenta
    • Permite a los clientes acceder a una cuenta existente al finalizar compra

    Igualmente en Creación de cuenta asegúrate de tener marcada la opción

    • Permite a los clientes crear una cuenta al finalizar compra.

    De esta forma permites el pago como invitado (sin tener cuenta) y también el acceso a la cuenta y a su creación en el checkout (que es como lo tienes ahora).

    Comenta si con esa configuración te funciona correctamente y, por favor, recuerda marcar el debate como resuelto cuando así sea, de esta forma nos ayudas a mantener el foro al día.

    Iniciador del debate fatima197

    (@fatima197)

    Hola José Luis,

    Te aseguro que lo tengo permitido desde los ajustes de Woocommerce, aún así no funciona,
    He reiniciado muchas veces y lo he actualizado pero sigue sin funcionar,
    Te ocurre otra solución?
    Saludos

    Moderador Jose Luis

    (@jose64)

    Actualiza todo a las últimas versiones, estás usando una versión obsoleta del tema Astra. Una vez tengas tema y todos los plugins actualizados haz la prueba nuevamente.

    Iniciador del debate fatima197

    (@fatima197)

    He actualizado el tema y todos los plugins y sigo teniendo el mismo problema 🙁

    Te ocurre una alternativa?

    Muchas gracias

    Moderador Jose Luis

    (@jose64)

    Si te sigue ocurriendo lo mismo es que algún plugin o un código personalizado está modificando el comportamiento normal.

    Desactiva todos los plugins excepto WooCommerce y elimina los códigos personalizados que tengas en el archivo functions.php (haz una copia de seguridad del archivo antes), si tienes un archivo de personalizaciones como Code Snippets los códigos personalizados se desactivan al desativar el plugin. Haz la prueba y comenta el resultado.

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • Debes estar registrado para responder a este debate.