Soporte » Plugins y Hacks » Contact Form 7 con Recaptcha v3 y Flamingo fallo envío formularios

  • Muy buen día a todxs,

    Más que ayuda, era para dejarlo por escrito, por si alguien consigue una solución más adelante, agradecería mucho que la compartiera. He visto mensajes similares con fallos recientes en el envío de formularios.

    La integración del recaptcha v3 con Contact form 7 me generó en varias webs (no en todas) fallos al enviar formularios. La que puse de ejemplo es una web nueva que no tiene casi nada. Me saltaba el aviso naranja de «Hubo un error intentando enviar tu mensaje. Por favor inténtelo de nuevo más tarde».

    Tengo Flamingo instalado y los mensajes llegaban a la bandeja de spam de ese plugin. Pero no al correo.

    Consulté con el servicio técnico de mi hosting, estuvieron investigando, desactivaron todos los plugins, cambiaron de tema y nada. Tampoco encontraron la respuesta.

    En el foro en inglés, el autor del plugin comenta de poner un filtro en el functions.php para los falsos positivos, pero a mi no me sirvió esa solución. Lo pueden ver en el siguiente enlace.

    Al final eliminé el recaptcha y volvió a funcionar el formulario.

    Pues eso, solo comparto para ver si más adelante a alguien más le sucede y logramos encontrar juntos una solución.

    Muchas gracias 🙂

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 6 respuestas - 1 de 6 (de 6 total)
  • Hola

    Para los que tengan el mismo problema, una solución alternativa a reCAPTCHA es

    Contact Form 7 Honeypot

    No es intrusiva y funciona perfectamente, el usuario no la detecta y a los bots le genera un error en el envío.

    Muchas gracias José Luis. Muy útil tu consejo. Probaré el plugin y ya te diré si me funciona de forma correcta.

    Un abrazo,

    Llevo 5 horas revisando mil cosas porque tenía el mismo problema y nada era lo que comentas el maldito recaptcha v3…
    lo curioso es que tengo lo mismo en otras 4 webs y allí funciona sin problemas…
    ¿puede ser porque no esta indexada en google?

    No está relacionado con la indexación @mianviru2

    Nunca llegué a descubrir el por qué del fallo, solo implementé la solución que nos dió @jose64 y genial.

    Mis formularios con contact form funcionan a la perfección. Igual algún día descubrimos el porqué del error y lo comentamos para que quede en el foro la solución.

    Saludos y buena semana,

    Hola a todos. Tuve el mismo problema e integré en el header de la página donde está el formulario de Contact Form 7 el siguiente script:

    <script src=»https://www.google.com/recaptcha/api.js?render=reCAPTCHA_site_key»></script>

    Hay que sustituir reCAPTCHA_site_key por la clave del sitio web que te da recaptcha.

    Me funcionó.

    Para más información https://developers.google.com/recaptcha/docs/v3

    Saludos.

    naznar

    (@naznar)

    Hola;
    Tengo exactamente el mismo problema. El formulario funciona perfectamente hasta que instalo recpatcha v3 y deja de funcionar, saliéndome el mensaje naranja de ‘Hubo un error…’.
    He probado con la última solución que propone @miguelangbernal pero en mi caso no funciona 🙁
    No tengo la web pública, está subida pero no está configurada para que no se vea, no sé si esto tiene algo que ver con el problema.
    Yo también agradezco alguna solución alternativa.
    un saludo.

Viendo 6 respuestas - 1 de 6 (de 6 total)
  • Debes estar registrado para responder a este tema.