Soporte » Instalación – Actualizaciones » copia del servidor remoto al local y de vuelta al remoto

  • Resuelto 10rous

    (@10rous)


    hola
    tengo que renovar mi blog y bajarlo del servidor remoto al local para trabajar en él manteniendolo activo en su url, en el localhost quiero aplicar un nuevo tema, instalar plugins e incluir nuevos widgets y luego subirlo de nuevo al servidor remoto

    no tengo problemas para instalarlo en el localhost, bajo todos los archivos a la carpeta local, exporto la base de datos del servidor remoto y la importo en el local y reasigno urls

    la pregunta es la siguiente, una vez haya aplicado el nuevo tema e intalado los plugins en el servidor local y quiera subir los cambios al remoto, ¿tengo que subir todos los archivos? o basta con que suba las carpeta Themes y Plugins o todo WP-content

    no voy a tocar nada de contenido, entradas,categorías etc. todo quedará igual

    gracias

Viendo 13 respuestas - 1 de 13 (de 13 total)
  • Hola 10rous,

    Si lo único que vas a hacer es instalar plugins y cambiar el tema, pues sólo tienes que subir estos archivos usando el ftp.

    Pero lo que SI debes tener en cuenta es que algunos plugins cambian la base de datos, por lo que si debes mirar esto y actualizar la base de datos, si los plugins lo hacen.

    Otra cosa con la que he tenido problemas en algunas migraciones, es que al momento de pasar del local host al hosting, si cambias la url simplemente usando el buscar y reemplazar en el archivo .sql de tu base de datos, se me suelen desconfigurar los widgets y las configuraciones del tema.

    Para evitar eso, uso un script que descargué de la siguiente página, que me busca la url y me la reemplaza sin problemas de este tipo:

    http://interconnectit.com/products/search-and-replace-for-wordpress-databases/

    Advierten ahí que lo uses bajo tu propia responsabilidad, pero hasta ahora no he tenido problemas.

    Me cuentas como te va con el cambio.

    muchas gracias Camilo
    si voy instalando paralelamente los plugins en ambos servidores no necesitaré reimportar la base de datos entonces?
    es una solución algo pedestre pero funcioanaría no?
    la cuestión es que otra persona pueda ir insertando entradas en el blog mientras yo trabajo sobre el tema y los plugins y pueda olvidarme de la base de datos

    respecto a la url, yo lo hago manualmente buscando la tabla wp-options, probaré lo que me comentas

    gracias

    10

    Pues hay dos cosas que puedes hacer:

    1) Al exportar la base de datos, sólo exportas la sección de la base de datos que creó el plugin y luego al importarla, sólo importas esa tabla. Así no tendrás problemas.

    2) Lo que dices, pero tienes que tener en cuenta que cualquier cambio que hagas en uno, debe hacerse en el otro y puede ser un poco aburridor y toma mucho tiempo si son plugins complejos.

    Yo también lo he hecho con wp-options, el problema que he notado es que hay unos datos que están serializados (o sea que en la base de datos se guarda de cuantos caracteres es la url y si no correponden, no muestra esas secciones).

    Si haces el cambio manual, la url local y la que tienes en el hosting no van a corresponder y ahí es cuando se desconfiguran los widgets o las opciones de un tema.

    La verdad se me hacía que era mucho trabajo, pero luego que lo probé y me funcionó, las migraciones no me dan problema y ahora este paso adicional me toma si mucho 5 minutos.

    Espero que te sirva
    Camilo

    camilo

    muchas gracias
    me sirve de mucho
    lo pruebo y te explico

    10

    lo acabo de probar
    por una parte bien porque el script funciona perfecto pero me pasan un par de cosas
    los enlaces aparecen bien pero lo redirecciona a http://localhost/xampp/
    y no se muestran las imágenes en el el blog, en el back end si, si embargo
    me podéis ayudar con esto?
    gracias

    Al momento de reemplazar los datos en la base de datos (lo que hace el script) pones la url que esta actualmente en wp-options, y en el siguiente campo pones la nueva a la que te quieres dirigir.

    La nueva url debe ser la dirección donde va a quedar tu blog, para que de esta forma todo quede organizado.

    No puedes cambiar la url en wp-options y luego correr el script, porque entonces no te va a cambiar el campo en wp-options, aunque creo que no haya problemas, pero es para evitarte un paso.

    Por ejemplo, supongamos que en este momento lo tienes en local y que en el wp-options aparece como la url del blog: http://127.0.0.1/pruebas/ y resulta que lo quieres cambiar al dominio http://www.pruebas.com que esta en tu hosting.

    Lo que haces es que pones a funcionar el script como te dice hasta el punto que tienes que hacer el cambio. Allí pones en el primer campo http://127.0.0.1/pruebas y en el segundo http://pruebas.com.

    De este modo el buscará en tu base de datos cada uno de los lugares donde aparece el texto 1 (http://127.0.0.1/pruebas) y lo reemplazará por el texto 2 (http://pruebas.com).

    Al mismo tiempo tendrá en cuenta lo de la serialización, que es la causa principal de porque usar ese script y no hacerlo manualmente.

    Lo de las imágenes es posible que las hayas ingresado manualmente en algunos de tus posts y las hayas enlazado de otra forma y al hacer el reemplazo no hizo el cambio por que no era similar al texto que pusiste.

    Camilo
    gracias de nuevo
    lo hice con el script, no cambié nada manualmente y sigo con el mismo problema
    reemplacé http://midominio.com por http://localhost/midominio que es donde tengo los archivos
    lo de las imágenes veo que añade un dominio previo a la url real, no subí yo las imágenes así que podría ser lo que dices

    Hola,
    a ver si lo que te está dando problemas es el archivo .htaccess. Si te has bajado todos los archivos del sitio te habrás bajado también el .htaccess. Te pongo un par de ejemplos.

    Archivo .htaccess para http://midominio.com:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Archivo .htaccess para http://localhost/midominio:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /midominio/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /midominio/index.php [L]
    </IfModule>
    
    # END WordPress

    Por lo demás el proceso es el que ya ha explicado camilobuitrago:

    1.- Copia de seguridad de la base en el servidor
    2.- Descarga de los archivos
    3.- Importar copia de seguridad en local
    4.- Ejecutar el script (muy bueno por cierto) para cambiar las urls
    5.- Si procede (si hemos descargado el sitio entero), cambiar el archivo .htaccess

    Los pasos son los mismos, cambiando server por localhost, para volver a poner tu sitio en el servidor.

    Un saludo

    Yo he seguido todos los pasos incluido cambiar el htaccess y sólo veo en local la pagina de inicio , cualquier otro link , me salta error 404.
    No se que hago mal. No hay manera de tener un clon de la web del servidor en local. !! ya no se que hacer..!!

    Gracias

    ¿Tienes activados los enlaces permanentes?
    Mira también la tabla «posts» en el campo guid a ver lo que tiene.

    Si en el apartado «ajustes comunes», tengo activada la opcion de Nombre entrada.
    En el apartado «opcional», tengo asignada la entrada «categoria», en la opcion Base enlace permanente de la categoría del producto
    y en el apartado «Base enlaces permanentes de productos», tengo marcada la primera opcion Predetermindado.

    En la tabla «posts», en el campo guid, tiene los valores de las url predetermindado , asi http://localhost/bocateriabaiona/?p=17 ; pero al ponerla en el navegador, el wordpress la cambia (lógicamente) por la url con el nombre, ( ya asi esta activada en ajustes comunes).

    Resumiendo estoy por cargarmelo todo, instalar un wordpress vacio y despues ir copiando las carpetas de los plugins y el theme en su sitio y finalmente refrescar la bd con la que tengo en el servidor. ¿ te parece un buen plan ?

    Gracias

    hola,
    quiero dar gracias a este foro, me ha ayudado a resolver el problema que era el mismo, iba a home y se veía pero los links me iban a la pagina de xampp.
    Con la respuesta de maperezotero lo he solucionado. Cambié el wp-options de forma manual y el .htacces tenía el problema que se me veía así:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    faltandome el nombre del dominio:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /nombrecarpeta
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /nombrecarpeta/index.php [L]
    </IfModule>

    # END WordPress

    Le puse nombre carpeta pq. solamente escribimos el nombre que ponemos despues de localhost en el servidor para verlo, en mi caso es de remoto a localhost, sino a la inversa no sería lo mismo. Lo incluyo aquí pq. tuve dudas en poner midominio ponía con www. o http y me daba error.

    Gracias!

    A ver si se puede marcar este tema como solucionado.

Viendo 13 respuestas - 1 de 13 (de 13 total)
  • El debate ‘copia del servidor remoto al local y de vuelta al remoto’ está cerrado a nuevas respuestas.