Soporte » Diseño – Temas y plantillas » Cuando desactivar el modo DEBUG

  • Resuelto kuro

    (@kuro)


    Estoy creando mi primera child theme y desde el principio activé el modo debug en el wp-config:
    define(‘WP_DEBUG’, true);

    El tema es que me ha ido bien mientras iba creando los diferentes archivos php pero aunque todavía no tengo todos los php necesarios para el proyecto me encuentro que tengo problemas instalando o usando plugins. A veces indican que han habido problemas de instalación o a la hora de configurarlos aunque luego parece que sí que se han instalado, el tema es que aparecen mensajes similares al siguiente en la cabecera del panel de administración:

    Notice: bbp_setup_current_user was called incorrectly. The current user is being initialized without using $wp->init(). Please see Debugging in WordPress for more information. (This message was added in version 2.3.) in/home/xxxxxxxx.com/public_html/wp-includes/functions.php on line 3897

    Notice: bp_setup_current_user was called incorrectly. The current user is being initialized without using $wp->init(). === Trace: #6 /home/xxxxxxxx.com/public_html/wp-content/plugins/polylang/admin/admin-base.php(187): get_current_user_id() #7 [internal function]: PLL_Admin_Base->init_user(») #8 /home/xxxxxxxx.com/public_html/wp-includes/plugin.php(525): call_user_func_array(Array, Array) #9 /home/xxxxxxxx.com/public_html/wp-settings.php(340): do_action(‘setup_theme’) #10 /home/xxxxxxxx.com/public_html/wp-config.php(81): require_once(‘/home/imagocat/…’) #11 /home/xxxxxxxx.com/public_html/wp-load.php(37): require_once(‘/home/imagocat/…’) #12 /home/xxxxxxxx.com/public_html/wp-admin/admin.php(31): require_once(‘/home/imagocat/…’) #13 /home/xxxxxxxx.com/public_html/wp-admin/options-general.php(10): require_once(‘/home/imagocat/…’) in /home/xxxxxxxx.com/public_html/wp-includes/functions.php on line 3897

    Pensaba que el modo DEBUG tenía que dejarlo activado hasta abrir la web al público, ahora está en modo mantenimiento.

    Si lo desactivo se que queda solucionado pero no se si es normal porque todavía no he acabado de crear todos los php necesarios y ahí sí que veo útil tener activada esta opción.

    Espero puedan guiarme con este tema.

    Muchas gracias

Viendo 2 respuestas - de la 1 a la 2 (de un total de 2)
  • Moderador almendron

    (@almendron)

    1.- Los errores y avisos no se solucionan por el hecho de desactivar el debug. Siguen allí aunque no te salgan esos avisos.
    2.- Lo correcto es ver cuál es el problema e intentar resolverlo si es que se puede. En el caso de plugins es complicado pero ten en cuenta que las noticias son solo avisos y que no significa que produzcan errores. Otra cosa es que te aparecieran avisos de errores. Entonces debería plantearte si usas o no ese pulgin en concreto.
    3.- Deja activo el debug hasta que publiques el sitio.
    https://codex.wordpress.org/es:Depurar_en_WordPress

    Iniciador del debate kuro

    (@kuro)

    Muchas gracias almendron por tu rápida repuesta. Desconocía todo eso que comentas.

    El único plugin que se comenta en esos avisos es Polylang que necesito para tener los 4 idiomas de la web que estoy creando.

    Muchas gracias por todo.

    Saludos

Viendo 2 respuestas - de la 1 a la 2 (de un total de 2)
  • El debate ‘Cuando desactivar el modo DEBUG’ está cerrado a nuevas respuestas.