• hola a todos

    el tema decision no me admite los caracteres especiales (ñ y acentos) en los encabezados (etiquetas h) lo cual es un problema ya que no me permite ponerlos en el titulo de las entradas del blog.

    En el resto si que se puede.

    Agradeceria si alguien me pudiese dar alguna ayuda en caso de que le haya sucedido.

    Gracias a todos y que vaya bien

Viendo 3 respuestas - de la 1 a la 3 (de un total de 3)
  • ¿Qué codificación tienes?

    Ver: (/wp-admin/options-reading.php) –> «Codificación para páginas y feeds»

    Si pones UTF-8 no debería haber problemas

    Iniciador del debate josancin

    (@josancin)

    Hola Luis:
    Muchas gracias por responder.
    Si, eso lo tenia bien.

    Te comento:
    aqui puedes ver lo que digo: http://hdosoconsultores.com/prueba/blog-especializado/
    en la primera entrada escribi níño y como ves no sale ni el acento ni la ñ sin embargo el widget de las entradas si que lo muestra bien:

    El codigo de la plantilla del blog es:

    Intentare estudiarlo a ver si consigo averiguar el porque y si no escribire a la empresa que hizo decision, muchas gracias por tu ayuda de todos modos:

    <?php
    /**
    * Template Name:blog_es_right_sidebar
    */
    get_header();?>
    <?php include (TEMPLATEPATH.’/get-option.php’);?>
    <div id=»page»>
    <div id=»container»>
    <div class=»page-wrapper»>
    <div class=»page-w600″>

    <div class=»space h10″></div>
    <!– get Cat ID –>
    <?php $cat_id = get_post_meta($post->ID, «cat-id-blog», true); ?>
    <?php $blog_item_number = get_post_meta($post->ID, «port-cat», true); ?>
    <?php query_posts(‘category_name=tecnico’);?>
    <?php if(have_posts()) : ?>
    <?php while(have_posts()) : the_post();?>
    <div class=»blog-sidebar-wrapper»>
    <!– post container –>

    <?php
    $image_id = get_post_thumbnail_id();
    $image_url = wp_get_attachment_image_src($image_id,’large’, true);
    ?>
    <?php if($image_id==null):?>

    <?php else:?>
    <div class=»frame h125 w210 hover mt7 mr30 alignleft»>

    «>
    <img src=»<?php bloginfo(‘template_directory’); ?>/scripts/timthumb.php?src=<?php echo $image_url[0] ;?>&h=125&w=210&zc=1″ alt=»<?php the_title(); ?>» />

    </div>
    <?php endif ?>
    <div class=»blog-sidebar-content»>
    <!– Title –>
    <div class=»title-wrapper»>
    <div class=»title»>
    <h2>
    «>
    <?php the_title();?>

    </h2>
    </div>
    </div>
    <?php postDate();?>
    <div class=»meta-left-full»>
    <?php echo mb_substr(get_the_excerpt(),0,230);?>
    </div>

    <?php //end blog sidebar content ?>
    </div>
    <div class=»space h27″></div>
    <div class=»divider»></div>
    </div>
    <?php endwhile?>
    <?php endif ?>
    <div class=»space h15″></div>
    <?php if (function_exists(«pagination»)) {
    global $additional_loop;
    pagination($additional_loop->max_num_pages);
    } ?>
    </div>
    <?php get_sidebar(‘single’)?>

    </div>
    </div>
    </div>
    <?php get_footer();?>

    Hola josancin!

    esto se debe a que la plantilla usa la biblioteca CufonText para cambiar la fuente de los títulos mediante JavaScript, los acentos no se ven debido a que la fuente que usa CufontText es probable que no soporte acentos del español.

    Sin embargo algunos temas que usan esta característica poseen un panel de control desde donde se puede deshabilitar esta funciona, si el tema no cuenta con esta caracteristica, hacerlo manualmente como tu lo hiciste y ademas de esto, editar el archivo header.php o functions.php en busca de la linea script que incorpora Cufontext la linea de código es así:

    <script type='text/javascript' src='http://hdosoconsultores.com/prueba/wp-content/themes/decision/js/cufon.js?ver=3.4'></script>

    Y borrarla!

    Saludos

Viendo 3 respuestas - de la 1 a la 3 (de un total de 3)
  • El debate ‘decision’ está cerrado a nuevas respuestas.