Soporte » Plugins y Hacks » Deprecated: ¿Cómo corregir el error?

  • Hola tengo el siguiente mensaje en la web:

    Deprecated: ¡La función _register_controls ha quedado obsoleta desde la versión 3.1.0! Usa Elementor\Controls_Stack::register_controls() en su lugar. in /home/xoazakhq/public_html/wp-includes/functions.php on line 5379

    Voy a la ubicación señalada y en lugar de encontrar _register_controls lo que está escrito es E_USER_DEPRECATED y al copiar Elementor\Controls_Stack::register_controls() en su lugar, no se corrige el error.

    ¿Qué debería hacer?

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 3 respuestas - de la 1 a la 3 (de un total de 3)
  • Moderador almendron

    (@almendron)

    1) Edita el archivo wp-config.php (haz primero copia de seguridad) y buscar la línea

    define( 'WP_DEBUG', true );

    y donde pone true cambiar por false.

    Esto no resuelve el problema. Solo oculta el mensaje.

    2) El error es muy probable que sea debido a un plugin: ¿tienes todos actualizados?

    Iniciador del debate asalba

    (@asalba)

    Hola, gracias por la idea, ahora ya no se muestra el error, entiendo que sigue allí, pero es menos molesto.

    Sí en realidad la página reportó un error crítico (pantalla blanca incluída) cuando actualicé todos los plugins. «My Shop Kit Popup Smart Bar Slide In» fue el plugin que originó el error crítico que inutilizó la web. Quité el plugin y lo volví a instalar, pero no lo activé. Pensé activarlo luego de que se vuelva a actualizar.

    Moderador almendron

    (@almendron)

    Así es. El error sigue allí.

    Es posible que algún otro plugin esté dando ese error. Yo haría lo siguiente:

    1) Vuelve a poner true

    2) Desactiva TODOS los plugins.

    3) Comprueba si el error ha desaparecido. Si es así, ve activando-comprobando plugin a plugin hasta encontrar al culpable.

Viendo 3 respuestas - de la 1 a la 3 (de un total de 3)
  • Debes estar registrado para responder a este debate.