Soporte » Instalación – Actualizaciones » Duda Novato Temas, Plugins y Versiones WP—Ayuda

  • Buen día a todos, en los últimos meses he tenido varios problemas con WP.

    Tenia instalado la versión 4.9.8, pero al ir actualizando plugins he tenido problemas, el Tema que uso es compatible con hasta la versión 5.4.12, entonces estuve actualizando la versión de forma MANUAL algunas veces y he dejado la versión 5.4.11, he tenido problemas de lentitud, en parte por el Hosting y en parte por los plugins, en especial por el plugin All in One SEO y ahora también un poco con Really Simple SSL y Smash Balloon Instagram Feed.

    Estuve actualizando de forma Manual por que si actualizo de forma «Normal» se actualizaría a la versión 6.2 de WP y entonces según mi lógica el tema que uso se deshabilitara, es así?

    Pregunto esto por que una vez puse un tema que en teoría no era compatible con la versión 5.4 de WP y vi que si funcionaba, entonces si actualizo de forma «normal» a la 6.2 el tema que tengo actualmente funcionara? (el tema no fue hecho para Gutemberg).

    Mi esperanza es que si realizo de forma normal la actualización los problemas acabaran, pero no quiero hacerlo hasta consultar con ustedes.

    Por otro lado retomando el problema con los plugins me he percatado que cuando genero una entrada y quiero poner una imagen principal, no me deja se queda en blanco la biblioteca y no aparece nada hasta que DESHABILITO All in One SEO, después de eso ya aparecía la biblioteca, ahora por desgracia tengo q hacerlo con otros plugins que he mencionado.

    Al checar los errores en la consola me aparecía por ejemplo:

    He contactado al soporte de All in One SEO y me dicen que le pida al Hosting subir mi memoria de 256M a 512M

    Les agradezco la ayuda respecto a mi duda con la compatibilidad de temas para WP y versiones de WP

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 3 respuestas - de la 1 a la 3 (de un total de 3)
  • Angel Aparicio

    (@angel_aparicio_gomez)

    Hola, pues la respuesta es «depende del tema». Es posible que exista una versión actualizada del tema que sea compatible con WordPress 6.X

    ¿Qué tema es? Si es un tema del repositorio (https://es.wordpress.org/themes/) seguramente tenga una versión actualizada.

    Lo ideal es tener siempre la última versión de WordPress. Porque si no vas a tener problemas de compatibilidad con los plugins, o no vas a poder actualizar los plugins.

    Una cosa que puedes probar es a sacar una copia de pruebas de la web (Con este plugin, por ejemplo: https://es.wordpress.org/plugins/wp-staging/) y actualizar dicha copia, a ver si tu tema es compatible con WordPress 6.X

    De todas formas, a medio plazo, te recomendaría que intentaras buscar un tema que sea compatible con las últimas versiones. Mantener un WordPress obsoleto no suele ser buena idea.

    Iniciador del debate smash598

    (@smash598)

    Hola Angel, gracias por comentar respecto al tema que tengo, con WP, sus versiones y el tema que uso.

    «¿Qué tema es? Si es un tema del repositorio (https://es.wordpress.org/themes/) seguramente tenga una versión actualizada.»

    El tema es :

    https://themeforest.net/item/inlife-simple-flexible-blogmagazine/15144801

    Se quedaron en la versión 5.4 de WP

    «Una cosa que puedes probar es a sacar una copia de pruebas de la web (Con este plugin, por ejemplo: https://es.wordpress.org/plugins/wp-staging/) y actualizar dicha copia, a ver si tu tema es compatible con WordPress 6.X»

    Voy a revisar ya que si no es compatible y realizo un Downgrade puede que no quede bien.

    «De todas formas, a medio plazo, te recomendaría que intentaras buscar un tema que sea compatible con las últimas versiones. Mantener un WordPress obsoleto no suele ser buena idea.»

    Si, ya tengo un tema que me puede funcionar pero es para la versión 6.1 🙁 , aun no lo actualizan para la versión 6.2, pero aun tengo la duda de un tema hecho para una versión inferior de WP puede funcionar con una versión mas actual?

    Angel Aparicio

    (@angel_aparicio_gomez)

    Mmmm, en principio si un tema es compatible con una versión «mayor» (6.X) debería funcionar con las versiones menores.

    Es decir, un tema compatible con 6.1 debería funcionar con 6.2.

Viendo 3 respuestas - de la 1 a la 3 (de un total de 3)
  • Debes estar registrado para responder a este debate.