• Resuelto Ana Cirujano

    (@acirujano)


    Hola, buenas, compañeros/as, a ver si me podéis echar una mano, por favor.

    Me aparece en WooCommerce este mensaje:

    «El directorio de subidas de tu tienda es navegable a través de la web. Te recomendamos encarecidamente que configures tu servidor web para impedir la indexación de directorios.»

    He consultado con mi hosting y me dicen:

    ___________
    He verificado que ambos

    /wp-content/uploads/woocommerce_uploads

    y

    /wp-content/uploads/

    devuelve la página 403 Forbidden Error como deberían.

    Sin embargo, he visto la documentación en el siguiente artículo:

    https://docs.woocommerce.com/document/digital-downloadable-product-handling/#protecting-your-uploads-directory

    Parece que el mensaje que recibes es porque WooCommerce requiere que agregues código personalizado al servicio NGINX en el servidor en el que está alojado tu sitio.

    Esto no es posible en nuestros servidores ya que usan un entorno personalizado de hosting interno.

    Sin embargo, ten en cuenta que el código solo es necesario si el servidor web en el servidor era NGINX.

    No usamos el servidor NGINX en nuestra configuración – usamos Apache como nuestro servidor web.

    El servicio NGINX está configurado solo como proxy inverso, que es diferente y no requeriría el código anterior.

    Por lo tanto, consulta con el equipo de soporte de WooCommerce cómo sin cambios en la configuración del servidor puedes configurar tu carpeta de subidas para que no sea accesible. Si las reglas de Apache son suficientes, pídele al equipo de soporte de WooCommerce que elimine la advertencia en el sitio web.
    _________________

    ¿Tenéis alguna pista sobre esto o me recomendais que lo consulte en el foro de WooCommerce oficial?

    Muchas gracias de antemano por vuestra ayuda 🙂

    Ana

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • Moderador Fernando Tellado

    (@fernandot)

    Hola @acirujano

    Para curarte en salud crea un .htaccess dentro de wp-content y métele esto:

    Options -Indexes

    Luego prueba a ver si sigue dando error.

    Iniciador del debate Ana Cirujano

    (@acirujano)

    Gracias, Fernando.
    Hecho, y sigue dando el mismo error…
    ¿Será un bug de WooCommerce? 🤔

    Moderador Fernando Tellado

    (@fernandot)

    Copia el .htaccess y lo metes también en las carpetas que te dan error a ver.

    No me suena que sea error común en WooCommerce, a mi (y mis clientes) al menos no me ha pasado nunca, primera vez que lo veo

    Moderador Fernando Tellado

    (@fernandot)

    A ver, mas posibles soluciones… 

    Prueba a meter esto en el functions.php

    add_filter( 'uploads_directory_is_public_notice', '__return_false' );

    Si no rula pregúntale al hosting si tienes esos directorios con autoindex off;

    Otro posible apaño sería cambiarles los permisos a 750.

    Si no, pues pasamos a otro experimento … 

    Instala el plugin «Transients Manager»:
    https://es.wordpress.org/plugins/transients-manager/

    1) Lo instalas y lo activas
    2) Ve a Herramientas > Transients
    3) Busca por «_woocommerce_upload_directory_status»
    3) Edita el valor del transient de «unprotected» a «protected»

    y si ni con esas, entonces hay en github un apaño para el archivo que genera esos avisos:

    https://github.com/woocommerce/woocommerce/pull/26600/commits/a240798362c693a8997e724acfac77dfd8a8879c

    Como solemos decir aquí … espero haberte ayudado 😉

    Iniciador del debate Ana Cirujano

    (@acirujano)

    Hola, Fernando.

    Se ha solucionado el problema instalando el plugin Transients Manager y siguiendo los pasos que me has indicado.

    ¡Muchas gracias por tu ayuda!

    Ana

    Iniciador del debate Ana Cirujano

    (@acirujano)

    ¿Puedo desinstalar el plugin Transients Manager o necesito tenerlo instalado? 🙂

    Moderador Fernando Tellado

    (@fernandot)

    Pues nada, me alegro 🙂

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)

El debate ‘El directorio de subidas de tu tienda es navegable a través de la web’ está cerrado a nuevas respuestas.