Soporte » Guías – Resolución de problemas » Embeds de Youtube no aparecen en WordPress

  • Resuelto juanpe3

    (@juanpe3)


    Muy buenos días,

    Tengo un problema con mi sitio de WordPress. Resulta que los vídeos de Youtube que pongo en el editor visual de las entradas no aparecen en el post una vez publicado.

    Este es un ejemplo del proceso que sigo para subir el embed y el resultado final:

    1. https://prnt.sc/26lckpk

    2. https://prnt.sc/26lckyy

    Vista previa del borrador (=que en la entrada publicada):

    3. https://prnt.sc/26lcl7a

    Como veis, el vídeo no aparece, lo que me hace sospechar que es un problema del bloque de Youtube del editor visual. Cuando pongo los vídeos como HTML personalizado, con el enlace de incrustación de Youtube, aparecen perfectamente.

    Esto me sucede en casi todas las entradas de la web, como esta, donde solo se ven espacios en blanco donde deberían salir los vídeos en el navegador de los usuarios:

    Vídeo al editar:

    1. https://prnt.sc/26lcmh3

    Vídeo final publicado:

    2. https://prnt.sc/26lcmwp

    El caso es que los vídeos se veían antes, pero el problema llegó cuando migré el sitio a un host de Ionos el año pasado, ¿puede ser ese el problema?

    He probado a eliminar Elementor por si había algún conflicto con las páginas, pero solo ha cambiado una entrada, en la que ahora sí pueden verse los vídeos:

    https://tuwebanime.com/articulos/historia-del-anime/series-peliculas-anime-90/

    He intentado explicar el problema lo mejor posible, si tenéis cualquier duda solo tenéis que escribir. Espero respuesta. ¡Gracias chicos!

    Un saludo.
    Juan

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 13 respuestas - de la 1 a la 13 (de un total de 13)
  • Moderador Jose Luis

    (@jose64)

    Hola.

    Desactiva cualquier plugin de optimización o cache que tengas instalado, por ejemplo el Autoptimize, limpia la caché y haz la prueba, si no te funciona desactiva la carga diferida (yo estoy haciendo pruebas con la carga diferida sin problemas).

    Comenta el resultado de tus pruebas y, por favor, recuerda marcar como resueltos los debates cuando así sea, de esta forma nos ayudas a mantener el foro al día.

    Iniciador del debate juanpe3

    (@juanpe3)

    Gracias José Luis, lo pruebo ahora y te digo.

    Iniciador del debate juanpe3

    (@juanpe3)

    He desactivado Autoptimize, WP Super Caché y Smush por si acaso, además de la carga diferida de imágenes, pero siguen sin verse los vídeos. También he limpiado la caché pero nada…

    El caso es que cuando pongo el código de inserción de los vídeos en un HTML personalizado me salen bien en la previsualización:

    1. Vídeo insertado en la entrada:

    https://prnt.sc/26lynbl

    2. Previsualización en borradores y publicado:

    https://prnt.sc/26lynhh

    ¿Se os ocurre alguna otra solución? Gracias.

    • Esta respuesta fue modificada hace 10 meses por juanpe3.
    • Esta respuesta fue modificada hace 10 meses por juanpe3.
    Moderador Jose Luis

    (@jose64)

    ¿Y por qué no los pones de esa forma? Yo estoy haciendo pruebas y no tengo mayor problema, aparte de eso, con el inspector de elementos estoy viendo en tu página varios errores, uno producido por Autoptimize (un error de JavaScript) y otros de YouTube por un vídeo con la url incorrecta (error 410, no disponible).

    Aparte de eso, en la página que estoy revisando se ven todos los vídeos: https://tuwebanime.com/articulos/historia-del-anime/series-peliculas-anime-90/

    Iniciador del debate juanpe3

    (@juanpe3)

    Gracias José Luis, sí, podría ponerlos así pero tengo más de 50 vídeos en la web y si hubiera alguna forma de solucionar el problema de raíz podríamos ahorrarnos todo ese tiempo de ponerlos manualmente y tener que redimensionarlos.

    Seguiré buscando soluciones, en esa página sí se ven los vídeos, creo que porque fue la última que publiqué, pero en el resto de las páginas como estas dos solo salen espacios en blanco:

    https://tuwebanime.com/articulos/historia-del-anime-v-series-70-80/

    https://tuwebanime.com/articulos/top-7-peliculas-de-yoshiaki-kawajiri-de-mejor-a-peor/ (aquí deberían aparecer debajo de cada título de película, yo los veo todos en la entrada de WordPress cuando la edito pero no en el artículo final).

    La verdad es que es súper frustrante. Miraré lo que dices de Autoptimize y los errores de vídeos.

    Si te parece bien podemos darnos dos días o así para resolverlo y si no podemos cerrar este hilo del foro. Muchas gracias, a ver si podemos darle una buena solución.

    • Esta respuesta fue modificada hace 10 meses por juanpe3.
    • Esta respuesta fue modificada hace 10 meses por juanpe3.
    • Esta respuesta fue modificada hace 10 meses por juanpe3.
    Moderador Jose Luis

    (@jose64)

    Hola, de incordio nada, no te preocupes por eso.

    Es posible que aunque desactivases Autoptimize se mantengan las páginas en caché, actívalo, vacía la caché, desactívalo y haz la prueba. Ahora WordPress incluye la carga diferida por defecto y es posible que tenga algún conflicto con lo que tengas en caché.

    Haz la prueba y pon una url donde no se vea bien, así lo seguimos revisando en una página que de problemas

    Iniciador del debate juanpe3

    (@juanpe3)

    Vale, gracias de nuevo José. He seguido los pasos y sigue sin verse. Si viene la carga diferida por defecto a lo mejor puede ser eso, ¿hay alguna forma de desactivarla desde WordPress?

    Podemos verlo en este artículo, es el que más visitas tiene y el más currado, también el que tiene más vídeos seguramente:

    https://tuwebanime.com/articulos/historia-del-anime-v-series-70-80/

    Moderador Jose Luis

    (@jose64)

    Estoy viendo una de las urls que pones, el video aparece pero con una altura de 0px, por eso no se ve, lo que no veo es la razón. El hecho de que la última publicación se vea bien y las anteriores no es lo que me hace pensar que seguramente se trate de algún problema de caché u optimización

    Moderador Jose Luis

    (@jose64)

    Para desactivar la carga diferida tienes un plugin en el repositorio, haz la prueba:

    Disable Lazy Load

    • Esta respuesta fue modificada hace 10 meses por Jose Luis. Razón: corregir enlace
    Iniciador del debate juanpe3

    (@juanpe3)

    Buenas, ya lo he instalado y he desactivado el lazy load en todas las imágenes de la web, sigue sin ir:

    https://prnt.sc/26m0nri

    Es raro lo de la altura de 0 píxeles, ¿sucede solo en un vídeo o en todos los de esa página? Te envío el HTML de dos de los vídeos por si te sirve de guía para ver mejor el problema:

    https://prnt.sc/26m0ozh

    EDIT: He hecho un experimento instalando varios temas y viendo la web en vista previa: se ven todos los vídeos de todos los artículos. A lo mejor es una incompatibilidad con el tema, o algún tipo de código que entra en conflicto con Ocean WP.

    Me sucedió con Elementor. En cuanto lo desactivé ya podía ver los vídeos que sí se pueden ver, los de este artículo: https://tuwebanime.com/articulos/historia-del-anime/series-peliculas-anime-90/

    Tiene que ser algo del tema que crea conflicto con otra cosa (perdona mi abstracción, no domino los términos informáticos jajaja).

    • Esta respuesta fue modificada hace 10 meses por juanpe3.
    • Esta respuesta fue modificada hace 10 meses por juanpe3.
    Moderador Jose Luis

    (@jose64)

    Es posible, puedes hacer la consulta en el foro del tema, ellos seguramente te podrán orientar mejor:

    Support » Theme: OceanWP

    De hecho, lo primero que solemos recomendar es que cambies el tema por uno de los temas por defecto de WordPress, uno de los Twenty, y hagas la prueba para asegurarte de que no sea un problema de compatibilidad del tema.

    Si haces la consulta en el foro de soporte del plugin puedes poner aquí el enlace para que si algún usuario tiene un problema similar pueda seguir la solución.

    Iniciador del debate juanpe3

    (@juanpe3)

    Gracias por la respuesta, este es el link donde he hecho la pregunta, en el foro de Ocean WP. En cuanto sepa la respuesta y resuelva el problema lo dejaré por escrito.

    https://wordpress.org/support/topic/youtube-embeds-not-showing-on-the-webpage/#new-topic-0

    • Esta respuesta fue modificada hace 10 meses por juanpe3.
    Iniciador del debate juanpe3

    (@juanpe3)

    Buenas tardes José Luis, ya está resuelto el problema.

    Resulta que tenía un código CSS customizado que era:

    .wp-block-embed__wrapper:before {
        padding-top: 0!important;
    }

    Lo borré en Apariencia > Personalizar > CSS/JS personalizado y ahora se ven los vídeos, eso sí, en full width o a pantalla ancha. Le he preguntado también cómo se podrían redimensionar, pero creo que con esta información ya podemos cerrar el debate. Muchas gracias por tu ayuda. Un saludo a todos.

    • Esta respuesta fue modificada hace 10 meses por juanpe3.
Viendo 13 respuestas - de la 1 a la 13 (de un total de 13)
  • El debate ‘Embeds de Youtube no aparecen en WordPress’ está cerrado a nuevas respuestas.