Soporte » Guías – Resolución de problemas » Enlaces de fotos a URL’s que no deberían existir

  • Resuelto admsaray

    (@admsaray)



    Buenas,
    Me encuentro con un problema al que no sé darle solución..
    Tengo unas 40 entradas publicadas x 10×15 fotos/imagenes por entrada… aprox 500 fotos que cometí el error de subirlas con URL al archivo multimedia.
    Por lo que tengo unas 500 fotos que tienen un link que no redirige al post/entrada que debería, sino que va a un enlace con sólo la foto…

    Mis preguntas son:
    1- Qué puedo hacer para resolver el problema de estas 500 fotos que redirigen a links “multimedia” y no a los links de las entradas? En este caso, he visto que tengo la opción de cambiarlo uno por uno con “URL personalizada”… hay otra manera?

    2- En este caso, qué puedo hacer para que me desaparezcan estos links que llevan a páginas sólo con la imagen? En la bilblioteca de medios, la URL me parece como NO modificable… y entiendo que si borro la imagen de la biblioteca, me desaparecería de la entrada..
    Por lo que, aunque vaya entrada por entrada cambiando la URL a cada imagen, no consigo que desaparezcan los links a imágenes sueltas porque no las podría borrar ni tampoco modificar.

    3- Por último, qué puedo hacer para que las próximas fotos que suba no me salgan en el momento de subirlas con la URL “bloqueada” y en este formato de ejemplo?
    wp-content/uploads/2018/04/IMG_2972.jpg
    Cuando en realidad lo único que quiero es subir imagen y que esté enlazada al link del post y NO cree un link nuevo…

    Muchas gracias por vuestro tiempo,

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 10 respuestas - 1 de 10 (de 10 total)
  • Moderador almendron

    (@almendron)

    No acabo de entender el problema.

    Entro en tu sitio, veo una primera entrada (La Búsqueda de Nuestra Casa Rodante) y hago clic en la imagen. Eso me lleva a la entrada propiamente dicho. Hasta aquí todo normal.

    Ya estoy en la entrada “La Búsqueda de Nuestra Casa Rodante” y allí hay unas cuantas imágenes. Aquí veo un primer problema que no tiene nada que ver con lo que explicas.
    Esa primera imagen está puesta a “Tamaño completo” lo que provoca que luego tenga que ser escalada[(4.089px × 2.211px (escalado a 955px × 516px)]

    Ninguna de las imágenes que has puesto en esa entrada están enlazadas (haces clic en ellas y no se abre ninguna nueva imagen o entrada).

    En cuanto a “wp-content/uploads/2018/04/IMG_2972.jpg”, es lo normal. Los exploradores necesitan saber la ruta de la imagen para poder mostrarla.

    Moderador almendron

    (@almendron)

    Yo te aconsejo lo siguiente:

    1) Ajustes > Medios y en “Tamaño grande” pones 955 de ancho y 0 (cero) de altura.

    2) Cuando insertes una imagen en un entrada, seleccionas “Grande” en “Tamaño”. De esta forma se insertará la imagen a ese tamaño con el consiguiente ahorro de tiempo de respuesta.

    3) Si quieres que esa imagen se pueda abrir luego a tamaño completo, en el apartado “Enlazado a” seleccionas “archivo multimedia”. Luego es conveniente usar algún plugin, como Easy FancyBox, para que se abra de forma más bonita.

    Buenas Almendron,

    Gracias por tu respuesta. Tomaré en cuenta lo que me comentas sobre las imágenes. El tema es que en este post que comentas, no encuentro mi “problema”, te pongo otro ejemplo donde sí que lo veo… aunque no entiendo la diferencia porque todo lo hice igual

    Si pongo en google: “descubre mi mundo cecos”, el primer enlace al que me lleva es al post:
    http://www.descubremimundo.com/perderse-cecos-paraiso-verde-asturias/

    Hasta aquí bien… el problema son los siguientes links que salen en Google… que no deberían existir, deberían enlazar al post directamente, y enlazan a páginas de nuestro blog que sólo sale la imagen… ejemplo:
    http://www.descubremimundo.com/perderse-cecos-paraiso-verde-asturias/cecos_10/

    Estoy en el punto que sé como poner estas imágenes que enlacen directamente al post, que es en la misma entrada y en opciones de imágenes -> link personalizado -> enlazo al post.
    El problema es que aunque haga esto, el link no desaparece porque el problema viene desde el momento que subo esta foto a biblioteca de medios y no le pongo la URL correspondiente, no?

    Muchas gracias por tu tiempo,

    Moderador almendron

    (@almendron)

    Sube las imágenes como siempre, es decir, mediante “Añadir objeto” y teniendo en cuenta lo que ya te he comentado respecto a los tamaños.

    El problema no tiene nada que ver con lo anterior sino con lo que te indexa Google. Resulta que WordPress genera una “página de adjuntos” de forma automática y Google después las indexa.

    ¿Solución? La más sencilla es aplicar una redirección 301 de forma que, al hacer clic en el enlace del adjunto, te lleve a la entrada. Y para ello, lee http://www.samuelaguilera.com/post/redireccionar-paginas-adjuntos-wordpress
    e instala el plugin que te recomiendan: https://wordpress.org/plugins/attachment-pages-redirect/

    • Esta respuesta fue modificada hace 7 meses, 2 semanas por  almendron.

    Millones de gracias…!
    Con este pluggin de Redirect Pages que me has recomendado ya he conseguido que se vayan los links a las entradas que tocan. 🙂

    También te he hecho caso y me he instalado el pluggin Easy FancyBox y lo he aplicado a esta entrada:
    http://www.descubremimundo.com/fuentelsaz-un-pueblo-pintoresco/

    He cambiado lo de “tamaño grande a 955 y 0 como me habías comentado (entiendo que para que salgan predeterminadas las que ponga a ese tamaño).

    He conseguido que las 3 fotos del link se pongan al tamaño que me indicabas, pero l problema que tengo ahora es la “imagen destacada” (la primera de cada post). Esta imagen se tiene que quedar como en el post que te indico, o hay alguna manera de ponerla igual que las demás?

    Vuelvo a darte las gracias por tu tiempo!
    Saludos

    Moderador almendron

    (@almendron)

    Esa primera imagen: ¿cómo la pones? Me da la impresión que es cosa de la plantilla.

    Sí, yo también creo que es cosa de la plantilla/tema que tengo.

    Para subir la imagen destacada… en el mismo post, le doy a “establecer imagen destacada”, subo el archivo, la recorto (para que únicamente se vea el cartel y nuestras caras en el slider de la pagina de inicio), y ya está…

    Es muy pesada? Ves algún problema/solución?

    Moderador almendron

    (@almendron)

    Tiene solución pero habría que editar alguno de los archivos del tema y el problema es que usas una plantilla comercial y no tengo acceso a ella. Deberías ponerte en contacto con el soporte del tema y pedirles una solución.

    De todas formas, siempre puedes coger la imagen, editarla con algún programa, recortarla a 1024 px de anchura y ya luego subirla a WordPress con esa tamaño.

    Perfecto, me pondré en contacto con ellos y si no me dieran solución, haría lo segundo.

    Muchísimas gracias por toda tu ayuda, me ha sido muy útil.

    Un saludo,

    Moderador almendron

    (@almendron)

    De nada. Un saludo.

Viendo 10 respuestas - 1 de 10 (de 10 total)
  • El debate ‘Enlaces de fotos a URL’s que no deberían existir’ está cerrado a nuevas respuestas.