Soporte » Guías – Resolución de problemas » Enlaces permanentes con «nombre de la entrada» no funcionan

  • Resuelto ulisesflores

    (@ulisesflores)


    Buen día:

    El sitio lo realice desde cero con Elementor Pro directamente en la ip del servidor (http://44.238.71.236) es decir sin conectar a el dominio (ya que estaba dirigido a un antiguo servidor), antes de redirigir el dominio los enlaces permanentes funcionaban perfecto en la opción «Nombre de entrada».

    Después de conectar el dominio ya con el certificado SSL activado y después de configurar los redireccionamientos y establecer la nueva url para el sitio, los enlaces permanentes dejaron de funcionar con la opción «Nombre de la entrada»

    Mi archivo .htaccess:

    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301,NE]
    Header always set Content-Security-Policy «upgrade-insecure-requests;»

    # BEGIN WordPress
    # Las directivas (líneas) entre «BEGIN WordPress» y «END WordPress» son
    # generadas dinámicamente y solo deberían ser modificadas mediante filtros de WordPress.
    # Cualquier cambio en las directivas que hay entre esos marcadores serán sobrescritas.

    # END WordPress

    Al hacer clic en cualquier link con «Nombre de la entrada» activado, me envía a la página con el enlace y aparece error 404:
    Not Found
    The requested URL /quienes-somos/ was not found on this server.

    En enlaces permanentes configurados con la opción «Simple» toda la pagina funciona perfectamente.

    Saludos y de antemano gracias por la ayuda.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • Moderador Jose Luis

    (@jose64)

    Hola.

    Bienvenido al foro de soporte. Tienes que regenerar los enlaces permanentes porque no tienes directivas entre el Begin y el End WordPress. Puedes renombrar el archivo para que WordPress vuelva a generarlo, entras en enlaces permanentes, cambias y guardas.

    Coméntanos si así lo solucionas y, por favor, recuerda cerrar el debate marcándolo como resuelto cuando así sea, de esta forma nos ayudas a mantener el foro al día.

    Iniciador del debate ulisesflores

    (@ulisesflores)

    Buenas tardes, gracias por la ayuda.

    Modifique el nombre del archivo .htaccess
    cambie el los enlaces y guarde
    No se regenero el archivo .htaccess

    tendrá que ver con los permisos de la carpeta?
    mi carpeta html tiene permisos drwxr-xr-x
    el archivo .htaccess -rw-r-r–

    Moderador Jose Luis

    (@jose64)

    Hola.

    Te dejo el enlace a la documentación donde se explica los permisos correspondientes:

    Carpetas / Archivos Core > Permisos de archivos

    Modificar los permisos de ficheros

    Prueba cambiando los permisos de la carpeta html a 755 (rwx-rx-rx)

    Iniciador del debate ulisesflores

    (@ulisesflores)

    Ya he realizado los pasos que me comentas y se regenero el archivo .htaccess

    # BEGIN WordPress
    # Las directivas (líneas) entre «BEGIN WordPress» y «END WordPress» son
    # generadas dinámicamente y solo deberían ser modificadas mediante filtros de WordPress.
    # Cualquier cambio en las directivas que hay entre esos marcadores serán sobrescritas.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Pero me sigue apareciendo el error al momento de usar «Nombre de la entrada» en los enlaces permanentes.

    ¿Alguna otra sugerencia?

    Iniciador del debate ulisesflores

    (@ulisesflores)

    Ya resolví el problema, les comento la solución:

    En mi caso el servidor es un Apache.

    Modifique el archivo httpd.conf en las partes de las siguientes lineas:

    AllowOverride None => AllowOverride All

    <Directory «/var/www»>
    AllowOverride All
    # Allow open access:
    Require all granted
    </Directory>

    y

    <Directory «/var/www/html»>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
    </Directory>

    Estos ajustes resolvieron mi problema.

    Basado en el siguiente post: https://juliorestrepo.wordpress.com/2020/02/11/wordpress-permalinks-no-funcionan/#comment-5834

    Saludos, marco como resuelto.

Viendo 5 respuestas - de la 1 a la 5 (de un total de 5)
  • Debes estar registrado para responder a este debate.