• Hola,
    Tengo un problema en la web con plantilla AVADA con los enlaces permanentes. Después de instalar un plugin de idiomas «Polylang» y duplicar las páginas de español a inglés. Aparecen estas con ERROR 404, no encuentra la página.
    No parece ser problema del servidor, ya que con otro tipo de enlaces las páginas funcionan correctamente.
    A que puede deberse que con este tipo de enlaces permanentes aparezca error, pero por ID funcione correctamente.
    He eliminado el plugin pero sigue sin funcionar los enlaces permanentes.
    Gracias, un saludo,

Viendo 6 respuestas - de la 1 a la 6 (de un total de 6)
  • Moderador LGrusin

    (@lgrusin)

    Prueba actualizar el enlace permanente aunque no hayas modificado nada.

    Un saludo

    Iniciador del debate wordsrpinkpress

    (@wordsrpinkpress)

    Hola LGrusin,
    Gracias por la respuesta.
    ¿Actualizar el enlace permanentes? No entiendo, si puedes explicármelo detalladamente.
    Gracias, un saludo.

    Moderador LGrusin

    (@lgrusin)

    Es habitual cuando hay cambios en las URLs, bien por algún plugin o por el uso de Custom Post Types, que haya que actualizar la reescritura de URL.

    No sé si será tu caso pero puedes probar en el menú Ajustes – Enlaces Permanentes, y sin modificar nada, darle al botón Guardar cambios. De esta forma WordPress actualiza los enlaces permanentes.

    Un saludo

    Iniciador del debate wordsrpinkpress

    (@wordsrpinkpress)

    Muchas gracias @lgrusin,
    Sigue sin funcionar, solo funcionan los enlaces simples.
    El soporte de la plantilla me comenta: I reviewed the .htaccess already and it was clean however the problem would be on the server relating to using custom permalinks. Only default permalinks are working, if you don’t want to use custom permalink then keep using default permalinks. However its best to contact the website host about the issue.

    Es algo muy extraño, me quedado sin enlances permanentes.
    Una opción seria empezar desde 0, verdad?

    Moderador LGrusin

    (@lgrusin)

    En todo caso a quien debes consultar es a Polylang.
    1 – ¿Está bien configurado Polylang?
    2 – ¿Funcionan los enlaces si desactivas el plugin? ¿y los demás plugins?
    3 – ¿Has probado si ocurre lo mismo con otro tema?
    Lee bien la documentación
    https://polylang.pro/doc/create-languages/

    No es necesario empezar de cero, los enlaces permanentes se pueden eligir a voluntad, nunca se pierden, solo te hacen cambiar la URL.

    Un saludo

    • Esta respuesta fue modificada hace 5 años, 8 meses por LGrusin.
    Iniciador del debate wordsrpinkpress

    (@wordsrpinkpress)

    Hola @lgrusin,
    Borre el plugin Polylang ya que pensé que podía ser el motivo. Todo empezó una vez múltiple las páginas con los idiomas, por eso borre las páginas y el plugin.
    No se dónde puede estar el error… volveré a instalar el plugin.
    Muchas gracias, un saludo.

Viendo 6 respuestas - de la 1 a la 6 (de un total de 6)
  • El debate ‘Enlaces permanentes Error 404’ está cerrado a nuevas respuestas.