Soporte » Guías – Resolución de problemas » Enlaces rotos a Taxonomías (Categorías)

  • Resuelto Dani Serrano

    (@daniserrano)


    Buenos días,

    El problema es que los enlaces a las Categorías de uno de los CPT que tengo en mi web han dejado de funcionar. Cuando accedo a la URL me hace una redirección 301 eliminando parte de la estructura:

    La url original es
    https://wpdesdezero.com/podcast/serie/wordpress-desde-zero/

    Redirecciona a
    https://wpdesdezero.com/podcast/wordpress-desde-zero/

    Por lo que está eliminando «/serie». Sólo me pasa con uno de los 4 CPT que tengo.

    Esta es la información que da el navegador:

    Request URL:https://wpdesdezero.com/podcast/serie/wordpress-desde-zero/
    Request Method:GET
    Status Code:301 Moved Permanently (from disk cache)
    Remote Address:37.59.226.82:443
    Referrer Policy:no-referrer-when-downgrade
    
    Content-Length:261
    Content-Type:text/html; charset=iso-8859-1
    Date:Fri, 20 Oct 2017 05:42:53 GMT
    Location:https://wpdesdezero.com/podcast/wordpress-desde-zero/
    Server:Apache

    Posibles causas.
    Hace poco estuve investigando la opción de Yoast para quitar o conservar la categoría base e los enlaces permanentes. La opción está en «Conservar».

    He probado a volver a guardar los enlaces permanentes después de dejar la opción Conservar.

    Es verdad que lo he advertido un tiempo después de haber andado tocando esa opción, por lo que no estoy 100% seguro que sea por eso.
    También me parece raro que sólo me ocurre en uno de los CPT.
    Y además algo que me parece raro también, es que el slug de esa taxonomía es:

    'rewrite' => array( 'slug' => 'podcast/serie' )

    Por lo tanto no me está eliminando el slug de la categoría, me está eliminando la mitad del slug de la categoría…

    Cuando lo descubrí únicamente me pasaba en un navegador, si utilizaba otro o utilizaba la navegación en modo incógnito no me ocurría, pero esto ha ido cambiando, ahora si pasa incluso me han llegado las alertas de los enlaces rotos.

    ¿Alguien puede echarme una mano?
    ¿Cómo lo puedo solucionar?

    Muchas gracias por vuestro tiempo,
    Un saludo,
    Dani

    • Este debate fue modificado hace 1 año, 7 meses por  Dani Serrano.
    • Este debate fue modificado hace 1 año, 7 meses por  Dani Serrano.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 4 respuestas - 1 de 4 (de 4 total)
  • Moderador Fernando Tellado

    (@fernandot)

    Hola @daniserrano

    ¿Has revisado la configuración del Yoast o reglas de rewrite? Recuerda que muchos plugins meten mierda en el htaccess. Es más, yo probaría a borrar del todo el htaccess y probar (guarda copia antes)

    Hola Fernando

    Si, la configuración del Yoast la he revisado y he puesto en los permalinks que conserve la categoría base.

    Respecto al htacces también, pero es cierto que no he probado a borrarlo por completo.

    Voy a probar eso. Muchas gracias 🙂

    Hola,

    Efectivamente, finalmente se trataba de una redireción 301 que yo mismo había metido.

    Redirect 301 /podcast/serie/ https://wpdesdezero.com/podcast

    Mi error ha sido pensar que como la url de cada categoría es algo así:

    https://wpdesdezero.com/podcast/serie/XXXXXX

    quedaría fuera de la regla, pero no.

    Un saludo,
    Dani

    Moderador Fernando Tellado

    (@fernandot)

    Me alegro 🙂

Viendo 4 respuestas - 1 de 4 (de 4 total)
  • El debate ‘Enlaces rotos a Taxonomías (Categorías)’ está cerrado a nuevas respuestas.