Soporte » WordPress Avanzado » ERR_INVALID_REDIRECT HTTP/1.1 301 Moved Permanently

  • Al acceder a mi sitio web me aparece ERR_INVALID_REDIRECT.

    HTTP/1.1 301 Moved Permanently
    Date: Mon, 31 Jan 2022 13:01:07 GMT
    Server: Apache
    X-Redirect-By: WordPress
    Upgrade: h2,h2c
    Connection: Upgrade
    Location: http:///
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=UTF-8
    
    http:///

    He desabilitado los plugins por si fuese algún problema de alguno de ellos.
    He revisado el htaccess pero no presenta ningún problema.

    # BEGIN WordPress
    # Las directivas (líneas) entre «BEGIN WordPress» y «END WordPress» son
    # generadas dinámicamente y solo deberían ser modificadas mediante filtros de WordPress.
    # Cualquier cambio en las directivas que hay entre esos marcadores serán sobrescritas.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Además se ha realizado una restauración de la página web y de la base de datos de antes de que empezase el problema pero el problema persiste.

    • Este debate fue modificado hace 3 meses, 2 semanas por Jose Luis. Razón: Quitar respuesta del iniciador del debate y añadirla a la consulta

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 15 respuestas - de la 1 a la 15 (de un total de 32)
  • Moderador almendron

    (@almendron)

    No me digas como pero se han borrado todos los mensajes. Ni idea de lo que ha podido pasar.

    En mis dos últimos mensajes, te decía que

    1) Archivo wp-blog-header.php: lo correcto es

    require_once ABSPATH . WPINC . '/template-loader.php';

    porque WPINC te lleva a wp-includes

    2) El archivo wp-load.php estaba correcto.

    A ver si puedes hablar con el soporte del hosting para que te pasen una copia de las líneas del log donde podamos ver el error.

    Y por último: ¿has eliminado del wp-config.php las dos líneas de las direcciones? Si no lo has hecho, hazlo.

    Iniciador del debate soleado21

    (@soleado21)

    Si he eliminado las dos lineas de redirección osea estas:

    CODE:
    define(‘WP_HOME’,’http://igualati.org&#8217;);
    define(‘WP_SITEURL’,’http://igualati.org&#8217;);

    tengo un log con errores: por ejemplo del día de ayer:
    CODE

    [Thu Feb 03 00:22:17.768424 2022] [:error] [pid 2599447:tid 140630625863424] [client 216.244.66.249:34372] [client 216.244.66.249] ModSecurity: Access denied with code 503 (phase 1). Matched phrase "DotBot" at REQUEST_HEADERS:User-agent. [file "/etc/httpd/modsecurity.d/activated_rules/922_user_agent.conf"] [line "19"] [id "5095"] [hostname "www.igualati.org"] [uri "/robots.txt"] [unique_id "YfsgOaFDJqLzOf13MEV8sgAAAk0"]
    [Thu Feb 03 01:14:08.951198 2022] [:error] [pid 2599283:tid 140630642648832] [client 216.244.66.249:33030] [client 216.244.66.249] ModSecurity: Access denied with code 503 (phase 1). Matched phrase "DotBot" at REQUEST_HEADERS:User-agent. [file "/etc/httpd/modsecurity.d/activated_rules/922_user_agent.conf"] [line "19"] [id "5095"] [hostname "www.igualati.org"] [uri "/robots.txt"] [unique_id "YfssYF7l-WH@vfA0-F5FVQAAAEs"]
    [Thu Feb 03 01:14:08.986113 2022] [:error] [pid 2599447:tid 140630625863424] [client 216.244.66.249:33144] [client 216.244.66.249] ModSecurity: Access denied with code 503 (phase 1). Matched phrase "DotBot" at REQUEST_HEADERS:User-agent. [file "/etc/httpd/modsecurity.d/activated_rules/922_user_agent.conf"] [line "19"] [id "5095"] [hostname "igualati.org"] [uri "/robots.txt"] [unique_id "YfssYKFDJqLzOf13MEWJTAAAAk0"]
    [Thu Feb 03 02:07:19.834265 2022] [:error] [pid 2668671:tid 140631154341632] [client 216.244.66.249:34434] [client 216.244.66.249] ModSecurity: Access denied with code 503 (phase 1). Matched phrase "DotBot" at REQUEST_HEADERS:User-agent. [file "/etc/httpd/modsecurity.d/activated_rules/922_user_agent.conf"] [line "19"] [id "5095"] [hostname "igualati.org"] [uri "/robots.txt"] [unique_id "Yfs416w3y7bXa0MTGxjhAgAAAIc"]
    [Thu Feb 03 02:07:21.697924 2022] [:error] [pid 2599285:tid 140631087232768] [client 216.244.66.249:40812] [client 216.244.66.249] ModSecurity: Access denied with code 503 (phase 1). Matched phrase "DotBot" at REQUEST_HEADERS:User-agent. [file "/etc/httpd/modsecurity.d/activated_rules/922_user_agent.conf"] [line "19"] [id "5095"] [hostname "www.igualati.org"] [uri "/robots.txt"] [unique_id "Yfs42YZN1Zop0Pmm8zWWbAAAAcY"]
    [Thu Feb 03 03:07:15.052263 2022] [:error] [pid 2693727:tid 140630214817536] [client 216.244.66.249:56410] [client 216.244.66.249] ModSecurity: Access denied with code 503 (phase 1). Matched phrase "DotBot" at REQUEST_HEADERS:User-agent. [file "/etc/httpd/modsecurity.d/activated_rules/922_user_agent.conf"] [line "19"] [id "5095"] [hostname "www.igualati.org"] [uri "/robots.txt"] [unique_id "YftG48nlx4gVnQZRxrhhiAAAAFU"]
    [Thu Feb 03 03:07:15.097941 2022] [:error] [pid 2693958:tid 140630609078016] [client 216.244.66.249:56556] [client 216.244.66.249] ModSecurity: Access denied with code 503 (phase 1). Matched phrase "DotBot" at REQUEST_HEADERS:User-agent. [file "/etc/httpd/modsecurity.d/activated_rules/922_user_agent.conf"] [line "19"] [id "5095"] [hostname "igualati.org"] [uri "/robots.txt"] [unique_id "YftG4y4cJ@AaJvu9PXsrZgAAAA8"]
    [Thu Feb 03 04:15:54.692308 2022] [:error] [pid 2693728:tid 140631095625472] [client 216.244.66.249:52042] [client 216.244.66.249] ModSecurity: Access denied with code 503 (phase 1). Matched phrase "DotBot" at REQUEST_HEADERS:User-agent. [file "/etc/httpd/modsecurity.d/activated_rules/922_user_agent.conf"] [line "19"] [id "5095"] [hostname "www.igualati.org"] [uri "/robots.txt"] [unique_id "YftW@hhjrPEkuFkldRBzDAAAAUU"]
    [Thu Feb 03 08:17:42.414391 2022] [:error] [pid 2774405:tid 140631416805120] [client 80.28.205.174:23495] [client 80.28.205.174] ModSecurity: Access denied with code 503 (phase 2). Match of "eq 0" against "USER:goaway" required. [file "/etc/httpd/modsecurity.d/activated_rules/909_wplogindos.conf"] [line "13"] [id "30000352"] [hostname "igualati.org"] [uri "/wp-login.php"] [unique_id "YfuPpsCXawlto919z3klJQAAAIA"]
    [Thu Feb 03 08:23:04.028195 2022] [:error] [pid 2693730:tid 140631162668800] [client 80.28.205.174:13247] [client 80.28.205.174] ModSecurity: Access denied with code 503 (phase 2). Match of "eq 0" against "USER:goaway" required. [file "/etc/httpd/modsecurity.d/activated_rules/909_wplogindos.conf"] [line "13"] [id "30000352"] [hostname "igualati.org"] [uri "/wp-login.php"] [unique_id "YfuQ6AhEZ4iwff2-Z6tEzAAAAdY"]
    [Thu Feb 03 08:23:08.950466 2022] [:error] [pid 2774405:tid 140631179519744] [client 80.28.205.174:20551] [client 80.28.205.174] ModSecurity: Access denied with code 503 (phase 2). Match of "eq 0" against "USER:goaway" required. [file "/etc/httpd/modsecurity.d/activated_rules/909_wplogindos.conf"] [line "13"] [id "30000352"] [hostname "igualati.org"] [uri "/wp-login.php"] [unique_id "YfuQ7MCXawlto919z3ko9QAAAIQ"]
    [Thu Feb 03 09:05:38.660852 2022] [proxy_fcgi:error] [pid 2693958:tid 140630617470720] [client 185.201.10.119:57922] AH01071: Got error 'Primary script unknown', referer: http://simplesite.com
    [Thu Feb 03 12:05:46.732847 2022] [proxy_fcgi:error] [pid 2835397:tid 140631137556224] [client 142.93.218.78:42054] AH01071: Got error 'Primary script unknown', referer: igualati.org
    [Thu Feb 03 12:37:39.130955 2022] [proxy_fcgi:error] [pid 2835398:tid 140630198032128] [client 72.167.70.124:43500] AH01071: Got error 'Primary script unknown', referer: http://simplesite.com
    [Thu Feb 03 13:01:34.399188 2022] [:error] [pid 2835621:tid 140630198032128] [client 216.244.66.249:55940] [client 216.244.66.249] ModSecurity: Access denied with code 503 (phase 1). Matched phrase "DotBot" at REQUEST_HEADERS:User-agent. [file "/etc/httpd/modsecurity.d/activated_rules/922_user_agent.conf"] [line "19"] [id "5095"] [hostname "www.igualati.org"] [uri "/robots.txt"] [unique_id "YfvSLh-i@CEuhWzJb0QkrAAAAdc"]
    [Thu Feb 03 13:27:25.165277 2022] [proxy_fcgi:error] [pid 2842186:tid 140630768473856] [client 185.232.14.28:53108] AH01071: Got error 'Primary script unknown', referer: http://simplesite.com
    [Thu Feb 03 14:05:33.046029 2022] [proxy_fcgi:error] [pid 2835398:tid 140630466467584] [client 80.28.205.174:28686] AH01067: Failed to read FastCGI header, referer: http://www.igualati.org/wp-admin/post-new.php?post_type=page
    [Thu Feb 03 14:05:33.053242 2022] [proxy_fcgi:error] [pid 2835398:tid 140630466467584] (104)Connection reset by peer: [client 80.28.205.174:28686] AH01075: Error dispatching request to : , referer: http://www.igualati.org/wp-admin/post-new.php?post_type=page
    [Thu Feb 03 14:14:59.670913 2022] [:error] [pid 2889837:tid 140630374213376] [client 216.244.66.249:47070] [client 216.244.66.249] ModSecurity: Access denied with code 503 (phase 1). Matched phrase "DotBot" at REQUEST_HEADERS:User-agent. [file "/etc/httpd/modsecurity.d/activated_rules/922_user_agent.conf"] [line "19"] [id "5095"] [hostname "www.igualati.org"] [uri "/robots.txt"] [unique_id "YfvjY8Xsajkaffi@sRWpvwAAAJE"]
    [Thu Feb 03 15:08:12.675307 2022] [proxy_fcgi:error] [pid 2901932:tid 140631313737472] [client 157.55.39.50:25824] AH01071: Got error 'Primary script unknown'
    [Thu Feb 03 15:13:30.444217 2022] [:error] [pid 2902151:tid 140630298711808] [client 216.244.66.249:42908] [client 216.244.66.249] ModSecurity: Access denied with code 503 (phase 1). Matched phrase "DotBot" at REQUEST_HEADERS:User-agent. [file "/etc/httpd/modsecurity.d/activated_rules/922_user_agent.conf"] [line "19"] [id "5095"] [hostname "www.igualati.org"] [uri "/robots.txt"] [unique_id "YfvxGlBqmh2-OyC52pHakAAAAhM"]
    [Thu Feb 03 15:36:16.200907 2022] [proxy_fcgi:error] [pid 2901932:tid 140631305344768] [client 45.93.101.43:52530] AH01071: Got error 'Primary script unknown', referer: http://simplesite.com
    [Thu Feb 03 15:36:18.887581 2022] [proxy_fcgi:error] [pid 2902151:tid 140631400019712] [client 45.93.101.41:53094] AH01071: Got error 'Primary script unknown', referer: http://simplesite.com
    [Thu Feb 03 16:02:27.670774 2022] [:error] [pid 2915464:tid 140630239995648] [client 216.244.66.249:57602] [client 216.244.66.249] ModSecurity: Access denied with code 503 (phase 1). Matched phrase "DotBot" at REQUEST_HEADERS:User-agent. [file "/etc/httpd/modsecurity.d/activated_rules/922_user_agent.conf"] [line "19"] [id "5095"] [hostname "www.igualati.org"] [uri "/robots.txt"] [unique_id "Yfv8k-9Kx4jffwD1B8c4IgAAAFI"]
    [Thu Feb 03 18:52:54.092239 2022] [proxy_fcgi:error] [pid 2901933:tid 140630718150400] [client 64.227.88.155:52682] AH01071: Got error 'Primary script unknown', referer: http://simplesite.com
    [Thu Feb 03 18:53:01.871264 2022] [proxy_fcgi:error] [pid 2901931:tid 140630088992512] [client 64.227.88.155:56046] AH01071: Got error 'Primary script unknown', referer: http://simplesite.com
    [Thu Feb 03 20:00:24.470428 2022] [:error] [pid 2915464:tid 140631408412416] [client 124.71.63.186:52186] [client 124.71.63.186] ModSecurity: Access denied with code 403 (phase 2). Match of "rx (http://bsalsa\\\\.com)" against "REQUEST_HEADERS:User-Agent" required. [file "/etc/httpd/modsecurity.d/activated_rules/20_asl_useragents.conf"] [line "231"] [id "330094"] [rev "3"] [msg "Atomicorp.com UNSUPPORTED DELAYED Rules: Fake User Agent String"] [severity "CRITICAL"] [hostname "www.igualati.org"] [uri "/"] [unique_id "Yfw0WP9Kx4jffwD1B8foMgAAAEE"]
    [Thu Feb 03 22:20:46.015426 2022] [:error] [pid 2902151:tid 140631280166656] [client 216.244.66.249:44070] [client 216.244.66.249] ModSecurity: Access denied with code 503 (phase 1). Matched phrase "DotBot" at REQUEST_HEADERS:User-agent. [file "/etc/httpd/modsecurity.d/activated_rules/922_user_agent.conf"] [line "19"] [id "5095"] [hostname "www.igualati.org"] [uri "/robots.txt"] [unique_id "YfxVPlBqmh2-OyC52pHOJAAAAgg"]
    [Thu Feb 03 23:09:12.338941 2022] [:error] [pid 2915464:tid 140631288559360] [client 216.244.66.249:55610] [client 216.244.66.249] ModSecurity: Access denied with code 503 (phase 1). Matched phrase "DotBot" at REQUEST_HEADERS:User-agent. [file "/etc/httpd/modsecurity.d/activated_rules/922_user_agent.conf"] [line "19"] [id "5095"] [hostname "www.igualati.org"] [uri "/robots.txt"] [unique_id "YfxgmP9Kx4jffwD1B8dKEgAAAEc"]
    [Thu Feb 03 23:09:12.364835 2022] [:error] [pid 2902151:tid 140631408412416] [client 216.244.66.249:55650] [client 216.244.66.249] ModSecurity: Access denied with code 503 (phase 1). Matched phrase "DotBot" at REQUEST_HEADERS:User-agent. [file "/etc/httpd/modsecurity.d/activated_rules/922_user_agent.conf"] [line "19"] [id "5095"] [hostname "igualati.org"] [uri "/robots.txt"] [unique_id "YfxgmFBqmh2-OyC52pHdHAAAAgE"]
    [Thu Feb 03 23:56:20.162789 2022] [:error] [pid 2902151:tid 140630181279488] [client 216.244.66.249:34212] [client 216.244.66.249] ModSecurity: Access denied with code 503 (phase 1). Matched phrase "DotBot" at REQUEST_HEADERS:User-agent. [file "/etc/httpd/modsecurity.d/activated_rules/922_user_agent.conf"] [line "19"] [id "5095"] [hostname "www.igualati.org"] [uri "/robots.txt"] [unique_id "YfxrpFBqmh2-OyC52pHpuAAAAhg"]
    [Fri Feb 04 00:43:55.228706 2022] [autoindex:error] [pid 2915464:tid 140630684579584] [client 65.108.78.77:53660] AH01276: Cannot serve directory /srv/vhost/igualati.org/home/html/wp-admin/css/: No matching DirectoryIndex (index.html,index.html,index.html.var,index.htm,index.php,index.php3,index.php4,default.html,default.htm,default.php,default.swf,index.php) found, and server-generated directory index forbidden by Options directive, referer: binance.com
    [Fri Feb 04 00:44:03.542940 2022] [:error] [pid 2901933:tid 140630239995648] [client 216.244.66.249:34524] [client 216.244.66.249] ModSecurity: Access denied with code 503 (phase 1). Matched phrase "DotBot" at REQUEST_HEADERS:User-agent. [file "/etc/httpd/modsecurity.d/activated_rules/922_user_agent.conf"] [line "19"] [id "5095"] [hostname "www.igualati.org"] [uri "/robots.txt"] [unique_id "Yfx208-kUMM2Jt8TGOtOgwAAAdI"]
    [Fri Feb 04 03:36:47.040517 2022] [:error] [pid 3091477:tid 140631305344768] [client 198.54.121.131:38974] [client 198.54.121.131] ModSecurity: Access denied with code 503 (phase 1). Match of "rx sqlpatch\\\\.php|tbl_|phpmyadmin|(^/administrator/index\\\\.php\\\\?option=)|\\\\/sql\\\\.|\\\\/admin\\\\/main|\\\\/FormMail|\\\\/tstemplate/ts/|mediaelement|export|import|webservice\\\\.php|\\\\.jpg|\\\\.htm|\\\\.gif|\\\\.js|\\\\.pdf" against "REQUEST_URI" required. [file "/etc/httpd/modsecurity.d/activated_rules/925_generic.conf"] [line "16"] [id "5101"] [hostname "igualati.org"] [uri "/wp-admin/admin-ajax.php"] [unique_id "YfyfTxXzVo7@iZeR7QMpjAAAAgU"]
    Iniciador del debate soleado21

    (@soleado21)

    si el problema esta en la redirección que hace a http:///

    he buscado por todas las línes de código y por toda la base de datos y no hay ninguna redirección ahi :S

    Iniciador del debate soleado21

    (@soleado21)

    he enviado un log de errores pero esta pendiente por un moderador aun poniendo CODE

    Iniciador del debate soleado21

    (@soleado21)

    Las páginas que no pasan por index.php funcionan. como por ejemplo http://igualati.org/?p=7203
    Además cuando vuelvo a subir el archivo wp-load.php la primera llamada que hace a la página de inicio también funciona y luego ya vuelve al error ERR_INVALID_REDIRECT

    • Esta respuesta fue modificada hace 3 meses, 2 semanas por soleado21.
    Moderador almendron

    (@almendron)

    Cambia el tema que tengas activo por uno de los que trae por defecto WordPress:

    https://www.hostinger.es/tutoriales/cambiar-tema-wordpress#Opcion-4-8211-Cambiar-el-tema-de-WordPress-usando-phpMyadmin

    Y otra cosa: ¿volviste a dejar los archivos de WordPress tal y como estaban?

    Iniciador del debate soleado21

    (@soleado21)

    si los archivos estan tal y como estaban antes de que dejase de funcionar.

    He cambiado el tema del worpdress y los plugins estan desactivados
    template twentytwenty
    stylesheet twentytwenty

    el resultado sigue siendo ERR_INVALID_REDIRECT

    se puede ver que el tema estan cambiado en http://igualati.org/?p=7203

    Además acabao de restaurar un copia de seguridad de la bbdd del día 20 de enero que la web estaba con correcto funcionamiento

    • Esta respuesta fue modificada hace 3 meses, 2 semanas por soleado21.
    Iniciador del debate soleado21

    (@soleado21)

    Respuesta de la cabecera:

    HTTP/2 301 Moved Permanently
    date: Fri, 04 Feb 2022 10:34:52 GMT
    server: Apache
    x-redirect-by: WordPress
    location: https:///
    content-length: 0
    content-type: text/html; charset=UTF-8
    X-Firefox-Spdy: h2`

    Iniciador del debate soleado21

    (@soleado21)

    Ahora mismo con una versión reciend descargada de WordPress y con una copia de Seguridad de la base de datos del 20 de Enero sigue igual…..

    Moderador almendron

    (@almendron)

    En el log de errores no veo el problema que te señalaba el soporte del hosting.

    Que te digan como llegan a la conclusión de que se trata de una redirección.

    Iniciador del debate soleado21

    (@soleado21)

    me han dicho….. que puede ser que en la bbdd alguna tabla de plugin haga alguna redirección… podria desactivar tablas?

    pero el caso que me dicen.. a nivel de servidor esta todo bien es cosa tuya

    • Esta respuesta fue modificada hace 3 meses, 2 semanas por soleado21.
    Iniciador del debate soleado21

    (@soleado21)

    si configuro en ajustes permanentes con http://igualati.org/?p=123 osea sin pasar por el index.php la web me funciona

    Moderador almendron

    (@almendron)

    Pero… ¿puedes entrar ahora en la administración de WordPress?

    Iniciador del debate soleado21

    (@soleado21)

    si, pero me pasa lo mismo que antes, cuando intento por ejemplo editar una pagina me pone que no tengo permisos aun estando en un usuario adminsitrador

    Moderador almendron

    (@almendron)

    1) Ajustes > Enlaces permanentes = «Simple»

    2) Ajustes > Generales > Dirección de WordPress (URL) y Dirección del sitio (URL) = http://igualati.org

    3) Activa uno de los temas que trae por defecto WordPress

    4) Desactiva todos los plugins.

Viendo 15 respuestas - de la 1 a la 15 (de un total de 32)
  • Debes estar registrado para responder a este debate.