Soporte » Guías – Resolución de problemas » Error 403 Forbidden al guardar entrada

  • Hola,

    Desde hace un tiempo, con las últimas versiones de WordPress y al usar el editor clásico, con mucha frecuencia y en varias instalaciones distintas, al darle a guardar una entrada me aparece un error “403 Forbidden – Access to this resource on the server is denied”.

    Si la guardo utilizando el editor en bloques, no me sale el error, pero usando el editor clásico me da error y pierdo muchísimo tiempo para conseguir crear una entrada.

    Usar el editor de bloques es totalmente inviable en mi caso, ya que el código que me añade no es el código que yo quiero añadir en las entradas.

    Este problema me pasa desde hace un tiempo, solo con las últimas versiones de WordPress, ya que antes nunca me había pasado. He buscado soluciones en Google y se limitan a decirte que pruebes esto y pruebes lo otro para ver si después de perder media jornada hay suerte y algo funciona.

    ¿Alguien sabría decir la causa de este error, y si hay alguna solución universal a este problema? Me trae de cabeza y me parece que no soy el único.

    EDITO: He visto que en mi caso lo que origina el error son los enlaces externos, ya que si elimino los enlaces se puede guardar. ¿Alguien sabría cómo se soluciona? Son enlaces normales, sin símbolos raros.

    Muchas gracias de antemano.

    • Este debate fue modificado hace 5 meses, 2 semanas por bernard88.
    • Este debate fue modificado hace 5 meses, 2 semanas por bernard88.
Viendo 3 respuestas - de la 1 a la 3 (de un total de 3)
  • Moderador almendron

    (@almendron)

    Por lo que veo, el problema viene de lejos porque hace ya 8 meses te dije que tenías que investigar porque no es normal que el editor clásico ocasione esa respuesta del servidor.

    En primer lugar, yo haría lo siguiente: provoca el error, toma nota de la hora y minuto, y con eso te vas a los logs de errores del servidor donde debería haber quedado registrado. A ver si esta información arroja algo de luz.

    En segundo, lugar, activa el debug: https://wordpress.org/support/article/debugging-in-wordpress/
    Lo mismo. A ver si nos da alguna pista.

    Y en tercer lugar, el procedimiento estándar que no te debería llevar más de 10 minutos:

    1) Activa uno de los temas que trae por defecto WordPress

    2) Desactiva TODOS los plugins.

    3) Comprueba.

    Iniciador del debate bernard88

    (@bernard88)

    Hola almendron, gracias de nuevo pero desde mi última consulta no he conseguido solucionarlo.

    Tras activar el debug, esto es lo que me sale (sustituyendo la web del error por web.com)

    2022-06-22 12:13:16.104053 [INFO] [7044] [213.94.29.123:8195-Q:0479936D97C8877E-21#APVH_web.com:443] File not found [/home/web.com/403.shtml] 
    [Wed Jun 22 12:13:06 2022] [error] [client 213.94.29.123] ModSecurity: Warning. [Rule: 'REQUEST_FILENAME' '!@pmFromFile path_excludes'] [id "77140992"] [msg "IM360 WAF: Suspicious access attempt (WP folders)!||SC:/home/web.com/wp-admin/options.php||T:LITESPEED||REQUEST_URI:/wp-admin/options.php||"] [severity "NOTICE"] [tag "service_i360custom"] [tag "noshow"] [hostname "www.web.com"] [uri "/wp-admin/options.php"], referer: https://www.web.com/wp-admin/options-writing.php

    Con el segundo método, no queda registrado ningún archivo donde debería (ni debug.log ni cambiándolo por define( ‘WP_DEBUG_LOG’, ‘/tmp/wp-errors.log’ );).

    El tercer método ya lo había probado sin éxito.

    Desde un soporte me comunican que desactivando el ModSecurity se soluciona el error, el problema es que el hosting donde la tengo no permite desactivarlo, así que seguimos igual.

    Y el error sí debe ser bastante común, ya que googleando me he encontrado casos idénticos, indicando la obtención del error solo al usar el editor clásico.

    Por si sirve de algo, el problema viene con los enlaces externos, ya que si quito todos los enlaces de la entrada, se guarda sin dar error.

    Moderador almendron

    (@almendron)

    1) ¿Eso te sale en el Debug? A mi me da la impresión que es del log de errores del servidor.

    2) ¿Usas algún plugin de seguridad?

    3) ¿Has comprobado si 213.94.29.123 es realmente la IP de tu ordenador? También es raro que no aparezca algo así como «Access denied with code 403».

    Una forma de comprobar si esa regla es la que ocasiona el problema es desactivandola de forma selectiva en el .htaccess

    Es solo poner una regla al principio de dicho archivo. Por ejemplo:

    <IfModule mod_security2.c>
    	SecRuleRemoveById 208
    </IfModule>

    Esto es solo un ejemplo. El código exacto te lo tienen que dar en el soporte del hosting.

    Y no, el editor clásico no suele dar ese problema. No al menos de forma generalizada. Hay cientos de miles de personas que lo usamos y no da ese problema.

Viendo 3 respuestas - de la 1 a la 3 (de un total de 3)
  • Debes estar registrado para responder a este debate.