Soporte » Guías – Resolución de problemas » Error 404 al editar los enlaces permanentes

  • Cambié los enlaces permanentes de mis post de simple a nombre de la entrada y cuando lo hago y trato de entrar en ellos por la ventana de Blogs me da error 404 Not found. Tengo que volver a ponerlos simples para que funcionen. Mi idea de programación es nula y estoy ahora empezando con WordPress, así que poco podré hacer que no sea a través del panel de control.

    Ah! Y le doy siempre a guardar cambios…

Viendo 12 respuestas - de la 1 a la 12 (de un total de 12)
  • Para mí que va a ser que el archivo .htaccess en el servidor no se actualiza por algún motivo, o algún otro tema relacionado con el servidor. ¿Has preguntado al soporte de tu hosting?.

    Iniciador del debate kromaquite

    (@kromaquite)

    No pero voy a hacerlo en cuanto pueda ¿Ellos podrían «repararlo»?

    Gracias

    Hola,
    Donde cambias los enlaces permanentes? Tengo la sensacion que lo cambias en el post editando el campo que hay, el sitio correcto es ajustes – enlaces permanentes eliges la opcion que deseas y le das a guardar cambios, sino existiera el .htaccess lo crearia y si tuvieses problemas con el servidor te mostraria un aviso.
    Si tienes acceso por ftp, haz una copia del .htaccess y borralo, entra en ajustes – enlaces permanentes y vuelve a guardar, asi te creala uno nuevo. Si funciona compara el .htaccess nuevo con la copia y si hay diferencias habla con tu hosting porque por norma general no deberia tener codigo.

    Ya diras…

    @kallookoo cambiar de «simple» a «nombre de entrada» son opciones que hay en «Ajustes->Enlaces permanentes», y como dice el post, le da «guardar cambios». No se por qué piensas que está haciendo otra cosa …. igual sí, pero no tiene pinta.

    Lo pienso por esta frase «Ah! Y le doy siempre a guardar cambios…» pero @kromaquite no lo aclara cuando pueda.

    ¿Cómo? Tu también dices «le das a guardar cambios en Ajustes->Enlaces permanentes», no sé porque si lo dice él te sugiere otra cosa :). Yo creo que está claro; si las opciones que configura son las que están en «Ajustes->Enlaces permanentes», darle a «guardar cambios» es guardar los cambios de «Ajustes->Enlaces permanentes». Pero que lo aclare si tienes dudas.

    Saludos!!

    Iniciador del debate kromaquite

    (@kromaquite)

    Si, si que le doy a aguardar cambios…

    Vale!
    @kromaquite entonces los enlaces permanentes los cambiastes en ajustes – enlaces permanentes, correcto?

    Iniciador del debate kromaquite

    (@kromaquite)

    Si, así lo hice: en ajustes-enlaces permanentes… y luego, guardar cambios

    Y te salio «Estructura de enlaces permanentes actualizada.» u otra cosa?
    Si salio asi, comprueba dos cosas.

    1- Ves al listado de archivos y donde tienes el archivo wp-config.php comprueba que existe el archivo .htaccess, lo puedes hacer por FTP o desde el panel de control de tu servidor, si existe renombralo por lo que quieras y repite los pasos, ajustes – enlaces permanetes – guardar, con eso se deberia crear un nuevo archivo .htaccess.
    2- En el panel de control de tu servidor comprueba que mod_rewrite esta activo, si tienes duda crea un ticket o llama para que te lo confirmen.

    Ya diras…

    Iniciador del debate kromaquite

    (@kromaquite)

    Ando un poco perdido… he conseguido entrar al servidor y al clicar en el archivo wp-config.php me aparece esto -que dicho sea de paso, no puedo editar-:
    The base configuration for WordPress
    *
    * The wp-config.php creation script uses this file during the
    * installation. You don’t have to use the web site, you can
    * copy this file to «wp-config.php» and fill in the values.
    *
    * This file contains the following configurations:
    *
    * * MySQL settings
    * * Secret keys
    * * Database table prefix
    * * ABSPATH
    *
    * @link https://codex.wordpress.org/Editing_wp-config.php
    *
    * @package WordPress
    */

    Por otro lado, en esa misma carpeta (miwebsite.com) además de ese archivo está el .htaccess que aparece como un archivo con el icono de interrogación. No se, creo que esto me viene grande…

    Iniciador del debate kromaquite

    (@kromaquite)

    Perdón, ya se como editarlo…

Viendo 12 respuestas - de la 1 a la 12 (de un total de 12)
  • El debate ‘Error 404 al editar los enlaces permanentes’ está cerrado a nuevas respuestas.