Soporte » Plugins y Hacks » WooCommerce » Error 500 en web

  • Hola a todos,

    Desde hace un tiempo estamos teniendo un error 500 periódicamente cuando realizamos alguna modificación en la pestaña Woocommerce > Pedidos. Si marcamos varios como completados, o generamos el envío con TIPSA, llega un punto que la web «peta» y da error 500.

    Adjunto parte del debug de WordPress:

    [01-Jul-2020 16:44:37 Europe/Madrid] PHP Notice:  status ha sido llamada <strong>de forma incorrecta</strong>. Order properties should not be accessed directly. Backtrace: require('wp-admin/edit-form-advanced.php'), do_meta_boxes, WC_Meta_Box_Order_Items::output, include('/plugins/woocommerce/includes/admin/meta-boxes/views/html-order-items.php'), do_action('woocommerce_order_item_add_action_buttons'), WP_Hook->do_action, WP_Hook->apply_filters, action_woocommerce_order_item_add_action_buttons, WC_Abstract_Legacy_Order->__get, wc_doing_it_wrong Por favor, visita <a href="https://wordpress.org/support/article/debugging-in-wordpress/">Depuración en WordPress</a> para más información. (Este mensaje fue añadido en la versión 3.0). in /var/www/vhosts/darwincollection.com/_httpdocs/wp-includes/functions.php on line 5167
    [01-Jul-2020 16:45:04 Europe/Madrid] PHP Deprecated:  woocommerce_price ha quedado <strong>obsoleto</strong> desde la versión 3.0. Utiliza wc_price en su lugar. in /var/www/vhosts/darwincollection.com/_httpdocs/wp-includes/functions.php on line 4713
    [01-Jul-2020 16:45:04 Europe/Madrid] PHP Deprecated:  woocommerce_get_template ha quedado <strong>obsoleto</strong> desde la versión 3.0. Utiliza wc_get_template en su lugar. in /var/www/vhosts/darwincollection.com/_httpdocs/wp-includes/functions.php on line 4713

    Hemos activado y desactivado plugins y no encontramos solución. El servidor es propio de Amazon Web Services y no consume ni un 10%, salvo que algo provoca que consuma bastante recursos y se acabe cayendo el servidor.

    • Este debate fue modificado hace 3 meses, 3 semanas por albcabgil.
Viendo 1 respuesta (de un total de 1)
  • Hola @albcabgil
    por lo que se ve en el registro de error que incluyes, uno de los problemas que tienes (no tiene por qué ser el único), es que algo que tienes instalado en tu sitio está utilizando funciones obsoletas de WooCommerce.

    Un buen sitio para empezar a recabar información son la página de estado de WooCommerce:
    https://darwincollection.com/wp-admin/admin.php?page=wc-status
    (mira sobre todo las secciones «plantillas» y «plugins activos»)

    También veo que tenéis instalado Flatco, un tema comercial. Aunque diga que es compatible con WooCommerce 4.1 es posible que no todas sus plantillas lo sean. Yo probaría a hacer una copia del sitio, instalar Storefront e intentar reproducir el error.

Viendo 1 respuesta (de un total de 1)
  • Debes estar registrado para responder a este debate.