Soporte » Instalación – Actualizaciones » Error a la hora de pasar un sitio de localhost a hosting con el plugin Duplicato

  • Hola. Tengo ya muchos sitios web hechos con WordPress. Siempre los hago en localhost y después los paso al hosting con el plugin Duplicator, y nunca me ha dado problemas. Pero ahora estoy usando un hosting nuevo con un colega y cada vez que voy a publicar un sitio nuevo en el paso 1 del Duplicator me conecta bien las DB pero cuando le doy ejecutar me pone este error:

    server code: 200
    status: OK
    response: 
    INSTALL ERROR!
    In order to extract the archive.zip file the PHP ZipArchive module must be installed. Please read the FAQ for more details. You can still install this package but you will need to check the Manual package extraction checkbox found in the Advanced Options. Please read the online user guide for details in performing a manual package extraction.

    Pero el colmo es que cuando trato de activar el sitio a mano, copiando los archivos e importando la DB, modifico la tabla wp-options los siteurl y home, y entonces cuando parece que todo va a salir bien y pongo la dirección del sitio en el navegador me pone
    http://localhost/misitio/
    todo como si estuviera todavía en localhost.
    Esto nunca me había pasado, ya he pasado decenas de sitios de localhost a hosting, o de un hosting a otro con ese mismo plugin, pero ahora no se que pasa.
    Si me pudieran ayudar se los agradecería.

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • Moderador almendron

    (@almendron)

    Por lo que dice el mensaje de error, debes ponerte en contacto con el soporte del hosting y que activen el «PHP ZipArchive module» en el servidor.

    Iniciador del debate sabdiel batista

    (@sabdielbatista)

    OK, gracias, ya me puse en contacto con ellos, pero no me han respondido todavía.

    Moderador almendron

    (@almendron)

    De nada. Ya nos dirás.

    Iniciador del debate sabdiel batista

    (@sabdielbatista)

    ya me respondieron, activé el módulo que hacía falta, pero tuve que bajar la versión de php, ahora lo que me está dando problemas es conectar el sitio con Jetpack

    Moderador almendron

    (@almendron)

    ¿Tuviste que bajar la versión de PHP? ¿a cuál?

    Jetpack: no te compliques la vida. Desactiva, borra y vuelve a instalar.
    Para configurar: hazlo a través de xxxxx/wp-admin/admin.php?page=jetpack_modules. Ahí podrás ver todos los módulos.

    Iniciador del debate sabdiel batista

    (@sabdielbatista)

    creo que bajé a 5.5….voy a hacer eso que dices con jetpack, borrarlo e instalarlo desde cero del reporcitorio oficial….gracias

    Moderador almendron

    (@almendron)

    Habla con el soporte de tu hosting porque no es de recibo que tengas que bajarte a esa versión para poder activar el módulo. No tiene ningún sentido.
    No digo ya que uses la 7.x que sería lo aconsejable pero bajarte a la 5.5… ¡sin comentarios!.

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • El debate ‘Error a la hora de pasar un sitio de localhost a hosting con el plugin Duplicato’ está cerrado a nuevas respuestas.