Soporte » Guías – Resolución de problemas » Error actualizar plugins

  • Resuelto sesepote

    (@sesepote)


    Hola, estoy queriendo actualizar un plugin pero me da error, tambien decir que uso xampp, probe a añadir define( ‘WP_TEMP_DIR’, ABSPATH . ‘wp-content/tmp/’) ; en wp-config pero nada, ¿Que podría hacer? el codigo es el siguiente:

    El proceso de actualización está comenzando. Este proceso puede tardar un poco en algunos servidores, así que, por favor, ten paciencia.
    
    Activando el modo mantenimiento…
    Actualizando plugin MailChimp for WooCommerce (1/1)
    
    Descargando la actualización desde https://downloads.wordpress.org/plugin/mailchimp-for-woocommerce.2.1.10.zip…
    
    Warning: fopen(C:\xampp\htdocs/wp-content/tmp/mailchimp-for-woocommerce.2.1.10-r0btSU.tmp): failed to open stream: No such file or directory in C:\xampp\htdocs\wp-includes\Requests\Transport\cURL.php on line 138
    
    Warning: fclose() expects parameter 1 to be resource, boolean given in C:\xampp\htdocs\wp-includes\Requests\Transport\cURL.php on line 409
    Descomprimiendo la actualización…
    
    Warning: unlink(C:\xampp\htdocs/wp-content/tmp/mailchimp-for-woocommerce.2.1.10-r0btSU.tmp): No such file or directory in C:\xampp\htdocs\wp-admin\includes\class-wp-upgrader.php on line 312
    
    Ocurrió un error al actualizar MailChimp for WooCommerce: No se ha podido descomprimir el paquete. PCLZIP_ERR_MISSING_FILE (-4) : Missing archive file 'C:\xampp\htdocs/wp-content/tmp/mailchimp-for-woocommerce.2.1.10-r0btSU.tmp'
    
    Desactivando el modo mantenimiento…
    
    Todas las actualizaciones se han completado.
Viendo 4 respuestas - 1 de 4 (de 4 total)
  • Hola de nuevo, ya está solucionado, por si alguien tiene un problema similar, resulta que al añadir

    define( ‘WP_TEMP_DIR’, ABSPATH . ‘wp-content/tmp/’)

    en wp-config.php le puse mal la dirección, ya que la carpeta que cree se llamaba «temp», no «tmp», solo tuve que cambiarlo y listo, ya funciona perfectamente. Mucho ojo, que muchos problemas informáticos son por pequeñas cosas como esta, los codigos no perdonan ni una.

    Hola, aprovecho tu hilo ya que mi problema puede estar relacionado, al tratarse de la actualización de un plugin.

    Resulta que ayer le di a la opción de actualizar los plugins y desde entonces aparece el siguiente error cuando intento acceder a mi web:

    «Warning: require_once(/home/u699373499/public_html/wp-content/plugins/jetpack/class.jetpack.php): failed to open stream: No such file or directory in /home/u699373499/public_html/wp-content/plugins/jetpack/jetpack.php on line 46

    Fatal error: require_once(): Failed opening required ‘/home/u699373499/public_html/wp-content/plugins/jetpack/class.jetpack.php’ (include_path=’.:/opt/php-5.6/pear’) in /home/u699373499/public_html/wp-content/plugins/jetpack/jetpack.php on line 46»

    El caso es que intento acceder por el FTP, pero tampoco me conecta y dado que mis conocimientos no son muy avanzados, no se como eliminar manualmente el plugin, o algo por el estilo.

    Alguien podría echarme una mano con el proceso?
    la web es http://www.playaangel.com, es de mi banda de rock.

    Muchisimas gracias de antemano y un saludo!

    Entra desde el cpanel donde tienes alojada la web, luego vas a la carpeta /wp-content/plugins y renombras la carpeta «jetpack», le pones «jetpack_PAK» por ejemplo y verificas su funcionamiento.

    Hechooo! Sesepote. He bajado otro servidor con el que me ha dejado acceder y renombrándolo, he podido desinstalarlo. Luego a la noche miraré de instalarlo otra vez. A ver si va bien.

    Muchas gracias!

Viendo 4 respuestas - 1 de 4 (de 4 total)
  • El debate ‘Error actualizar plugins’ está cerrado a nuevas respuestas.