Soporte » Instalación – Actualizaciones » Error al actualizar desde versión 5.8

  • Resuelto tvalades

    (@tvalades)


    Buenos días, desde la versión 5.8 ando pegándome con el tema de actualziar wp a la última versión.
    Al principio, mi proveedor de hosting me arrojaba error por el theme (Astra)
    En este entorno de pruebas he cambiado el theme astra por hello elementor ya que también está maquetada con elementor.
    He eliminado el theme astra desde apariencia > detalles > borrar y he eliminado rastro en la base de datos. Aún así el error persiste y no consigo actualizar.

    WordPress sólo me saca el mensaje de: Ha habido un error crítico en esta web.

    En los logs lo que encuentro es esto:
    [Thu May 26 13:13:41.054136 2022] [proxy_fcgi:error] [pid 17678:tid 139892905219840] [client 188.78.37.111:48008] AH01071: Got error 'PHP message: PHP Fatal error: Uncaught Error: Call to undefined function wp_get_current_user() in /home/grtendencias/prueba/wp-includes/capabilities.php:693\nStack trace:\n#0 /home/grtendencias/prueba/wp-includes/functions.php(3533): current_user_can('unfiltered_html')\n#1 /home/grtendencias/prueba/wp-includes/block-editor.php(206): get_allowed_mime_types()\n#2 /home/grtendencias/prueba/wp-includes/class-wp-theme-json-resolver.php(199): get_default_block_editor_settings()\n#3 /home/grtendencias/prueba/wp-includes/class-wp-theme-json-resolver.php(384): WP_Theme_JSON_Resolver::get_theme_data()\n#4 /home/grtendencias/prueba/wp-includes/global-styles-and-settings.php(106): WP_Theme_JSON_Resolver::get_merged_data()\n#5 /home/grtendencias/prueba/wp-includes/script-loader.php(2379): wp_get_global_stylesheet()\n#6 /home/grtendencias/prueba/wp-includes/class-wp-hook.php(307): wp_enqueue_global_styles('')\n#7 /home/grtendencias/prueba/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters(NULL, Array)\n#8 /home/grtenden...', referer: https://prueba.grtendencias.es/wp-admin/update-core.php?action=do-core-upgrade

    Pero no entiendo mucho que quiere decir

    Estoy buscando en google, por stackoverflow y nada que me ayude.

    Gracias de antemano

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 2 respuestas - de la 16 a la 17 (de un total de 17)
  • Moderador almendron

    (@almendron)

    Antes de nada: ¿no habrás añadido en el «wp-config.php» algo relacionado con las actualizaciones?

    Una última prueba:

    1) Crea carpeta «prueba».

    2) Crea base de datos nueva.

    3) Instala en esa carpeta la misma versión de WP que tienes donde no te deja actualizar. Descarga exactamente la misma versión.

    Nada más instalar, edita el wp-config.php y añade

    define('AUTOMATIC_UPDATER_DISABLED', true ); // desactivar acrtualizaciones automaticas

    4) Prueba a actualizar.

    Iniciador del debate tvalades

    (@tvalades)

    He hecho una instalación nueva de WordPress 6.0, he importado la base de datos, los plugins e imágenes y funciona

    • Esta respuesta fue modificada hace 6 meses por tvalades.
Viendo 2 respuestas - de la 16 a la 17 (de un total de 17)
  • El debate ‘Error al actualizar desde versión 5.8’ está cerrado a nuevas respuestas.