Soporte » Plugins y Hacks » Error al probar cache en el plugin WP Super Cache

  • Hola a todos
    Tengo un problema con la configuración del plugin WP Super Cache, he realizado varios ajustes y al momento de probar la cache, me aparece el siguiente mensaje
    ¡Las páginas no coinciden! ¡Las marcas de tiempo difieren o no se encontraron!
    Ya consulte con mi hosting y me comentan que en la configuración realizada, no hay problema alguno.
    He consultado foros pero no he podido dar ni resolver este problema.
    ¿Alguien que me pueda ayudar? Lo agradecería mucho, ya que soy algo novato en el mundo de WordPress y quiero resolver de una vez por todas eso.
    Saludos y gracias.

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 9 respuestas - de la 1 a la 9 (de un total de 9)
  • Moderador almendron

    (@almendron)

    ¿Tienes instalado Cloudflare y autoptimize? Es posible que entren en conflicto.

    También he encontrado esto: https://help.dreamhost.com/hc/es/articles/214588698-Instalaci%C3%B3n-de-WP-Super-Cache#tiempo

    Iniciador del debate ekomilkamericas

    (@ekomilkamericas)

    Hola
    Muchas gracias por la ayuda, respecto a la pregunta, no tengo instalado Cloudflare pero el plugin de autoptimize si, en ese caso ¿Debo desactivar y borrar el plugin de Autoptimize?

    Porque consulte el link que me proporcionaste y explica muy bien la solución, sin embargo, Cloudflare no esta instalado.

    Moderador Jose Luis

    (@jose64)

    Hola.

    Prueba eliminando totalmente las optimizaciones y caché, una vez hecho esto activa nuevamente Autoptimize y una vez esté todo funcionando correctamente activa WP Super Cache. Coméntanos si así lo resuelves y, por favor, recuerda marcar el debate como resuelto cuando sea el caso, así nos ayudas a mantener el foro al día.

    Iniciador del debate ekomilkamericas

    (@ekomilkamericas)

    Hola @jose64

    Antes que nada espero estés bien, respecto a lo que comentaste, lo hice, borre las optimizaciones correspondientes junto con la caché, posteriormente, active Autoptimize, sin embargo, al activar de nuevo WP Super Cache, el problema sigue persistiendo con el mismo mensaje:

    Página 1: 200 (OK)
    Página 2: 200 (OK)
    ¡Las páginas no coinciden! ¡Las marcas de tiempo difieren o no se encontraron!

    En los ajustes avanzados de la configuración, puse el intervalo de tiempo de la caducidad de la caché y el temporizador, entonces me percaté de lo siguiente:

    Cuando guardo cambios, aparece lo siguiente, antes de las configuraciones
    Tiempo de caducidad y Recogida de basura
    La hora UTC es 2021-10-19 22:15:10La hora local es 2021-10-19 17:15:10
    La próxima recogida de basura será a las 2021-10-19 22:19:37 UTC

    Antes simplemente los ignore, sin embargo, ¿Crees que esto puede ser la razón por la cuál me aparece el error que mencioné?
    Quizá no tenga nada que ver y este confundiendo cosas que no tienen nada que ver, solo que me pareció raro esa métrica.
    En caso de que no tenga nada que ver, quizá la configuración de Autoptimize puede ser la que este mal ¿no?
    Ya que la configuración de WP Super Cache, me la proporcionó mi hosting.

    Moderador Jose Luis

    (@jose64)

    Hola.

    En la documentación que te indicó @almendron te dice que desactives la opción de minimizar el HTML en cloudflare, aunque no tengas cloudflare instalado el resultado es el mismo, si tienes activado minimizar HTML en Autoptimize desactívalo, borra la caché y prueba nuevamente.

    Lo que indicas del tiempo de caducidad y recogida de basura es informativo, no un error, te indica la hora Universal (UTC), la de tu sistema o local (que estás usando la zona horaria UTC-5, el uso horario de México) y la hora a la que se hará el próximo vaciado en hora universal.

    Iniciador del debate ekomilkamericas

    (@ekomilkamericas)

    Hola que tal @almendron
    Antes que nada espero te encuentres bien y una disculpa por apenas responder.

    Realice lo que me comentaste, he desactivado la opción de minimizar HTML en Autoptimize, borre la caché tanto de Autoptimize como de WP Super Cache, pero, al probar caché de nuevo, en el plugin de WP Super Cache, el mismo mensaje sigue apareciendo.
    No se si pueda compartirte la configuración que tengo en Autoptimize, para comprobar que tengo bien configurado el plugin y así descartar que entre ambos plugins, no exista una incompatibilidad. Tal vez me desvié mucho e incluso no tenga nada que ver, pero ya no se que pueda ser realmente.

    Y acerca de los tiempos, muchas gracias, no sabía bien a que se refería con eso, ahora ya me quedo claro.

    Muchas gracias por la ayuda brindada hasta al momento, saludos.

    Moderador almendron

    (@almendron)

    Disculpa, pero estaba de viaje y no he podido conectarme.

    1) Desactiva WP Super Cache y Autoptimize.

    2) Activa solo Autoptimize.

    3) activa solo WP Super Cache

    En cada paso, comprueba y toma nota de si desparece el problema.

    Iniciador del debate ekomilkamericas

    (@ekomilkamericas)

    Hola que tal @almendron
    Antes que nada agradezco tu respuesta y tu tiempo, así que no te preocupes.

    Acabo de realizar los pasos que mencionas, pero el problema sigue vigente.
    He vuelto a configurar cada uno de los plugins pero aún así sigue apareciendo lo mismo.
    ¿Requieres que te proporcione las opciones que he habilitado en ambos plugins, cuando los he vuelto a instalar?

    Saludos.

    Moderador almendron

    (@almendron)

    Dime en qué opción (1, 2 y 3) desaparece el problema y en cuál sigue estando.

Viendo 9 respuestas - de la 1 a la 9 (de un total de 9)
  • Debes estar registrado para responder a este debate.