Soporte » Guías – Resolución de problemas » Error al publicar cambios en apariencia del tema

  • Resuelto pcqnk

    (@pcqnk)


    Hola. Desde hace unos días tengo un problema con mi instalación de WordPress. El caso es que no puedo publicar cambios en la apariencia del tema. He probado todo, tengo muy pocos plugins instalados y solo un tema, pero he probado a desactivar los plugins, instalar el tema por defecto, reinstalar WordPress, me he puesto en contacto con el servidor y me dicen que no se ve nada ‘raro’… A ver si alguien ha tenido el mismo problema o similar y me puede echar un cable. GRACIAS!! de antemano. Saludos

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 14 respuestas - de la 1 a la 14 (de un total de 14)
  • pcqnk

    (@pcqnk)

    Se me pasó, al ir a la apariencia del tema,por defecto el botón de ‘Publicar’ está en la opción de ‘Programar’, de esta forma tampoco publica. Y después no puedo volver a acceder, me sale un mensaje de ‘Tus cambios programados recién publicados’, con un enlace de ‘Personalizar nuevos cambios’ que tampoco funciona.

    Hola, tengo exáctamente el mismo problema y no consigo encontrar respuestas.
    Como referencia, esta persona parece que también lo tiene:
    https://es.wordpress.org/support/topic/problema-al-guardar-cambios-en-pagina-nueva/
    Has conseguido solucionarlo tu?

    Saludos

    pcqnk

    (@pcqnk)

    Hola. Pues no lo he conseguido solucionar, parece un error derivado de la última versión de wordpress y configuración de servidores, pero el proveedor de ese servidor me ha dicho que todo está correcto, a pesar de que tengo hechas varias páginas en distintos servidores, inclusive la mía, y sólo en esa tengo ese problema.

    Ponte en contacto con tu proveedor de hosting a ver si te ofrece alguna solución.

    Saludos.

    cri2wp

    (@cri2wp)

    Gracias por tu respuesta.

    El problema es que el hosting es nuestro :-). Es un servidor con Strato y hemos visto que hasta la versión 4.8 de W Press. funciona sin problemas. A partir de la V 5.0… todas van mal.

    Lo que también es raro es que nadie del foro aporte conocimiento sobre esta situación, no te parece?.. Abriste el hilo hace 2 meses y ni una sola aportación con propuestas o ideas.

    Es posible que solo nos pase a nosotros 🙂

    Saludos

    pcqnk

    (@pcqnk)

    Pues la verdad es que todo es raro como dices,q ue pase en algunos hostings y en otros no, que nadie tenga respuesta….

    Acabo de actualizar a la versión 5.5 y me sigue dando el mismo problema, de momento no necesito hacer cambios de personalización, pero si en algún momento tengo que hacerlos no sé que solución tomaré, seguramente cambiar el hosting, porque he reinstalado worpress desde 0 y me da el mismo problema….

    Si sirve de ayuda, esta web está en un servidor del que el único dato que tengo es que utiliza plesk, no me han dicho nada más, dan pocos detalles….

    Bueno, si alguien encuentra alguna solución, espero que la comparta para poder poner fin a esta ‘guerra’.

    Saludos.

    cri2wp

    (@cri2wp)

    Opciones paa hacer cambios:
    Programa el cambio, asegúrate que el reloj del servidor coincide con el real y espera que pase el momento. A veces tarde, pero si que hace los cambios

    También he visto que si te quedas en WPress 4.XX no tienes problemas.

    Sería bueno confirmar que el hosting sea de Strato, Aquí puedes localizar donde está el Hosting: https://sitereport.netcraft.com/
    Ya me dirás..

    cri2wp

    (@cri2wp)

    Creo que SI que es strato. mira la línea: DNS admin y verás que corresponde a strato
    Todo apunta a un problema de seguridad o bloqueo de seguridad…y con Strato será dificil gestionar.

    En fin… habrá que buscar otro hosting!

    cri2wp

    (@cri2wp)

    pcqnk

    (@pcqnk)

    Gracias por la información, cuando sea necesario buscaremos otro hosting si no lo solucionan antes.

    Saludos!

    Moderador Jose Luis

    (@jose64)

    Hola @pcqnk

    Actualiza todo, temas y plugins, no únicamente WordPress, estás usando una versión no actualizada del tema Astra.

    Aparte de eso, WordPress ha aumentado los requisitos mínimos del hosting, revisa si los alcanza, y eliminó el soporte a las versiones de jQuery obsoletas, esos son los cambios básicos.

    Revisa esta entrada donde explican la razón del cambio y cómo solucionar temporalmente los problemas generados:

    Errores tras actualizar a WordPress 5.5 ¿hay solución?

    Apreciad@s,

    Gracias José Luis por tu sugerencia, pero estando convencido que es un tema de relación entre las nuevas versiones de WP a partir de la V 5, He hecho una prueba y sin saber cual es realmente el problema, he encontrado una solución posible.
    La instalación anterior del Servidor era: CentOS 7 64bit + Plesk Onyx
    He reinstalado todo con: Ubuntu 18.04 LTS 64bit + Plesk Onyx y funciona todo sin problemas.
    @pcqnk, por si os puede servir!!.

    Saludos

    emigdio

    (@emigdio)

    No se trata de un problema de versión de WordPress, ni un problema del proveedor STRATO, ni un problema de Plesk. Se trata de un problema de CentOS7.

    Después de mucho buscar, he encontrado una solución al problema y quiero compartirla.
    En este foro explican el problema: aquí
    Ese foro nos lleva una explicación en los foros de plesk: aquí

    Básicamente es un problema en CentOS7, el archivo UTC no es válido y esto provoca problemas en la publicación de cambios en WordPress.

    El problema se soluciona sustituyendo ese archivo “/usr/share/zoneinfo/UTC” por una copia correcta (yo la he sacado de otro servidor con CentOS6).

    Y ya funciona todo correctamente. Ni siquiera es necesario reiniciar.

    cri2wp

    (@cri2wp)

    Apreciado @emigdio
    Muchas gracias por tu solución. No voy a comprobarlo 🙂 pero creo que soluciona el problema por lo que he leido en los foros de Plesk.

    Que tengas un buen día!

    pcqnk

    (@pcqnk)

    Muchas gracias.Saludos.

Viendo 14 respuestas - de la 1 a la 14 (de un total de 14)
  • Debes estar registrado para responder a este debate.