Soporte » Guías – Resolución de problemas » Error AMP Google Search Console

  • Resuelto carcargar

    (@carcargar)


    Hola, me gustaría que me ayudaseis con un tema. Google Search Console me informa de un error AMP en todas las entradas de mi blog. En concreto: Hay un atributo o un valor de atributo no permitidos en la etiqueta HTML.
    Y el problema que aparece en el código es:
    layout=intrinsic i-amphtml-layout=intrinsic><i-amphtml-sizer
    class=i-amphtml-sizer><img
    alt aria-hidden=true class=i-amphtml-intrinsic-sizer role=presentation src=»data:image/svg+xml;charset=utf-8,<svg height="255" width="795" xmlns="
    Se que está relacionado con la imagen del título de todas las entradas del blog. Utilizo a3LazyLoad. No se si puede estar relacionado por si acaso lo desactivé de las entradas, pero no se ha arreglado. Teniendo en cuenta que no sé nada programación, por favor me podéis indicar como arreglarlo?
    De antemano, un montón de gracias y espero vuestras noticias

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • Hola @carcargar

    Coloca el codigo otra vez entre las etiquetas code para poder visualizar tu codigo y veremos que podemos hacer.

    Saludos

    Iniciador del debate carcargar

    (@carcargar)

    Hola kallookoo. Lo primero un montón de gracias por tu respuesta y tu disposición a echarme una mano. Como decía no entiendo nada de programación, he aprendido cosas sueltas sobre la marcha, y ni siquiera estoy segura de haber entendido bien tu propuesta :-). He copiado de nuevo el código con la etiqueta code al inicio y al final.

    layout=intrinsic i-amphtml-layout=intrinsic><i-amphtml-sizer
    class=i-amphtml-sizer><img
    alt aria-hidden=true class=i-amphtml-intrinsic-sizer role=presentation src=»data:image/svg+xml;charset=utf-8,<svg height="255" width="795" xmlns="

    Por favor, si no lo he hecho bien dame alguna pista más para repetirlo. Llevo tiempo buscando información sobre el tema pero no he conseguido nada.
    Otra vez muchas gracias y buen fin de semana

    Hola @carcargar

    Olvidate del codigo, he preferido revisar tu pagina para verlo mejor.
    Aqui tienes el resultado:
    https://search.google.com/test/amp?id=3nRLVpJBhyW_9nvqYYIt0Q
    Como puedes ver te comenta que en las imagenes estan mal formadas,

    Como no puedo ver como creas la version amp, no puedo comentarte nada mas.
    Bueno salvo que revises la configuracion ya sea del plugin o el theme.

    Saludos

    Iniciador del debate carcargar

    (@carcargar)

    Gracias de nuevo. No quiero incordiarte mucho más. Solo un par de preguntas por si me dan alguna pista. Utilizo el pluging AMP con el modo de plantilla lector que era el único que requería trabajo adicional. No lo he configurado de ninguna manera porque no visto ninguna otra opción de configuración. He visto que el theme Divi que es con el que yo trabajo no está en el ecosistema AMP, por lo que tu sabes puede estar ahí el problema o no tiene nada que ver…

    Muchas gracias otra vez

    No uso Divi, pero lo he mirado y parece que el problema viene de Divi.

    https://www.elegantthemes.com/blog/wordpress/how-to-use-the-official-google-amp-wordpress-plugin

    Tambien vi un plugin de pago que daba compatibilidad, no lo pongo por no hacer spam, pero pon en tu buscador «divi amp» y deberias encontrarlo.

    Ahora como usas un theme comercial tengo que comunicarte que nosotros no damos soporte a este tipo de productos, ya que tiene su propio soporte y aparte nosotros no tenemos acceso.
    Conclusion, deberas contactar con ellos para que te de una solucion.

    Suerte

    Edito:
    Mirate este plugin; https://es.wordpress.org/plugins/accelerated-mobile-pages/

    • Esta respuesta fue modificada hace 1 año, 7 meses por kallookoo.
    Iniciador del debate carcargar

    (@carcargar)

    Muchas gracias¡¡ Seguiré investigando

    Un saludo
    Carmen

    Hola @carcargar

    Si consideras que tu pregunta esta resuelta marcala como resulta, asi nos ayudas en mantener el foro organizado.

    Gracias

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • El debate ‘Error AMP Google Search Console’ está cerrado a nuevas respuestas.