Soporte » Guías – Resolución de problemas » error carga www y https

  • Resuelto danibaha

    (@danibaha)


    Buenas,

    Tengo un gran problema

    He comprobado que si entro a la página web sin las WWW, es decir https://xxxxx.com la página sale bien, la alojada en mi contenido wordpress.

    Pero sorprendentemente, si acceso con las WWW, es decir https://www.xxxxx.com la página que carga es una versión que no corresponde al contenido alojado en mi wordpress, sino a algún contenido antiguo que desconozco donde está puesto que no está en mis páginas (hice una migración hace año y medio)

    El problema se acrecienta puesto que en google, si buscas mi empresa y pones EMPRESA o Empresa y salta la ficha, cuando pulsas sobre la web, al cargar google la que tiene las WWWW, sale esa incorrecta versión.

    Algo raro debe de ser puesto que como os digo esa versión no se encuentra en mis páginas que tengo creadas en WorPress, lo cual me hace no poder resolver yo el problema al desconocer la causa.

    El resumen es que la versión que aparece en https://empresa.com es la que debería de salir en todas las opciones posible, es decir la que tiene el slider con unas cebras y luego una playa azul.

    Muchísimas gracias.

Viendo 9 respuestas - de la 1 a la 9 (de un total de 9)
  • Moderador almendron

    (@almendron)

    La primera vez que veo algo así 🙂

    No solo son páginas distintas sino que una está con la versión 5.4.2 de WordPress y la otra con la versión 5.8.1

    Dices que hiciste la migración hace año y medio: ¿dentro del mismo servidor o desde otro?

    En cualquier caso, se trata de un problema relacionado con el dominio y el hosting en que nada tiene que ver WordPress.

    Mi consejo es que te pongas en contacto con el soporte del hosting para

    1) Que comprueben el problema.

    2) En última instancia, wue incluyan una redirección en el .htaccess de forma que cualquier visitante que entre con «www» sea redirigido a la versión sin «www».

    Por cierto, ya nos dirás qué te dice el soporte de tu hosting.

    Iniciador del debate danibaha

    (@danibaha)

    Buenas,

    Cuando hice la migración fue cuando me cambié de un hosting a otro, al cambiar ellos me hicieron la migración completa, pero esto debe pasar desde hace meses y ahora es cuando he detectado que es por las www.

    Me han indicado que las páginas que carga son de worpress y que el problema no está en el hosting sino en el propio wordpress, aunque les he indicado lo de las diferentes versiones, pero insisten en que el problema está en worpdress.

    Yo la página que carga no la tengo entre mis páginas creadas y he borrado caché y todo sigue igual, carga dos páginas diferentes.

    Me han indicado que van a mirarlo internamente desde el departamento de aplicaciones de WordPress, bajo presupuesto, pero insisten que es así.

    La verdad que no se que hacer puesto que no tengo ningún conocimiento para poder resolver esto.

    Si me dicen algo desde aplicaciones os avisaré, pero me preocupa bastante porque son 2 webs diferentes, hasta el propio menu.

    Gracias

    Iniciador del debate danibaha

    (@danibaha)

    Además esto solo pasa con la portada, es decir, si pongo las www me sale una web diferente que no sale en mis páginas, pero si pongo las www a una subsección, es decir en vez de http://www.xxxxxxxxx.com pongo http://www.xxxxxxxx.com/viajes-combinados ahí si me sale la versión buena, es solo con la home, por si puede servir de dato.

    Moderador almendron

    (@almendron)

    ¿Has puesto la redirección o te han dicho algo los del hosting?

    ¿Qué tienes puesto en Dirección de WordPress (URL) y Dirección del sitio (URL) en Ajustes Generales?

    Moderador Mariano Perez

    (@mpcdigital)

    Hola,

    hay que revisar lo primero en las tablas DNS que gestionen el dominio que haya una entrada de tipo A que apunte a la ip del servidor correcto y después que haya una entrada CNAME que apunte la versión www a la versión sin www. Después verificar que no hay entradas duplicadas apuntando a distintos sitios.

    • Esta respuesta fue modificada hace 1 semana, 5 días por Mariano Perez.
    Iniciador del debate danibaha

    (@danibaha)

    Buenas,

    Lo primero muchísimas gracias por la ayuda.

    Desde el Hosting me siguen indicando que el problema se debe a wordpress puesto que lo que carga procede de ahí, les he indicado lo que me habéis dicho, van a seguir comprobándolo.

    He desactivado el plugin que tenía de caché y que me iba muy bien swift performance y desde que lo he hecho las www carga como el https sin ellas….

    Ellos no han redireccionado nada… por tanto este plugin algo estaba influyendo en esto… pero me parece muy extraño.

    Otro punto raro y que me preocupa es que google, si pones en el «bahary travels» y sale toda la información, el texto y título que pone no va acorde al que yo he configurado con yoast seo, es decir, salen unos textos que google ha indexado que no son los actuales y esto solo ocurre con la home, con las otras lo que configuro en yoast seo sale en google bien indexado.

    Mi duda es que como google asociaba las www a la hora de indexar, que ahora si no vuelve a pasar, indexe lo correcto en cuanto al texto correcto.

    Aun así me preocupa que una versión de hace 1 año y que no está entre mis páginas creadas, esté por ahí circulando.

    Gracias

    Moderador Mariano Perez

    (@mpcdigital)

    Si ahora está bien entrando en Google Search Console se puede solicitar una reindexión del contenido bueno. Pero en todo caso siempre lo acabará haciendo pero puede tardar más.

    Iniciador del debate danibaha

    (@danibaha)

    Buenas,

    Cuando pongo bahary travels en google sale en la búsqueda 5 este enlace, donde se ve obviamente el error.

    Podríais eliminar el post o editar las páginas para que no lo indexe google como búsqueda de mi web ?

    Gracias nuevamente por la ayuda, he desisntalado el swift perfromance y ya no tengo ese error, aun así me extraña muchísimo todo, respecto a que usaba versiones diferentes de wordpress y porque esa página que cargaba con las www no está en mi sección de páginas.

    Gracias.

    Moderador Mariano Perez

    (@mpcdigital)

    Hecho

Viendo 9 respuestas - de la 1 a la 9 (de un total de 9)
  • Debes estar registrado para responder a este debate.