Soporte » Plugins y Hacks » Error con Gutenberg

  • Resuelto josesg95

    (@josesg95)


    Buenas tardes, saben como se soluciona el siguiente error «Fallo al actualizar. Las respuesta no es una respuesta JSON válida» que aparece al crear un bloque de medios con Gutenberg. Solicite soporte con mi hosting pero me comentan que es un error del plugin

    19-Feb-2021 17:01:02 UTC] PHP Fatal error: Uncaught Error: Call to undefined function gutenberg_use_widgets_block_editor() in /home/gqdsfdzf/public_html/wp-content/plugins/gutenberg/gutenberg.php:47

    Por mi parte ya realice las siguientes acciones pero no eh encontrado solución:
    1-Eh desactivado todos los plugin
    2-Regrese al tema básico Twenty Twenty-One
    3-Fui a enlaces permanentes y seleccione la opción «simple»
    4-Borre la cache del navegador
    5-Desinstale el plugin Gutenberg y lo volví a instalas

Viendo 8 respuestas - de la 1 a la 8 (de un total de 8)
  • Moderador almendron

    (@almendron)

    WordPress ya incorpora por defecto Gutenberg por lo que no es necesario instalar el plugin. Es verdad que este último va algo más avanzado pero no es ni mucho menos imprescindible. Prueba a desactivarlo.

    Iniciador del debate josesg95

    (@josesg95)

    Hola Almendron, incluso desactivándolo y borrando la cache persiste el error

    Moderador almendron

    (@almendron)

    1) Indica la URL para echar un vistazo.

    2) ¿Qué versión de PHP y de WordPress estás usando?

    3) Prueba a desactivar Gutemberg y a trabajar con el Editor clásico: https://es.wordpress.org/plugins/no-gutenberg/

    Iniciador del debate josesg95

    (@josesg95)

    PHP 7.2 / WP Versión actual: 5.6.1 (ya estuve volviendo a las versiones anteriores con el plugin WP Downgrade y nada)
    Con el editor clásico si se puede, pero me gustaría utilizar Gutenberg. No conozco mucho pero el editor clásico me parece un poco limitado para lo que pienso realizar

    • Esta respuesta fue modificada hace 5 días, 8 horas por josesg95.
    Moderador almendron

    (@almendron)

    ¿Con qué versión de Gutenberg estás trabajando? Si con la última (10.0.0), prueba con la versión anterior: https://downloads.wordpress.org/plugin/gutenberg.9.9.3.zip

    Iniciador del debate josesg95

    (@josesg95)

    Buenos días almendron, jaja si se pudo! muchísimas gracias. Retrocedí a la versión 9.9.1 con el plugin WP Rollback. Espero que funcione bien jeje muchísimas gracias en verdad!!

    Moderador almendron

    (@almendron)

    De nada. Un saludo.

    Nota: intenta pasar a la versión 7.4 de PHP.

    Iniciador del debate josesg95

    (@josesg95)

    Listo, actualizada a 7.4. Que pases buen dia!

Viendo 8 respuestas - de la 1 a la 8 (de un total de 8)
  • Debes estar registrado para responder a este debate.