Soporte » Guías – Resolución de problemas » Error Configuración de Impuestos

  • albersr

    (@albersr)


    Hola.

    He revisado el foro y en Internet y no encuentro solución a mi problema.

    Estoy creando una tienda y he activado las tasas de impuestos. Después he ido a las opciones de añadir distintos tipos según el país o provincia y sus códigos, tal y como viene en los tutoriales.

    El caso es que al intentar añadir una línea, pongo el código del país (ES), el valor 21 y el nombre del impuesto (IVA 21%) y al dar a «Guardar cambios», el valor del impuesto y el nombre me lo pone a 0. No se guardan los valores (he probado distintos códigos y valores).

    He desactivado todos los plugins, he desactivado el tema y he dejado Storefront, y he vaciado caché.

    No se me ocurre qué más hacer.

    Muchas gracias por anticipado.

    Un saludo.

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • Moderador Jose Luis

    (@jose64)

    Hola.

    Bienvenido al foro de soporte de WordPress.org. Te dejo el enlace a las Instrucciones de uso de los foros, ahí tienes explicada, entre otras cosas, la forma correcta de hacer una consulta. Es evidente que tienes un problema con tu instalación, quedamos a la espera de más detalles para tratar de ayudarte a solucionarlo

    Iniciador del debate albersr

    (@albersr)

    Hola Jose Luis, gracias por la respuesta.

    Disculpa, he leído el enlace de las instrucciones pero no sé qué he hecho mal al realizar la consulta. Pongo más detallados los datos, por si es eso; si no, indícame por favor qué es.

    Versión WordPress: 5.6
    PHP: 7.4
    Tema: GeneratePress: 3.0.2
    Constructor: Elementor 3.0.14 y Elementor Pro 3.0.8

    Tengo varios plugins que estoy probando, pero como decía, esto me ocurre incluso antes de instalar los plugins (aún así los he desactivado por si acaso). También probé a volver al tema Storefront, pero nada.

    Creo que eso no debería afectar tampoco, porque me ocurre desde el propio configurador de WordPress, pero no sé.

    Se me ha ocurrido probar a exportar en formato CSV con el botón que hay bajo las líneas de impuestos, modificar el archivo con Excel en el ordenador, y después importar el archivo a WordPress, y así, sí me mantiene el impuesto modificado, pero sigue sin dejarme modificar nada desde ahí.

    Si como dices, es un problema de instalación, ¿tendría que reinstalar WordPress? ¿Perdería todos los cambios del tema y Elementor?

    Gracias de nuevo.

    Un saludo.

    Hola @albersr

    ¿Has conseguido solucionar el problema?

    Yo tengo el mismo problema que tu, solo que a mi directamente no se me guarda la fila con el impuesto creado.

    Un saludo

    Iniciador del debate albersr

    (@albersr)

    Hola @ramirulo

    Pues la verdad es que no me dieron ninguna solución, pero haciendo pruebas descubrí un «apaño».

    Añadí las filas que quería con el nombre de los impuestos, exporté el archivo a una hoja de cálculo y lo descargué en el ordenador. Luego lo modifiqué en Excel y lo volví a subir a woocommerce y así sí lo guarda.

    Espero que te sirva de ayuda.

    Un saludo.

    Hola @albersr

    Te comunico que yo he conseguido arreglar mi problema y supongo que realizando la misma acción arreglaras el tuyo.

    Dirígete a la pestaña Woocommerce/Estado

    Selecciona la pestaña herramientas y ve a la opción «Verificar las tablas de la base de datos» y presiona en «Verificar base de datos»

    Creo que el problema se debe a que cuando deseas guardar algún cambio en la sección de impuestos, estos cambios no logran registrarse y guardarse en la base de datos.

    Y al parecer al revisar la base de datos mediante el método que te he indicado antes, se corrigen solas.

    ( Es importante realizar una copia de seguridad siempre antes de hacer nada, por si las moscas )

    Espero que te sirva, un saludo

    Iniciador del debate albersr

    (@albersr)

    Hola @ramirulo

    Pues muchísimas gracias por comentarlo, lo probaré a ver si es eso, porque la verdad di muchas vueltas y probé tantas cosas que ya ni recuerdo.

    Seguro que le es útil a más personas, gracias por postearlo.

    Un saludo.

    Moderador Jose Luis

    (@jose64)

    Hola.

    Efectivamente, el hecho de que no puedas guardar una opción indica que hay un error en la instalación, en el caso de WooCommerce es la que indica @ramirulo, como regla general siempre hay que hacer una copia de seguridad de la base de datos antes de manipularla, inclusive cuando usas algún plugin de optimización, porque si se produce algún error el resultado puede ser desastroso.

    Gracias por comentar cómo lo resolviste, recuerda marcar el debate como resuelto para que otros usuarios sepan que aquí tienen una solución válida.

Viendo 7 respuestas - de la 1 a la 7 (de un total de 7)
  • Debes estar registrado para responder a este debate.