Soporte » Guías – Resolución de problemas » Error en actualizacion 5.7

  • eperalta

    (@eperalta)


    Hola actualice mi sitio y tengo problemas, no puedo hacer nada trabajo con flatsome y no deja agregar nada, la actualización de woocommerce arrojo error 500 server time out, sin embargo tengo la ultima version activa

    Notice: WP_Scripts::localize ha sido llamada de forma incorrecta. El parámetro $l10n debe ser un array. Para pasar datos arbitrarios a los scripts, usa en su lugar la función wp_add_inline_script(). Por favor, visita Depuración en WordPress para más información. (Este mensaje fue añadido en la versión 5.7.0).

    La página con la que necesito ayuda: [accede para ver el enlace]

Viendo 10 respuestas - de la 1 a la 10 (de un total de 10)
  • kallookoo

    (@kallookoo)

    Hola @eperalta

    Sobre el error 500, por algun motivo la ejecucion de x script tardo mas de lo que tienes definido, normalmente casi todos tienen el mismo valor. La cuestion es como saber si fue realmente el WooCommerce u otro que esta tambien haciendo cosas.

    Sobre el notice, tienes algun plugin o el propio theme que no es compatible con la nueva version del WordPress ya que ahora fuerza un tipo concreto y algo lo llamo mal.

    Mi sugerencia si fuese posible es que restaures el WordPress (archivos y base de datos) desde algun backup que tengas y esperes para que los plugins y el theme digan que son compatibles con la 5.7

    Me ocurre exactamente lo mismo. Al actualizar a WP 5.7

    Notice: WP_Scripts::localize ha sido llamada de forma incorrecta. El parámetro $l10n debe ser un array. Para pasar datos arbitrarios a los scripts, usa en su lugar la función wp_add_inline_script(). Por favor, visita Depuración en WordPress para más información. (Este mensaje fue añadido en la versión 5.7.0). in /usr/home/nortonei.com/web/wp-includes/functions.php on line 5313 Notice: WP_Scripts::localize ha sido llamada de forma incorrecta. El parámetro $l10n debe ser un array. Para pasar datos arbitrarios a los scripts, usa en su lugar la función wp_add_inline_script(). Por favor, visita Depuración en WordPress para más información. (Este mensaje fue añadido en la versión 5.7.0). in /usr/home/nortonei.com/web/wp-includes/functions.php on line 5313

    Por si sirve de algo, he desactivado el debug en el wp-config y ya no aparece ese error.

    define(‘WP_DEBUG’, false);

    Moderador Jose Luis

    (@jose64)

    Hola @neich78

    Al desactivar el modo de depuración no resuelves el problema, solo ocultas el mensaje de aviso que te indica que tienes el problema.

    Si, correcto. Hasta que se encuentre una solución el problema sigue ahí. A ver si alguien puede añadir algo. Gracias

    senseidb

    (@senseidb)

    Alguien encontró alguna solución a este inconveniente?
    Yo también presente este problema el siguiente pagina (https://i.ibb.co/D1DcL6Z/img1.jpg)
    https://cader.sunarp.gob.pe/resoluciones/

    a mi me sale este error:

    Notice: register_rest_route ha sido llamada de forma incorrecta. A la definición de ruta de la API REST para age-gate/v1/shortcode le falta el argumento permission_callback necesario. Para las rutas de la API REST que están pensadas para a ser públicas, usa __return_true como la llamada de permiso. Por favor, visita Depuración en WordPress para más información. (Este mensaje fue añadido en la versión 5.5.0). in /home/d14cguxr9to1/public_html/wp-includes/functions.php on line 5313

    No sé como resolver esto, agradezco la ayuda.

    Hola,

    Veamos, comentais cosas diferentes la persona que inicio la consulta tiene un problema parecido pero no igual que el vuestro.
    Ahora bien por lo que comentas la solucion seria la misma, actualizarlo todo.
    El motivo porque la solucion es la misma es que algun plugin o el propio theme que usais no esta actualizado para los cambios que realizo el WordPress o incluso que su codigo este mal desde un principio.

    Por cierto desactivar el debug del WordPress no soluciona nada, como bien comenta @jose64

    Si despues de tenerlo todo actualizado seguis igual crear una nueva consulta, para ver individualmente porque sucede.

    Gracias

    • Esta respuesta fue modificada hace 6 días, 1 hora por kallookoo.

    Mira que tengo actualizado todo, el tema (kuteshop), el wodpress los plugings, lo unico que falta actualizar es un pluging de WPbakery page builder, puesto que ese venia con el tema que compre no poseo una licencia para actualizarlo, quede con la versión 6.6.0 ya le escribí a los de soporte donde compre el tema en envato, para ver si me pueden ayudar.

    Sin embargo me llego un mensaje de wordpress.org, donde me indican que el que causo el daño fue el pluging de woocommerce para facebook el cual ya desactive pero sigo igual hasta el momento.

    Quedo pendiente si me puedes dar una guía para solucionar esto, la verdad yo no soy programador, simplemente administro la plataforma porque conozco wordpress y nunca había tenido problemas.

    Gracias por tu atención.

Viendo 10 respuestas - de la 1 a la 10 (de un total de 10)
  • Debes estar registrado para responder a este debate.